Jump to content

Recommended Posts

With the release of Catalina, Apple has included a ton of localized versions of Noto Sans in its system font library. These fonts can’t be removed or disabled. I actually have the complete Noto Sans and Noto Sans Display font families installed, and it’s difficult to quickly find them now.

A way to be able to hide fonts would be extremely helpful. For the time being I’ve favorited the Noto Sans families I use but I don’t want to have to add every font to my favorite list just to avoid seeing the system fonts.

i see two ways of doing this. The first is adding a hide action next to the existing favorite one and creating a new hidden fonts tab after favorites this allows the user to still select a hidden font for use if they want to. Alternatively, placing the font list in a preference pane, using checkboxes to select fonts you want to hide, and not showing them in the UI at all. In either solution you would be choosing which fonts to hide, not which fonts to show. This way new fonts that are installed would always be immediately available.

4761E24C-D70E-429A-BB68-49E82A7A53E9.jpeg

Link to comment
Share on other sites

Why have you installed Noto for all possible scripts? It slows down starting not only Affinity software, but all other programs that load fonts on start (i.e. Word etc). Do you really need Avestan, Imperial Aramaic and Glagolitic? Uninstalling most of fonts that you will never use may help to clean the list. Personally I would install specific fonts only when I need them.

W11, Dell G5, i7, 64GB, NVIDIA GeForce RTX 2600, Wacom Intuos Pro M + iPad Pro 2018.
 sakrajda.eu

Link to comment
Share on other sites

  • 4 weeks later...

The Noto fonts come with MacOS Catalina and cannot be deleted or deactivated. See https://support.apple.com/en-jo/guide/font-book/fntb2bcb512d/mac and https://support.apple.com/en-us/HT210192

They clutter up my font list too and I would appreciate it very much when the devs would think about a clever way to hide fonts from the menu. Maybe even allow us to organise fonts in categories (serif, san serif, project X, client Y). That would save a lot of time.

Link to comment
Share on other sites

  • 9 months later...

 

See attached screenshots below:

The problem here is that these only seem to be seven actual typefaces (or even six, if you disregard the one not activated by the system) — see screenshot of Font Book below.

For some reason, though, Affinity seems to be listing each and every sub-character-set, including hieroglyphs (!) as if they were individual typefaces. 
If I'm right, this means that the bug — which really needs to be fixed! — is that Affinity lists character sets instead of typefaces.
If I'm wrong, it means that those are not subsets at all, but that Affinity lists typefaces that aren't even on my computer.
I can't really decide which one is worse — but having to scroll past some 60 fonts in the middle of the font list is a real pain.

It would be great to hear from the devs what's going on here — I see in the forums this problem dates back to at least 2017...

 

image.png

image.png

Link to comment
Share on other sites

Per Apple all of those fonts are available.

"The following fonts are installed and enabled automatically by macOS Catalina. Additional fonts are available for download or as needed by your document or app. New or updated fonts may be added over time. This list is current as of 24 April 2020."

https://support.apple.com/en-us/HT210192

So all of those fonts are "available."
Since Affinity apps on the Mac use the macOS font manager ... my guess is all these fonts are listed because they are seen as available to the apps.

Obviously that is not what you want to see happening, but how else should it be happening?
How would someone use those fonts if they cannot see them as available?
I do not use Mac so my question may seem a bit silly, but how would/should it work?

This does not appear to be the same issue as hiding installed fonts.

Link to comment
Share on other sites

  • 9 months later...

Also Typeface can do it. 

 

You can deactivate them in Typeface, but you’ll have to import them manually – takes seconds. 

1. Open Typeface
2. Choose File > Import…
3. Navigate to /System/Library/Fonts/Supplemental
4. Import the ’Supplemental’ folder

That folder contains optional system fonts, which can be deactivated by Typeface. It includes the ‘document support’ Noto fonts.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.