Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

expressoaddict

Members
  • Posts

    33
  • Joined

  • Last visited

Everything posted by expressoaddict

  1. See attached screenshots below: The problem here is that these only seem to be seven actual typefaces (or even six, if you disregard the one not activated by the system) — see screenshot of Font Book below. For some reason, though, Affinity seems to be listing each and every sub-character-set, including hieroglyphs (!) as if they were individual typefaces. If I'm right, this means that the bug — which really needs to be fixed! — is that Affinity lists character sets instead of typefaces. If I'm wrong, it means that those are not subsets at all, but that Affinity lists typefaces that aren't even on my computer. I can't really decide which one is worse — but having to scroll past some 60 fonts in the middle of the font list is a real pain. It would be great to hear from the devs what's going on here — I see in the forums this problem dates back to at least 2017...
  2. I am still three years later seeing dozens and dozens of Noto fonts appearing as soon as I install Affinity Designer on a new Mac. They are locked by the system and cannot be deleted (without, as described, me creating a new partition and installing a new instance of MacOS — please let's agree that that's quite a cumbersome, time-consuming and overly complicated thing to have to do to get rid of fonts that were installed against my will...) Please advise!
  3. Hi all, First of all sorry for double posting — I'm sorry if I made a faux pas by posting this in the bug section, but since it sits unanswered there I'm coming here for help. Here's hoping someone can explain to me what's happening (and how to stop it...) Problem: I am using a Wacom pen (intuos pro M) and love using it with Designer. I'm using a Mac. Since I have my keyboard positioned above my tablet, every time I use a keyboard shortcut or enter some text the pen rests in my hand and the back tip hovers over the tablet. For that reason, I have set the back tip functionality to DISABLED in the Wacom settings, so as not to involuntarily do something with the back tip. This works fine in every other app; the reverse tip does nothing. But. In Designer, if reaching for the keyboard so the reverse tip hovers over the tablet, I find that Designer will: 1. Almost always: Change my cursor to a circle (probably an Erase Brush, because the undo menu item changes to "undo erase brush tool" — something I didn't voluntarily select, and also something that to my knowledge should not be possible in the vector persona?) 2. Sometimes also: Add a mask layer to the current layer 3. Occasionally also: Add marching ants to the edges of the full page, as if I had performed a cmd+a on pixel layer 4. occasionally also: Show the assistant notification telling me a layer was rasterized for me. Is this by design? If so why? Why does the reverse tip of the Wacom perform stuff in Designer when globally set to off? Should I even be able to select the eraser brush in Designer without switching to the Pixel Persona? Am I missing something? All help appreciated, this is driving me somewhat crazy... /E
  4. Hi all, this just has to be a bug — I can't see it documented anywhere, nor anyway to turn it off (if intentional): I am using a Wacom pen (intuos pro M) and love using it with Designer. But. Since I have my keyboard positioned above my tablet, and I also love using keyboard shortcuts (plus of course, need to type text every now and then) both in Designer and elsewhere, I have globally disabled the "reverse tip" in the Wacom settings so as to not involuntarily invoke something as the pen rests loosely in my hand. This works fine in every other app; the reverse tip does nothing. But. In Designer, if reaching for the keyboard (so that the reverse tip hovers over the tablet) I suddenly find that Designer will: 1. Almost always: Change my cursor to a circle (probably an Erase Brush, because the undo menu item changes to "undo erase brush tool" — something I didn't voluntarily select, and also something that to my knowledge should not be possible in the vector persona?) 2. Sometimes also: Add a mask layer to the current layer 3. Occasionally also: Add marching ants to the edges of the full page, as if I had performed a cmd+a on pixel layer Is this by design? If so why? Why does the reverse tip of the Wacom perform stuff in Designer when globally set to off? Or am I missing something? Please advise! /EA. Edited to add two things: 1. I should probably mention that I’m on a Mac 2. Another “sometimes” symptom is that sometimes, the assistant notification appears telling me it has rasterized a layer for me. PS to moderators: If I ought to have posted this is the support forum rather than bugs feel free to move it; I don’t seem to be able to myself. Then again, I guess the right choice of forum depends on whether this turns out to be unintended behavior or not... 😆
  5. Thanks! For anyone running into the same problem, I think I found a workaround. Incidentally, this once again seems to relate to "resolution" — which coming from other vector apps should not really be a factor in an app like this. But to avoid the problem, here's what I did: 1. Set "scale with object" to all strokes (luckily, can be done by selecting all and checking that checkbox) 2. In the transform box, type 1000% for size 3. Convert the oversized version by selecting "expand stroke" 4. In the transform box, type 10% for size It is now correctly converted.
  6. My need: Make illustration using a pressure profile to simulate hand drawn lines Then convert those lines to outline objects, for preservation when areas are needed instead of lines (such as vinyl cutouts, or any other situation where line weights are not supported) Result: When converting lines to areas (using "expand stroke"), the exact line is not converted into areas, but weird artifacts are introduced (probably depending on incorrect interpretation of ends and joints). Questions: a. Any thoughts on how to avoid? b. This quite like being a bug, what is the best way to report it? Here or elsewhere? /LA.
  7. Well then. Complicated as it may be. Is there any way to copy stuff out of Affinity the way things can be copied out of Illustrator?
  8. Sure — but is that relevant to my problem, really? MacOS Preview does indeed render vectorized objects fine, regardless of whether it is a PDF or an SVG or something else under-the-hood. Any such vector/object based file format is a collection of objects, in which a full-resolution pic could well be embedded. No need to resize it just because we put it on the clipboard. So on one hand, you're right: It's not uncommon to enclose a bitmap (preview) of a vector illustration, together with the unaltered resolution-independent vector version, be it in a saved/exported file (such as PDF) or when copying to the clipboard. But my point is not that. My point is that when copying an illustration with an image in it, while any enclosed bitmap fallback/preview part will obviously by definition have a resolution and thus have all contents jagged if zoomed, the object/vector part should just be preserved as is — including images which should just be enclosed at its own original full resolution. Again, the reason for downscaling images in this case is none, as proven by other illustration packages. One more example — perhaps the most obvious one as to why Affinity's current model is far from ideal: Below, two screenshots. First, I create the same kind of graphic in both Affinity and Illustrator, with some native objects plus my one random pasted pic from google. Then, I copy the Affinity artwork into Illustrator, and the Illustrator artwork into Affinity. Note how Illustrator encloses all data and lets me continue to work with the unaltered material in the destination app, whereas Affinity downsamples the data and makes it useless. I don't think it's inappropriate to say Illustrator gets this right and Affinity gets it wrong.
  9. Same as when pasting from Affinity Designer — namely MacOs Preview. So: Copying from Illustrator to Preview gives another result (resolution independent) than if copying from Affinity Designer to Preview (resampled).
  10. In fact, and for comparison — doing the exact same thing in Illustrator gives me this: (sorry for another set of large screenshots below) In short, Illustrator copies the image to the clipboard like any other object, leaving for the destination app to render it to any resolution at output time. If Affinity's take is by design, I would love (well — need!) a setting to opt out of that behavior...
  11. So math aside, coming at this from any other vector based illustration software I need to say this doesn't make sense to me at all: Being an object oriented, vector-based app, it feels completely against the norm for Affinity to let the clipboard receive a rasterized-to-the-measurements-of-its-own-internal-workspace version of anything — the entire point of vector based illustration being that no rendering takes place (should take place) until actual printing/exporting to a resolution-dependent entity is performed. So just as a an elaborate bezier curve doesn't get jagged when copying it out of the app, nor should a pic get downsampled in the process. (Or, conversely, if a pasted pic will not be handed over as-is, why are not also vector objects rasterized and downsampled to that internal resolution?) Below is a graphic with some vector objects + one pasted pic, first seen in Affinity Designer, then cut-and-pasted to the MacOs Preview app. To me, it honestly makes no sense why the image is re-rasterized when nothing else is — and unfortunately, it's inconsistencies and quirks like this, where Affinity sort of seems to invent their own workflow and logic in a world where certain agreements have already been made, that stops me from dumping Adobe and switching for real. I may hate Illustrator and inDesign for a number of reasons, but none of them is unpredictability, and when things needs to get made on a deadline, clunkiness is a small price to pay for not having to struggle with unexpected results... /L.A.
  12. So here's my specific problem. I have a Designer document, into which I have pasted a nice and (reasonably) hi-res photo. Selecting the photo in Designer gives me the top-left info that its resolution is 900x1350 pixels. Very good. But if I try to copy it... ...and paste it into another app (word, preview, photoshop) this will quite unexpectedly give me 1. a letter-sized blank frame/workspace, with 2. a centered version of the photo, at very low resolution. For some reason, what's copied into the clipboard is a pdf (with its size set to portrait letter, which makes no sense since I'm cutting the photo from a landscape A4 document anyway) with a centered photo object whose resolution has been reduced to (in this case) 244x363 pixels, i.e. about a quarter of its original width and height. Is there a setting to actually copy the selected photo in its entirety to the clipboard, not as part of a pdf but as the jpg it actually is? Is this a bug or is it by design? (And if so, please explain to my why I want it...) But most of all: Please help me cut my pasted pic out of Designer and into other apps, with the original size and resolution preserved — how can I do that?
  13. Perhaps by design, but to me this is an oddity/quirk: Add a couple of photos. Say you want to mimic a classic photo, so you put a white stroke on one, and a drop shadow. Some of the photos you crop, some not. You then copy the layer effects from the first photo to the rest. Result: All parts of the stroke that goes outside of the photo bounding box will be cut on cropped photos. You CAN work around this by only using "stroke inside" — but it is a bit counterproductive since the drop shadow, while no doubt outside the cropped bounding box (correctly) stays visible. So I would suggest the paradigm should be "stroke is added to photo after crop", not "before crop and thus affected of the crop itself". Hope you see what I mean. Thanks, /Fredrik.
  14. Thank you Mike for your response/followup — and sorry for not answering sooner. I guess I'm starting to understand what's going on, and I will use this post to elaborate, but let me start with saying I think Affinity Designer has a fundamental flaw in its CMYK color handling, probably due to the fact that Affinity has its roots in bitmap graphics and thus implicitly in the RGB color model. First, to answer the questions above: I am choosing 100% black (known as K in the CMYK world) by choosing CMYK for color model and 100% black from the CMYK slider window. After that, whether I print directly or export to PDF (and thus also if exporting to PDF, then printing said PDF) the black surface will appear not solid black but rasterized (probably at about 85%K) This is not correct behavior. I attach two photos below — a 100%K square as printed to the same printers directly from Affinity Designer and directly from Adobe Illustrator. As can be seen, when printed from Affinity a 100%K comes out as a rasterized grey. The same from Illustrator becomes solid black. The problem, I believe, is this: Sure: Everybody knows 100%K isn't perfectly, deeply pitch black. BLACK ink/toner lacks the depth to create a rich, full-bodied black. This introduces problems when interpreting an RGB photo for printing with the CMYK model, since RGB(0,0,0) means perfectly black and 100%K optically really doesn't. To compensate, RGB(0,0,0) is normally printed by complementing the 100%K with some extra C, M and Y to thicken it. As a result of this, going in the other direction — i.e. converting a CMYK artwork to RGB — 100%K is often rendered only as a dark grey, since it would take 100%K + some extra CMY to make it fully RGB(0,0,0) pitch black. This is all fine and dandy. BUT. For some reason, Affinity Designer seems to be INTERPRETING a CMYK artwork when printing to a CMYK printer — and this should not be done. CMYK values should just be passed on as-is to a CMYK printer, meaning 100%K should be printed with 100% coverage from the BLACK cartridge/toner/ink. As can be seen on the print from Illustrator, that is also exactly what happens there. However, Affinity seems to be thinking "hey, 100%K isn't really black, so let's interpret it as 85% black" which is like paying tax twice: When printing just 85% coverage with the black cartridge, which you may argue already isn't optically black in itself, the blackness is reduced even further — in direct conflict with rules, logic and most importantly: the values I have chosen. So, in summary, it seems as if Affinity applies some kind of "interpretation" for CMYK values even when printing to a CMYK printer, which is incorrect behavior for a vector graphics program. Photos below. Please also note that this becomes even more visible when printing to a black-and-white laser printer — I apologize for the quality issues (stripes) due to low toner levels, but even so the square (and supposedly solid black text) come out as grey and rasterized. Whereas again, from Illustrator they don't.
  15. I did ask this before, and found myself somewhat trashed for not getting CMYK/RGB conversion. I left the forum (and finished my work in inkscape because I had to get it done) but would like to ask once again, hopefully this time someone can help me with a solution. The short question is: When working in CMYK space, assigning 100%K to an object, why is it not printed as 100%K? To reproduce: Start a new document. For settings, I choose PRINT and color format CMYK/8. For color space I'm quite sure I've been through them all, from US WebCoated SWOP vs (which I think was the default) ending with Generic CMYK. Add an object, set color to 100% K. Print. Whatever I choose, a 100%K object will be printed as rasterized (on a black and white laser printer) or grey in a PDF etc etc. What do I need to do to make Affinity treat 100%K in CYMK mode as something to print with 100%K black?
  16. Let me just close this topic by stating that if I have purchased a vector design package that does not print the same CMYK values to a CMYK printer that I have set the artwork to be, then I am the fool for thinking an app for forty bucks could do a professional job. I don't want to be rude — I have just read your bio and realize that you are not a graphics professional — but the information in your post above makes no sense at all from a professional standpoint, nor are your deductions about color handling correct. I could go back to the early days of manual color separation, when we printed four sheets of black-and-white film at the very expensive typesetter service, then exposed them onto plates, which in turn were used for offset printing onto paper. Those four sheets were the respective originals for the C M Y and K printing colors, which meant that if I gave an object a certain mix of these components, each film would represent that mix in a literal, one-to-one ratio. If my color was 20C, 30M, 40Y, 10K, then the cyan film would be 20% grey, the magenta 30% etc. This, quite simply, is how CMYK printing works. So. Designing in CMYK and printing to CMYK, I don't want any conversion to take place. If I want my blacks to be 100%K, I design my artwork accordingly. If I want something else, then that's the value I'll set. But I alone decide how black my blacks will be. In case your answer is to be considered an official contribution to this forum, I guess I'll have to go back to using apps like InkScape which, while crazily inferior in features and UI, has never once let me down in terms of printing and designing in CMYK.
  17. Perhaps at the risk of becoming crazy here... If I add an object, set the color picker to CMYK, make the object 100%K — then right there in the document what I get is an almost-black object. If I then change the color picker to RGB, it will change not to (0, 0, 0) but to (35, 31, 32). So quite obviously, Affinity Designer has decided that 100%K is a greyish color — which is also the way the object prints. I don't think I can explain it any clearer — all I do is wonder why something I set to a CMYK value won't print with those values.
  18. Both, in fact. Printing a 100%K object, either direct or from a PDF, gives me a weak, weak raster — I guess corresponding quite well to the 94% I see if exporting to RGB. So one could also say that the only way for me to print full black is to set RGB(0,0,0) and not 100% K. I'm on MacOS Sierra, printing to two different Laser printers, one Samsung and one HP. So I think you're understanding my question perfectly — I would so dearly like my CMYK objects to print at the CMYK values I set... :) So — you can choose a conversion? Is there a way to just turn it off? Or what am I not doing the way you are?
  19. I am sorry, but are you responding to my question or to one that you would like me to have asked instead? I am designing things in CMYK. When ripping such graphics to a CMYK printer no conversion shall take place. That's the beauty of vector graphics — and the difference to bitmap/raster — if working in CMYK I set the values to be printed and that's it. Color conversion may take place for display onscreen (which is RGB) but that is totally different from the ripping process. If I have a number of CMYK objects, as in Affinity Designer, they shall be ripped/printed/separated as per my settings, period. If I also add an RGB photo to my design then by all means, it — and only it — need be converted at the time of rip/printing. But not the rest. It is true that no color conversion can be exact. That is why none should take place, when I design a CYMK object and print it as such. My question, to clarify, is: Why does it? And: When conversion does take place, why is it off, so that 100%K — the blackest — isn't rendered as RGB(0,0,0) ?
  20. Thank you for understanding my initial question. Yes, this is what's odd — even printing a 100%K surface (to printer or to PDF) gives me a not-quite-black surface where it should. I can't really see why RGB conversion should be involved in the process at all here — especially of the color "completely black" which should be at the absolute end of any color model anyway. And the answer is yes — my color model is CMYK8. Which makes it even less understandable. So how does everyone else do? I surely can't be the only one using CMYK colors in Affinity Designer...?
  21. Not sure about how this answers my question yet — but here goes: The document is set to "print", and the color to CMYK/8 About color space, it doesn't matter what format I export to — 100%K turns into some lighter off-black, which I can't see why it should. I'll try to explain what I mean: 100%K should turn into #000000 regardless of colorspace — from a (line art) designer standpoint, K is as black as can be and should be treated as such. Again, designing line art using some "enhanced black" say, CMYK 222X, isn't a good idea due to the potential bleeding and misalignment that may follow. It seems to me Designer lives in a photo world, forgetting that vector graphics, designed in CMYK for print, need no color space. They are what they are. Is there any way to have Designer not handle colors at all?
  22. Hi, having worked with vector packages from the early days of Corel Draw for Windows, I consider myself having quite a grasp of coloring, CMYK values, separation for print and whatnot. But with Affinity Designer a problem is introduced that I have never encountered in any other vector app: The CMYK values seemingly being transformed using RGB color profiles and turning out something completely different from what I intended. While in other packages exporting a 100% K renders just that: complete blackness, a 100% K surface from Affinity seems to result in a greyish almost-black (and if exporting to a bitmap format, 100%K transforms into 94%.) This seems to be the case regardless of export format. Is there any documentation for how to use color values in Affinity, and how (or why) conversion takes place? Can it be turned off? Or is the CMYK color model in Affinity Designer only there as a coarse guideline, translated internally to and from RGB even if my intended use is printing? Any help and explanation greatly appreciated. (Case in point: Yes, you could argue that 100%K on paper isn't as rich and totally black as K with some percentage of CMY — but being a vector app, I want to be able to design a logo with a BLACK element — to be printed with K only — then print it as vector in complete blackness while also exporting it to, say, a web page header, with the black element still being completely black. This seems, confusingly, impossible with Affinity Designer today. Am I right?)
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.