Jump to content
IndigoMoon

Identification of Tamron lenses mounted to Canon bodies

Recommended Posts

On 12/5/2019 at 2:36 PM, IndigoMoon said:

Just as feedback for you, the automatic recognition still does't work.

But the new manual lens selection in develop is a great step forward! Thanks!

Unfortunately, as far as we can tell, this particular camera/lens combination does not give us enough information to disambiguate between the two possible lenses.

Hopefully the manual lens selection will be a good workaround for you though. This is just the kind of situation where we see it getting the most use. :) 

Share this post


Link to post
Share on other sites

This also happens with the Sigma lens mounted on a Canon.

sigma_tameron.jpg


Affinity Photo 1.7.3.481 ; Affinity Photo Beta 1.8.0.532; Win10 Home Version:1903, Build: 18362.207: Intel Core i7-4770, 3.90GHz, 32GB Ram, Nvidia GTX 645, 3-Internal HDD (1 Crucial MX5000 1TB, 1-Crucial MX5000 500GB, 1-WD 1 TB), 4 External HDD

Share this post


Link to post
Share on other sites
On 12/9/2019 at 11:32 AM, Tom Lachecki said:

This is just the kind of situation where we see it getting the most use. :) 

Thanks Tom! Yes, it's not a big deal to select manually the correct lens now. :)

Additionally, it would be great, if I could define a standard lens for such cases. So, for the next time the right body/lens combination will be selected automatcally (similar to Lightroom).

It's already fantastic to mark the correct lens as Favorites, but such a feature would be the cherry on the cake. ;)

 

Share this post


Link to post
Share on other sites
1 hour ago, IndigoMoon said:

Additionally, it would be great, if I could define a standard lens for such cases. So, for the next time the right body/lens combination will be selected automatcally (similar to Lightroom).

It's already fantastic to mark the correct lens as Favorites, but such a feature would be the cherry on the cake. ;)

Oh, that's a good idea. I'll think about it. :P

In the meantime, if you only have one body/lens combination, you can go into Develop Assistant and tell it to just always take your Most Recently Used lens profile. Then you won't even have to select the profile manually any more.

Share this post


Link to post
Share on other sites
On 12/11/2019 at 2:17 PM, Tom Lachecki said:

In the meantime, if you only have one body/lens combination, you can go into Develop Assistant and tell it to just always take your Most Recently Used lens profile. Then you won't even have to select the profile manually any more.

Hi Tom, thank you for that hint! Yes, this new option is a good solution after a shooting with just one lens :) , but you don't have to forget to disable this setting again to avoid wrong corrections with other lenses.

On 12/11/2019 at 2:17 PM, Tom Lachecki said:

I'll think about it. :P

I'm not a programmer, so I hope it's not that much work... Thanks again ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.