Jump to content
Sign in to follow this  
Wychelm

Automatic Page Numbers

Recommended Posts

Hi Mike here, a flustered old fogey. Am excited about Publisher. However, alas cannot get page numbers to automatically show on pages. Have placed text box at master pages bottom left both inside and outside of master frame margins, gone Text—insert—field—page number, got hash in box on master, no page number shows on pages. What have I done wrong please: Mac OS 10.13.6, Publisher 1.7.0.283.

Share this post


Link to post
Share on other sites
2 hours ago, Wychelm said:

What have I done wrong

Nothing that I can tell, I have had similar problems and all I did was to  reapply the Master Page to the pages. That sometimes helps after editing the Master Pages.

 


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.1 | Affinity Photo 1.7.1 | Affinity Publisher 1.7.1 | Affinity Photo Beta 1.7.2.146 | Affinity Publisher Beta 1.7.2.422

Share this post


Link to post
Share on other sites
4 minutes ago, Old Bruce said:

I have had similar problems and all I did was to  reapply the Master Page to the pages. That sometimes helps after editing the Master Pages.

Same here, using current beta as well as a number of previous.


Using macOS 10.13.6,    Publisher 1.7.1.408,    and Publisher Beta 1.7.2.420.

Share this post


Link to post
Share on other sites

Hi Mike,

This sounds like it should work, are you sure the master is applied to the page you aren't seeing the page number on?

If so, feel free to attach the file and we can take a look.


Serif Europe Ltd. - www.serif.com

Share this post


Link to post
Share on other sites

All of you, and Jon P, thank you for your time. I've had another play and still no joy: re-applied masters thank you Old Bruce and cubesquareredux, created superfluous ones, tried inside and outside the master guides, alas no result. Two grabs for consideration, the MasterB symbols in the bottom box are hashtags and I've tried different typefaces. The boxes were drawn with the text frame tool on the text bar above the main window. It has to be something simple I've got wrong?

MasterB.jpeg

MasterB_Applied.jpeg

Share this post


Link to post
Share on other sites

Drastic measures follow.

Select the pages in the far left Pages Studio. You should have a light blue outline on them. Start with the first page and click once to get the light blue out line then select page 5 while holding down the shift key. Once all are selected (blue outline) right click/control click and from the menu choose clear all masters. then apply the masters again by selecting the pages and doing the right click/control click and select Apply Masters. Choose Master B which I think is the one with the page numbers.

If that fails, or you want to instead of using drastic measures, attach the file here and we can take a look.

 


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.1 | Affinity Photo 1.7.1 | Affinity Publisher 1.7.1 | Affinity Photo Beta 1.7.2.146 | Affinity Publisher Beta 1.7.2.422

Share this post


Link to post
Share on other sites

Thanks Old Bruce. Will try that on the old file—but have got page numbers! Went new document, set up with the same number of pages, then immediately went to master and added page numbers and that works. Added baseline grid, still have numbers. The old file—followed your instructions; the weird bit is, can only see one master at a time: so, right-click on masterB and get dialogue apply masterA, with B greyed out. Try right-click on B, get A with B greyed out. applied either, no page numbers. So the old file is somehow corrupt? Perhaps, cannot add content and then page numbers? That was what I did . . . will send the file if you think it worthwhile!

Share this post


Link to post
Share on other sites
11 hours ago, Wychelm said:

Perhaps, cannot add content and then page numbers?

As a test, I created a new document with default master, then …

… added some text on page 1, then went to master page and added page number field, and …

… things seemed to work OK.


Using macOS 10.13.6,    Publisher 1.7.1.408,    and Publisher Beta 1.7.2.420.

Share this post


Link to post
Share on other sites

We never got to see the file, as it seemed quite unique to this customers file.

If you have the same issue can you attach the file and I'll take a look?


Serif Europe Ltd. - www.serif.com

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×