Jump to content
TomM1

1.7.0.112 flashing effect

Recommended Posts

When making adjustments like painting on a levels layer, some ares of the document vibrate or change intensity in a subtle flashing effect.

This happens even when hovering a brush over  the document.


Website

iMac Retina 5K 27 inch Late 2105, 3.2-i5, 32 GB Memory, AMD Radeon M380 2048 MB

Share this post


Link to post
Share on other sites

Hey TomM1,

Does this still happen if you turn off 'Show Brush Previews' from Preferences > User Interface?

If it does still happen, could you please do a quick screen recording so I can see what you are seeing?

Do you have Metal computer enabled from Preferences > Performance? 

Share this post


Link to post
Share on other sites

Turning off Show Brush Previews eliminates the effect on hover but it is still there when actually painting.

The flashing effect is less noticeable at 100%.

Metal is enabled.

This screen recording shows the hovering effect:

https://www.dropbox.com/s/5xydipl9ly97wvg/Flashing.mov.zip?dl=0


Website

iMac Retina 5K 27 inch Late 2105, 3.2-i5, 32 GB Memory, AMD Radeon M380 2048 MB

Share this post


Link to post
Share on other sites

Hey TomM1,

Thanks for the video, it was really helpful.

Anyway, what you are seeing are the rendering tiles reacting to a mouse-over. I can't see your Layers Panel however this usually occurs if you have a number of Live Filters or Adjustments in the document. 

It might seem a bit strange however this is by design as it's just the way the rendering tiles work.

Share this post


Link to post
Share on other sites

If this is by design, something is very wrong.

I have seen the rendering tiles effect, for example, zooming in and out, especially on large files.

But it stops  after the image is rendered. It's not supposed to be a continuous effect while you are working.

Again, this is while painting not just mouse over.

The image should not  flash and change while you are trying to perform simple painting strokes.

No software of this type does this.

Since this issue does not occur on an identical copy in 1.6.7, I will still assume this is a bug or 1.7 will be a step backward.


Website

iMac Retina 5K 27 inch Late 2105, 3.2-i5, 32 GB Memory, AMD Radeon M380 2048 MB

Share this post


Link to post
Share on other sites
22 minutes ago, TomM1 said:

Since this issue does not occur on an identical copy in 1.6.7, I will still assume this is a bug or 1.7 will be a step backward.

Do you have the copy from 1.6 that I can look at? I obviously cannot open a file made in the beta in 1.6 so I wasn't able to check if this was a regression. 

Share this post


Link to post
Share on other sites

PM an email address and I will send the link to the (large) file.


Website

iMac Retina 5K 27 inch Late 2105, 3.2-i5, 32 GB Memory, AMD Radeon M380 2048 MB

Share this post


Link to post
Share on other sites
7 hours ago, Chris B said:

I've made you a private Dropbox folder :) 

The 1.6 file actually has more layers than the beta file, because I started to get a bit nervous about continuing this project in beta.

Otherwise they are the same.

I have uploaded both files.


Website

iMac Retina 5K 27 inch Late 2105, 3.2-i5, 32 GB Memory, AMD Radeon M380 2048 MB

Share this post


Link to post
Share on other sites

Hey TomM1,

Thanks for uploading the files.

By the look of things, we're doing a quick low-render than performing a high-render straight after. This is causing the flickering.

I'm not sure why this doesn't happen in 1.6 but I imagine we're just rendering the screen differently (likely for performance reasons).

Turning off Brush Previews stops this from happening but this might impair you if you need to see the brush preview...

Share this post


Link to post
Share on other sites

I forgot to mention that if you go to Preferences > Performance and change Retina Rendering to High quality (Slowest) this will also stop the flickering, however you might notice panning and zooming and the general responsiveness of the document may be affected.

 

Share this post


Link to post
Share on other sites

I would suggest not displaying the low-quality render until X amount of time after starting the high quality one and discarding it if the high-quality one completes on time.

Share this post


Link to post
Share on other sites

I actually prefer brush preview off.

But the good news is that changing Retina Rendering to High quality ( was set to Automatic by default) fixed the issue in 1.7 and improved 1.6.

I don't see any issue with panning and zooming. Rendering after zooming is almost instantaneous in 1.7. 

600 mb file

 

Thanks.


Website

iMac Retina 5K 27 inch Late 2105, 3.2-i5, 32 GB Memory, AMD Radeon M380 2048 MB

Share this post


Link to post
Share on other sites
14 minutes ago, TomM1 said:

I don't see any issue with panning and zooming. Rendering after zooming is almost instantaneous in 1.7.

 

That's great :) 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×