Jump to content
Sugar Lion

Ctrl/Cmd Click to Reset all Values

Recommended Posts

I notice that some but not all settings allow for double click to reset there values. I find it odd that this is not consistent across the board. Working audio software for over twenty years Cmd/Ctrl left click is considered a standard for the most part I would say. It is a very easy way to streamline the editing process. I would love to see this. 

Share this post


Link to post
Share on other sites

In 1.7 its already for maybe the half of the sliders implemented. Remember the dev there, that they do not forget the other half!


OSX 10.13.5  / iMac Retina 27" / AMD Radeon R9 M380 / Metall: on!

Share this post


Link to post
Share on other sites
17 hours ago, Polygonius said:

In 1.7 its already for maybe the half of the sliders implemented. Remember the dev there, that they do not forget the other half!

I am using the beta, I tried a few adjustment layers and few live filters but the sliders don't reset on double clicking, alt clicking ............

Share this post


Link to post
Share on other sites

It works at least in shadow/highlights ans Whitebalance on both sliders. But general, maybe its my mouse, but a double-click seems often interpreted as singel/or 3time click... so it sometimes jumps to middle and than to the point the cursor is. Its a little bit buggy and only implemented in just a few adjustments in the moment... 


OSX 10.13.5  / iMac Retina 27" / AMD Radeon R9 M380 / Metall: on!

Share this post


Link to post
Share on other sites

Affinity sliders also lack another awesome feature: Drag (way) beyond the bounds of the slider to reset the slider to either it's last used value (either last custom value or its default value). Super helpful when playing around yet some more - nah, that doesn't look better - no need to memorize previous settings then.

I love nifty little helpers like these, because they do not interfere with the workflow of anyone who doesn't use that feature.

Share this post


Link to post
Share on other sites
52 minutes ago, Polygonius said:

It works at least in shadow/highlights ans Whitebalance on both sliders. But general, maybe its my mouse, but a double-click seems often interpreted as singel/or 3time click... so it sometimes jumps to middle and than to the point the cursor is. Its a little bit buggy and only implemented in just a few adjustments in the moment... 

In the Develop persona resetting the sliders by double clicking, works but in the Photo Persona I can't find any slider that can be reset this way.

This is really annoying because there is not a standard across the app.

Same thing here In a problem reported earlier

8 minutes ago, hifred said:

I love nifty little helpers like these, because they do not interfere with the workflow of anyone who doesn't use that feature.

True! ;)

Share this post


Link to post
Share on other sites
41 minutes ago, hifred said:

I love nifty little helpers like these, because they do not interfere with the workflow of anyone who doesn't use that feature.

Me too.  i long time ago suggested such things, like right-click for last value, or shift-doubleclick for reset ALL parameter in a box, or mouse on aslider and the left/right will step fore/back and the up-down do the same but in smaller division.... or rightclick for tools, like brushes, that opens a menu where you can select 5 favorite brushes and switch back to the last...current 5, or next in the category without the long way to brush-panel, or your 5 favorite attributes like flow / color-dynamic... rotation by 90°... 

i really hope 1.8 will focus of workflow / efficiency, there are lot of things which needs too much clicks/longways...


OSX 10.13.5  / iMac Retina 27" / AMD Radeon R9 M380 / Metall: on!

Share this post


Link to post
Share on other sites

I'll bump this up. LR uses this and makes working through the settings easier, and faster. Even though most of the dialogs have a reset button, it may reset all the sliders, when all I need to do is reset one of them.

 


Affinity Photo 1.8.5.703 ; Affinity Photo Beta 1.9.0.733); Win10 Home Version:1903, Build: 18362.207: Intel Core i7-4770, 3.90GHz, 32GB Ram, Nvidia GTX 645, 3-Internal HDD (1 Crucial MX5000 1TB, 1-Crucial MX5000 500GB, 1-WD 1 TB), 4 External HDD

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.