Jump to content

Confused by brush mask not behaving the same on desktop & iPad

Recommended Posts

Perhaps there is something that I am not understanding about the iPad vs, which I've had for a long time, but am only just trying out now.

I have a file, that I can brush a mask in and out with black and white on the desktop vs. and it behaves as expected. When I transfer the file to iPad and do the exact same thing, it behaves as if the brush is grey, whether I choose black or white.  Does anyone have any idea where I may be going wrong ... or is this a bug?

Grumpy, but faithful (watch out all you cats)

Link to comment
Share on other sites

55 minutes ago, GFS said:

Bumb on this ... where do I send the screen-recordings?

Just post it here, select Click to choose files at bottom of a new post. 


My dad always told me, a bad workman always blames their tools….

Just waiting for Ronny Pickering…..

Affinity Photo, Designer, Publisher 1.10 and 2.0 on macOS Ventura 13.3 Beta on M1 Mac Mini 16GB 1TB
Affinity Photo, Designer, Publisher 1.10 and 2.0 on Windows 10 Pro.
Affinity Photo, Designer, Publisher 2.0 on M1 iPad Pro 11” on iPadOS 16.4 beta 



The hardest link to find https://affinity.help

Link to comment
Share on other sites


I tried something similar to your file and it worked as expected, just like on the desktop version.

The only way I could get something similar to your problem was if I set the opacity of the mask layer (pressing the more button)  to 25% or similar.

Sorry if it's no help :(

Windows PCs. Photo and Designer, latest non-beta versions.

Link to comment
Share on other sites

  • Staff

Don't use just the CMYK black (K) to paint on the mask as it will not give you a true/rich (blackest) black. Set all CMYK sliders to 100% or pick the black from the RGB sliders (all to 0%) or set the Lightness to 0% in the HSL sliders instead and you should get the same result as in the desktop.

Link to comment
Share on other sites


thanks for jumping in.

The colour picker is indeed the problem, but the bug actually goes beyond that.

Obviously, you wouldn’t choose RGB sliders to change the colour from white to grey to black (3 sliders instead of 1).  But playing around with them, I find that the HSL sliders are also buggy (which is what I normally use and therefore why I tried another colour model when I found it not working correctly).  Sometimes the HSL choice is refusing to paint at all, when white is selected.  I switch to black and it’s as expected, back to white ... nothing.  In fact, right now, switching around, I can’t get HSL to paint with white.

Grumpy, but faithful (watch out all you cats)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.