Jump to content
You must now use your email address to sign in [click for more info] ×

Swatches panel: cannot delete document and app palettes [fixed]


Recommended Posts

Choosing Delete Palette from the Swatches panel hamburger menu does nothing when attempting to delete document or app palettes. 
The following dialog should appear: "Confirm Delete. Are you sure you want to delete palette named 'xyz'?"

Affects all three apps 2.3.0.2114
Don't know if it already affected the previous 2.3 betas.
Works on 2.2.1.

Ventura 13.6.1, MacBookAir M2 15"

Edited by loukash

MacBookAir 15": MacOS Ventura > Affinity v1, v2, v2 beta // MacBookPro 15" mid-2012: MacOS El Capitan > Affinity v1 / MacOS Catalina > Affinity v1, v2, v2 beta // iPad 8th: iPadOS 16 > Affinity v2

Link to comment
Share on other sites

8 hours ago, loukash said:

Choosing Delete Palette from the Swatches panel hamburger menu does nothing when attempting to delete document or app palettes. 
The following dialog should appear: "Confirm Delete. Are you sure you want to delete palette named 'xyz'?"

The option to Delete an Application Palette is greyed out so can't even be selected and as mentioned above the option to delete a Document Palette can be chosen but it doesn't invoke the Confirm Delete option.

Affinity Designer 2.4.0.2301 | Affinity Photo 2.4.0.2301 | Affinity Publisher 2.4.0.2301
Affinity Designer 1.7.3 | Affinity Photo 1.7.3 | Affinity Publisher 1.10.8
MacBook Pro 16GB, macOS Monterey 12.6.8

Link to comment
Share on other sites

1 hour ago, Hangman said:

The option to Delete an Application Palette is greyed out

Not for me on Mac. But there's no dialog to execute the command.
Although I vaguely remember there may have been a similar bug before where the default application palettes weren't deletable?

MacOS system palettes are grayed out, of course. Those are being managed via the Apple Color Picker.

MacBookAir 15": MacOS Ventura > Affinity v1, v2, v2 beta // MacBookPro 15" mid-2012: MacOS El Capitan > Affinity v1 / MacOS Catalina > Affinity v1, v2, v2 beta // iPad 8th: iPadOS 16 > Affinity v2

Link to comment
Share on other sites

11 minutes ago, loukash said:

Not for me on Mac. But there's no dialog to execute the command.

My error, I had inadvertently added a System rather than an Application Palette! 😜

Affinity Designer 2.4.0.2301 | Affinity Photo 2.4.0.2301 | Affinity Publisher 2.4.0.2301
Affinity Designer 1.7.3 | Affinity Photo 1.7.3 | Affinity Publisher 1.10.8
MacBook Pro 16GB, macOS Monterey 12.6.8

Link to comment
Share on other sites

48 minutes ago, loukash said:

Although I vaguely remember there may have been a similar bug before where the default application palettes weren't deletable?

@EmT, there is already a somewhat related bug in v2.2.x:

  1. choose "Delete" for a linked app palette
  2. click "Delete From All Apps"
  3. the app palette is deleted from this app but not from the other two apps: it remains there, unlinked, and has to be deleted individually two more times

So it only got worse in 2.3…

MacBookAir 15": MacOS Ventura > Affinity v1, v2, v2 beta // MacBookPro 15" mid-2012: MacOS El Capitan > Affinity v1 / MacOS Catalina > Affinity v1, v2, v2 beta // iPad 8th: iPadOS 16 > Affinity v2

Link to comment
Share on other sites

  • Staff

The issue "Cannot delete Document or Application Palettes, option is greyed out or prompt does not show. " (REF: AF-1108) has been fixed by the developers in internal build "2.3.0.2139".
This fix should soon be available as a customer beta and is planned for inclusion in the next customer release.
Customer beta builds are announced here and you can participate by following these instructions.
If you still experience this problem once you are using that build version (or later) please reply to this thread including @Serif Info Bot to notify us.

Link to comment
Share on other sites

  • Staff

The issue "[macOS] Deleting a linked swatch from all apps leaves swatch as unlinked in other 2 apps" (REF: AF-1111) has been fixed by the developers in internal build "2.3.0.2139".
This fix should soon be available as a customer beta and is planned for inclusion in the next customer release.
Customer beta builds are announced here and you can participate by following these instructions.
If you still experience this problem once you are using that build version (or later) please reply to this thread including @Serif Info Bot to notify us.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.