Jump to content
You must now use your email address to sign in [click for more info] ×

Designer V2 glitching out on my rotated (portrait orientation) monitor?


Recommended Posts

Working with my monitor turned to portrait. Designer is rotating everything to horizontal, but when I move to screen capture it, it will force it back to how it should look. The dark gray area is cut off halfway and then its dark black. So I'm not sure but it seems like it wants to be on a landscape monitor? When I screenshot it, the dark part won't show up.

 I can't take a screen recording because as soon as I try, it will actually forces designer to work properly again (??). Likewise it looks how it should if another app is selected (and designer is in the background - screenshot attached).

 

Does anyone else have this issue?

V2 updated. Macbook Pro m2 max.

Screenshot 2023-09-21 at 5.44.05 PM.png

Link to comment
Share on other sites

I'm dumb - I realized I could use my phone camera to show what's going on. Attaching a photo and a video.

When I'm using other apps it'll appear normal, but when I go in and try to work it goes back to the weird horizontal glitch. Photoshop and other apps are working fine. I've updated to the latest OSX, restarted computer and all apps.

IMG_4785.JPG

Link to comment
Share on other sites

1 hour ago, bwackv said:

Working with my monitor turned to portrait. Designer is rotating everything to horizontal ...

What happens if you rotate the doc/canvas?

☛ Affinity Designer 1.10.8 ◆ Affinity Photo 1.10.8 ◆ Affinity Publisher 1.10.8 ◆ OSX El Capitan
☛ Affinity V2.3 apps ◆ MacOS Sonoma 14.2 ◆ iPad OS 17.2

Link to comment
Share on other sites

@v_kyr that will rotate the canvas but the problem of the black and the wonkiness persists. It was actually working for awhile this morning and now I've come back and the computer was asleep, and when it woke up it was back to doing the same thing as the video and image above. Can anyone help?

Link to comment
Share on other sites

1 hour ago, bwackv said:

that will rotate the canvas but the problem of the black and the wonkiness persists.

How does the Dell behave with other macOS apps in portait orientation mode, I assume it works well for other apps?

1 hour ago, bwackv said:

It was actually working for awhile this morning and now I've come back and the computer was asleep, and when it woke up it was back to doing the same thing as the video and image above.

How is the monitor connected to the MBP, via Thunderbolt/USB-C or via HDMI, or some DP capable adapter/hub/dock?  Since AFAI recall mac silicon hardware has a tendency, via USB-C ports, after a sleep mode and so during a wake up again, to not resync always correctly with external monitors. I saw this effect via external LG 4K monitors connected via USB-C and so via a mac thunderboldt port.

However, in case ADe messed up some of it's internal prefs monitor and orientation related setting here, perform an ADe reset and tryout/look how it behaves then afterwards (without MBP sleep mode).

 

☛ Affinity Designer 1.10.8 ◆ Affinity Photo 1.10.8 ◆ Affinity Publisher 1.10.8 ◆ OSX El Capitan
☛ Affinity V2.3 apps ◆ MacOS Sonoma 14.2 ◆ iPad OS 17.2

Link to comment
Share on other sites

@v_kyr Everything else is working just fine with the rotated monitor. I am attached via HDMI.

I performed the resets and it is still behaving all wonky. Such a huge bummer here because I am going to have to switch back to photoshop. Is there anyone else who has experienced this? Or any other ideas?

Link to comment
Share on other sites

33 minutes ago, bwackv said:

Everything else is working just fine with the rotated monitor. I am attached via HDMI.

Via HDMI & DisplayPort the USB-C hardware connection problems I mentioned above usually don't exist under macOS. And if every other macOS app behaves just fine in monitor pivot mode, I believe it's more an Affinity app problem/bug. - You can file in a bug report related to this "when in monitor pivot mode" behaving here ...

... so that it will be checked and hopefully fixed.

☛ Affinity Designer 1.10.8 ◆ Affinity Photo 1.10.8 ◆ Affinity Publisher 1.10.8 ◆ OSX El Capitan
☛ Affinity V2.3 apps ◆ MacOS Sonoma 14.2 ◆ iPad OS 17.2

Link to comment
Share on other sites

3 minutes ago, bwackv said:

No way to get a second pair of developer eyes on this in the forums? Seems like I can't be the only one here?

By developers it will mostly only be recognized when posting it here -> V2 Bugs found on macOS. - Other than that, if some other forum people/users are also used or tried out ADe on an external monitor in pivot mode, they can tell you probably their experiences here in this regard.

 

9 minutes ago, bwackv said:

In the meantime, do you know where I can go to get a refund on affinity? I can't use the app with this bug...

For that look after threads about that theme ...

... etc.

☛ Affinity Designer 1.10.8 ◆ Affinity Photo 1.10.8 ◆ Affinity Publisher 1.10.8 ◆ OSX El Capitan
☛ Affinity V2.3 apps ◆ MacOS Sonoma 14.2 ◆ iPad OS 17.2

Link to comment
Share on other sites

Is anybody else using the Affinity apps in a monitor pivot (vertical portrait) mode on a Mac (or Win PC) and can share his experiences here about the apps behavior then?

☛ Affinity Designer 1.10.8 ◆ Affinity Photo 1.10.8 ◆ Affinity Publisher 1.10.8 ◆ OSX El Capitan
☛ Affinity V2.3 apps ◆ MacOS Sonoma 14.2 ◆ iPad OS 17.2

Link to comment
Share on other sites

On 9/25/2023 at 12:59 PM, v_kyr said:

Is anybody else using the Affinity apps in a monitor pivot (vertical portrait) mode on a Mac (or Win PC)

Nope, but the first thing I would try is switching off Hardware Acceleration and fiddling with the Metal/OpenGL? stuff that is on a Mac

 

To save time I am currently using an automated AI to reply to some posts on this forum. If any of "my" posts are wrong or appear to be total b*ll*cks they are the ones generated by the AI. If correct they were probably mine. I apologise for any mistakes made by my AI - I'm sure it will improve with time.

Link to comment
Share on other sites

Hi. I have tested on both my displays on 90º, 180º and 270º  rotation and I had no issues at all. I checked with the three Affinity apps and all work like it should.

Also checked with Metal and OpenGL render engines.

Used Affinity apps 2.2 version. With MacOS Sonoma on a m2 mac mini.

Sorry not being able to add more light on the issue.

 

Link to comment
Share on other sites

16 hours ago, Daniel Gibert said:

Hi. I have tested on both my displays on 90º, 180º and 270º  rotation and I had no issues at all. I checked with the three Affinity apps and all work like it should.

Also checked with Metal and OpenGL render engines.

Used Affinity apps 2.2 version. With MacOS Sonoma on a m2 mac mini.

Thanks for the infos!

What displays (brand & model) do you have in use, the OP uses some sort of Dell model here?

Don't know which concrete macOS version the OP uses (Ventura or Sonoma), but I can imagine that the latest Sonoma might probably also got some enhancements or fixes here related to external monitor connections.

Further some monitor vendors do also offer some additional window regions/positioning driver software (especially for ultra wide screen models), which when used in conjunction could maybe (?) conflict with Affinity apps.

☛ Affinity Designer 1.10.8 ◆ Affinity Photo 1.10.8 ◆ Affinity Publisher 1.10.8 ◆ OSX El Capitan
☛ Affinity V2.3 apps ◆ MacOS Sonoma 14.2 ◆ iPad OS 17.2

Link to comment
Share on other sites

4 minutes ago, Daniel Gibert said:

An LG HDR 4K on HDMI and a Peaq PMO-S243-VFC FHD on USB-C.

Thanks. - And the USB-C connected one doesn't have any wake on syncing problems over the Thunderbolt/USB-C port, so you are probably using a dedicated MacMini USB-C and not a Thunderbolt here or?

☛ Affinity Designer 1.10.8 ◆ Affinity Photo 1.10.8 ◆ Affinity Publisher 1.10.8 ◆ OSX El Capitan
☛ Affinity V2.3 apps ◆ MacOS Sonoma 14.2 ◆ iPad OS 17.2

Link to comment
Share on other sites

17 minutes ago, Daniel Gibert said:

Nope. It works flawlessly. It is connected directly to the mac to prevent hub issues.

Interesting, I've seen continiously reproducable (re)syncing problems under Ventura with some LG monitors here, when they are connected via their USB-C port (the monitor's own USB-C and internal hub port) to some M2 macbook thunderbolt port. The LGs always loose their connectivity when macbooks are rebooted or do wake up from sleep, so the LG monitors don't get any signals and have to be resetted or reconnected in order to be again recognized.

I should add, that when the LGs are connected over HDMI or DisplayPort instead of USB-C, this loosing sync connection doesn't happen (AFAI can tell).

☛ Affinity Designer 1.10.8 ◆ Affinity Photo 1.10.8 ◆ Affinity Publisher 1.10.8 ◆ OSX El Capitan
☛ Affinity V2.3 apps ◆ MacOS Sonoma 14.2 ◆ iPad OS 17.2

Link to comment
Share on other sites

  • Staff

Hi @Calvert

Is this repeatable? 

The auto brightness issue I was referring to is something that can specifically affect MacOS. It's very unlikely to be the source of your issue.

If you are able to repeat this issue, could you please list your computer's specs [OS version, CPU, GPU, RAM]

Lee

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.