Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Pinch to zoom not working on MacBook Pro

Recommended Posts

I have a 2021 M1 Mac running macOS 12.2 (the current version of macOS). On the built-in trackpad, the two-finger, pinch-to-zoom functionality works fine within Apple apps (e.g., Safari) and with all the non-Apple apps I use, with one exception: Affinity Designer. Pinch-to-zoom does not work when using Affinity Designer. Is there a setting somewhere within Affinity Designer that I have to turn on to activate pinch-to-zoom?

Probably not relevant, but I will mention that I also have a 2015 Intel Mac running macOS 11.6 (Big Sur), and pinch-to-zoom works fine when using Affinity Designer on that machine.

Link to comment
Share on other sites

Check the AD Preferences settings for ...

Tools options:

  • ...
  • Choose whether the middle mouse button will allow scrolling or zooming.
  • Choose whether dragging with the Zoom Tool zooms around the cursor (scrubby zoom) or creates a 'zoom to' marquee.
  • Choose if the canvas can be rotated using a Trackpad or not.
  • Choose if the canvas can be rotated using a scroll wheel or not.


☛ Affinity Designer 1.10.5 ◆ Affinity Photo 1.10.5 ◆ OSX El Capitan

Link to comment
Share on other sites

  • Moderators

Hi @pomme27,

Sorry to hear you're having trouble!

I have tested this here using an M1 Macbook Air and this feature is working as expected for me - both 'pinch' zooming & double tap 'smart zoom' within Affinity Designer.

Can you please confirm the exact model of M1 mac you are running? What are your settings under System Preferences > Trackpad > Scroll and Zoom?

Many thanks in advance :)

Link to comment
Share on other sites

  • 1 month later...

I've also had this happen to me.

I've had pinch / spread gesture to zoom in / out regularly stop working on Affinity Publisher, but there turning the scroll and zoom setting in preferences on/off fixed it. However, on Af Designer this time, it didn't work. Restarting the app didn't work either.

Chip Apple M1 Pro, 16-inch 2021 MBPro


Link to comment
Share on other sites

  • Moderators

Thanks for letting me know @Lukc666 & I'm sorry to hear this function occasionally stops working for you!

I'll be sure to log this with our QA team, to see if we can replicate this behaviour here and hopefully reduce the frequency of this.

I hope this helps :)

Link to comment
Share on other sites

  • 4 months later...
  • 2 months later...

This is most likely a macOS-based issue that cannot be solved by the Affinity devs. After upgrading my system from Catalina to Ventura, I get the same behavior. It’s annoying. Make-shift fixes to try:

  • In Terminal, restart the dock process: killall dock — does not work for me
  • Uncheck and recheck the Pinch to Zoom checkbox in System Preferences > Trackpad — works reliably for me
  • Enable three-finger swipe-up for Mission Control and use this gesture to reactivate Pinch to Zoom — seems to work sometimes, more experimental data needed
  • Start the screen saver — never tried this, more experimental data needed





Link to comment
Share on other sites

I experienced similar issues with the Zoom controls in Publisher v.2 (and I assume that it would have been the same in Designer v. 2 and Photo v. 2, as well), however, following the instruction for accessing System Preferences and toggling the Zoom options Off/ON corrected the problem. 

FYI: I have a 2017 MacBook Pro and had just updated to Ventura (Mac OS 13.0.1). Prior the update the issue was non-existent.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.