Jump to content

Can't export anything under 1.10.3 + Monterey


Recommended Posts

Ever since i upgraded to Monterey and downloaded the new Affinity Version i cannot export anything anymore in any Affinity App. Needless to say this is CATASTROPHIC. I essentially cannot do my work anymore! The rollback to the older version of affinity didnt change anything either and that means i would have to downgrade the OS, which would take forever!

iMac (Retina 5K, 27-inch, 2017), 4,2 GHz Intel Core i7, 64 GB 2400 MHz DDR4, Radeon Pro 580 8192 MB, ROG PG348Q

Link to comment
Share on other sites

9 minutes ago, farbenfeuer said:

Ever since i upgraded to Monterey and downloaded the new Affinity Version

Did you run the older version on Monterey or did you upgrade to Monterey, then updated the Affinity apps, and only then noticed the problem? (I'm asking because I happened to have 1.10.3 updated first and run without problems on Big Sur, then upgraded to Monterey, and I have not noticed problems so far; I have an M1 chip so that might have effect on this, too. Do you mean that PDF exports are broken, or also raster exports?

Link to comment
Share on other sites

I first upgraded the affinity suite, then updated to monterey, then tried downgrading the affinity suite to the version bevor.

Cant export anything. The dialog pops up and i can set everything as usual, but as soon as i click export nothing happens.

iMac (Retina 5K, 27-inch, 2017), 4,2 GHz Intel Core i7, 64 GB 2400 MHz DDR4, Radeon Pro 580 8192 MB, ROG PG348Q

Link to comment
Share on other sites

15 minutes ago, farbenfeuer said:

I first upgraded the affinity suite

Did you run 1.10.3 on the old system (including exporting) before upgrading to Monterey? I am just trying to eliminate the effect of one or the other, since I did not have problems with 1.10.3 on Big Sur, but I have not found Monterey to cause problems with any of the apps that I have installed, either. When you export, can you see calculation of the estimated file size and information on whether anything will be rasterized? If you do, this might be related to some file privilege or save location problem -- when you click Export, do you get the dialog asking the save location? Or does the inactivity follow only after having specified the save location and starting the export? Do you have any problems "saving as" opened documents to locations where you are exporting?

Link to comment
Share on other sites

I dont think i tested exporting on before i also upgraded to monterey. 

 

Yes i can see the calculation of estimated file size

Nothing happens after clicking export. The export dialog just disappears but where the dialogue for where to export the file to should appear, nothing happens. It doesn't freeze or anything either. 

Saving the affinity changes works fine, but doing "save as" doesnt work either.

With your hint i tried setting up "full disc access" for affinity designer and it still wont export.

iMac (Retina 5K, 27-inch, 2017), 4,2 GHz Intel Core i7, 64 GB 2400 MHz DDR4, Radeon Pro 580 8192 MB, ROG PG348Q

Link to comment
Share on other sites

Do you experience these problems with any other apps? Do you mean that when you try to "save as" you do not get any dialog box at all, or that trying to save as to any location fails? If this is just an Affinity app issue, it might be that the app tries to access the "last used" location which is not available at the moment (e.g. network share or cloud drive), and therefore fails to display the dialog for specifying the location of file to be exprted or saved as...

Btw, did you upgrade to Monterey from BigSur or from an earlier version? 

Link to comment
Share on other sites

As i said - No Dialog box at all. And actually yes, other apps like PS seem to have the same problem. In PS just nothing happesn when clicking save. Export dialog stays open, but when i click Save, nothing happens. So im guessing this emphasizes it to be more of a OS problem, than Affinity. Do you have any idea what it could be? 

I upgraded from the last version of Big Sur.

iMac (Retina 5K, 27-inch, 2017), 4,2 GHz Intel Core i7, 64 GB 2400 MHz DDR4, Radeon Pro 580 8192 MB, ROG PG348Q

Link to comment
Share on other sites

Ok this is actually weird: So i tested more apps to be sure and it seems like Affinity photo and Adobe Illustrator are fine whereas Designer, Publisher and Photoshop are not.

So then im kinda clueless why that is...

Edit: InDesign is fine too. So then i tried opening files i usually did in designer with photo and tried exporting, which seems to work fine.

And google doesnt give me anything about this issue either. Kinda helpless here... :/

iMac (Retina 5K, 27-inch, 2017), 4,2 GHz Intel Core i7, 64 GB 2400 MHz DDR4, Radeon Pro 580 8192 MB, ROG PG348Q

Link to comment
Share on other sites

9 hours ago, farbenfeuer said:

And google doesnt give me anything about this issue either. Kinda helpless here... :/

Yes, I tried that too. There are instructions related to reverting default user access privileges using Terminal, but I would not go for it (other than as last resort). But this kind of qualitative behavior (app-dependent) is odd, unless it could somehow be related to "last accessed location" in different apps and that would be e.g. network share or a cloud drive. So I would probably check next that you have clear access to those kinds of addresses that you have previously used with Big Sur. 

Link to comment
Share on other sites

I dont think its that. My network was reachable and besides that i pretty much always save on my disk in specific client folders. MIght have no choice but to rollback -.-

iMac (Retina 5K, 27-inch, 2017), 4,2 GHz Intel Core i7, 64 GB 2400 MHz DDR4, Radeon Pro 580 8192 MB, ROG PG348Q

Link to comment
Share on other sites

So for everybody that has the same Problem: Apparently it has to do with external Monitors. For me, if i disable the monitor it works. Some seem to have success with resetting the SMC on mac. I didnt though.

iMac (Retina 5K, 27-inch, 2017), 4,2 GHz Intel Core i7, 64 GB 2400 MHz DDR4, Radeon Pro 580 8192 MB, ROG PG348Q

Link to comment
Share on other sites

  • 2 weeks later...
3 hours ago, Jelle said:

I'm having the same issue with 1.10.4 Affinity Designer and Monterey 12.0.1

Have you tried the 1.10.5.1 beta? 

https://forum.affinity.serif.com/index.php?/topic/152500-affinity-designer-customer-beta-11051/

 

 

Affinity Photo 1.10.5, Affinity Designer 1.10.5, Affinity Publisher 1.10.5;  2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.10.5.280 & Affinity Designer 1.10.5 for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 15.0.2

Link to comment
Share on other sites

See related on the Apple support pages ...

☛ Affinity Designer 1.10.5 ◆ Affinity Photo 1.10.5 ◆ OSX El Capitan

Link to comment
Share on other sites

Same here. Affinity Publisher 1.10.4 (fresh installed on a new machine) Monterey 12.0.1 / MacBook M1 Pro 16mb / 

Export: shows you the file options panel, upon clicking export.. box vanishes.. then nothing.

Save as Package: After Summary box, the next box pops up, but all black.. // Command "." does cancel the box / keyboard 'Enter' pops up the normal message asking that it needs an empty folder, etc. // So this one is functional, but just 'blacked out' 

@ Serif. A speedy fix is very much appreciated.

Screen Shot 2021-12-01 at 22.50.21.png

Link to comment
Share on other sites

1 minute ago, eff said:

Same here. Affinity Publisher 1.10.4 (fresh installed on a new machine) Monterey 12.0.1 / MacBook M1 Pro 16mb / 

Export: shows you the file options panel, upon clicking export.. box vanishes.. then nothing.

Save as Package: After Summary box, the next box pops up, but all black.. // Command "." does cancel the box / keyboard 'Enter' pops up the normal message asking that it needs an empty folder, etc. // So this one is functional, but just 'blacked out' 

@ Serif. A speedy fix is very much appreciated.

Screen Shot 2021-12-01 at 22.50.21.png

Yep!  Welcome to my world.

 

 

 

Link to comment
Share on other sites

Fix for "Export" and "Package" issue

In Monterey, the culprit is your second monitor setting as Main Display

  • Go to your Mac Preferences
  • Displays / Display settings...
  • Set your MacBook as default monitor.
  • Set external monitor as Extended display

This will bring Affinity back to normal 

Edited by eff
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.