Jump to content

Grid gutter decimal places limited to 3


Recommended Posts

Hi everyone,

I set up a custom grid with the spacing set to a value with 6 decimal places.

My problem is, that I can't have the same precision of 6 decimal places for the gutter parameter, which is limited to 3 decimal places.

For my custom grid to work properly I need at least 4 decimal places.

 

Now I'm not sure, if this is a bug or if that is an intentional restiction, but it's confusing because it renders the precision of the spaceing useless if the gutter can't match it.

 

I created a screenshot to show the problem.

I made sure that in settings > user interface > decimal places for unit types: is set to 6 for every unit type

I typed the value 0,123456789 in both flieds (spacing and gutter).

In spacing it was correctly rounded to 0,123457

In gutter it was only rounded to 0,123

1497739329_Bildschirmfoto2021-05-26um11_00_06.thumb.png.0a1bd9e21cc6593bde32e26ff19bcec8.png

It would be very helpful if the gutter decimal places could be extended to 6.

Thank you

Luca

 

Tested with
Affinity Publisher 1.9.2
Affinity Publisher 1.9.4 (1076)

on

macOS 11.4
MacBook Pro (15 Zoll, 2019)

 

 

Link to comment
Share on other sites

  • Moderators

0,123456789 displayed to 3 decimal places is 0,123 so it is already correctly showing the number you have typed.

The value is STORED for both fields is 0,123456789 so there is very little problem here other than you wanting to know it has stored it as you typed it. 

We can request that this field is displayed to the same number of decimal places, but rest assured it is storing and acting on the value you typed.

Patrick Connor
Serif Europe Ltd

"There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon

 

Link to comment
Share on other sites

Hi @Patrick Connor,

thanks for the quick reply, you are right, the value is correctly stored. What must have confused me is the rendering of the grid.

I attached a video to show the grid rendering confusion.

In the beginning the gutter is set to 0, then I paste the exact location of my object and then the rendering of the grid makes it seem like there is a rounding error, because the lines don't align, but then I discovered if I play around with the decimal place numbers the rendering of the grid is not correct or precise enough.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.