Jump to content
You must now use your email address to sign in [click for more info] ×

PDF pass through and fonts not being embedded


Recommended Posts


I've noticed on that we had a couple of ads, and I am providing one of them, that the fonts that are embedded in a PDF are not passing through correctly in Publisher. This was on 1.9.2

Paulding Carnegie Lib HW 2x2 14.pdf


I know there was a new update, but I'm not sure what is going on. The PDF shows the font embedded.

I had caught and fixed another ad that did this too. This one I missed before going to print.




Link to comment
Share on other sites

Your screenshot shows what I would expect to see if subsetting is enabled. Because the embedded font is missing the glyph for the ‘ti’ ligature you’re getting a ‘Ć’ glyph instead.

Disabling subsetting (i.e. forcing the entire font to be embedded) should fix the problem.

On a side note, it would be more consistent to have the times both stated as ‘{start} to {end}’ or ‘{start} till {end}’ rather than one of each.

Alfred spacer.png
Affinity Designer/Photo/Publisher 2 for Windows • Windows 10 Home/Pro
Affinity Designer/Photo/Publisher 2 for iPad • iPadOS 17.3.1 (iPad 7th gen)

Link to comment
Share on other sites

Can you provide the .afpub document, and the PDF it includes, too?


-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.3, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.3

Link to comment
Share on other sites

Here is the PDF - page 11. WBNews14-21.pdf

Here is the AFPUB file: 

Alfred - I would not expect that to happen, as it doesn't in other programs. I have been dealing with embedded fonts for nearly 20 years with Indesign. Subsetting is common and the correct way when fonts won't allow the full embedding. All characters that are used are embedded and nothing else. I believe this to be a bug if it doesn't put in the ligature.

thanks for you help!


Link to comment
Share on other sites

On 4/14/2021 at 2:10 PM, Bryce said:

fonts that are embedded in a PDF are not passing through correctly in Publisher.

When I place in v.193 your Paulding.PDF and Klopfenstein.PDF as Passthrough + export them with preset "for print" (all fonts & subset) I get both the ligature 'ti' and the Garamond font successfully. That makes me wonder what were your export settings in the 'More' section? Or whether your macOS 10.15, respectively its Quartz PDFContext "Build 19H524 ApendMode 1.1" might influence the issue?

v193 paulding-ligature & klopfenstein-font.pdf


macOS 10.14.6 | MacBookPro Retina 15" | Eizo 27" | Affinity V1 only

Link to comment
Share on other sites

The Klopfenstein pdf was made in Indesign several years ago. What's funny is that it's not noticeable until it's exported. Affinity shows it correct. It's only once it is exported that is wrong. I have my own preset on it that is the "for print" modified to include PDF/X4 compliance, otherwise it get a lot of blacks turn to a CMYK mix on the second export. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.