Jump to content
Jesse Morris

Is this a bug? Group selection doesn't work in outline mode

Recommended Posts

I think this is a change in 1.9.

I'm used to and expect groups to behave the way the documentation says:  If you click on any of it it will select the group, and you can option-click or double click to select internal elements.  This DOES work normally with 1.9. However, when I switch to Outline Mode, it seems to stop working - clicking inside a group just selects the single element.

Steps to reproduce:  New document, make two squares, group them, clear selection, click on one (group is selected).  Go into outline mode, clear the selection, and click on a square. (Just the single square is selected)  Leave outline mode, and things go back to working normally.

This is neither the behavior I expect nor want, so I think it is bug.

Share this post


Link to post
Share on other sites

I would hazard a guess this is by design.

You could use split view with Outline on one side and pixel view on the other.

image.png.a942649a26bc25657bf69e3cf5d7b1f2.png


iMac 27" Late 2015 Fully Loaded, iMac 27" Mid 2011 both running High Sierra 10.13.6 - Affinity Designer/Photo & Publisher - Illustrator CC, Inkscape, Blender, Sketchup, Pepakura Designer, MTC, Pixelmator & Pixelmator Pro + more... XP-Pen Artist-22E, - iPad Pro 12.9 B|  

Affinity Help - Affinity Desktop Tutorials - Feedback - FAQ - most asked questions

Share this post


Link to post
Share on other sites

Why would this be deliberate?  I don't understand why I have to choose between being able to see my low-contrast or light stroke stuff, and having the main purpose (in my use) of groups enabled. I do a lot of design for laser cutter stuff, so I often have large shapes (or groups) with a very light stroke, so outline view has been very useful to me in previous versions. Which I think didn't do this.

I tried what you suggest and it mostly works, though when the group is half in outline and half in vector sometimes clicking the vector side selects just a constituent object, though most of the time it selects the group.  That is very strange.  Anyway, after I figured out what was going on, just toggling outline view with the hotkey is easy enough, and honestly easier than sliding the divider back and forth.

Share this post


Link to post
Share on other sites
59 minutes ago, firstdefence said:

I would hazard a guess this is by design.

This would be strange, because the difference between Layer and Group is declared in the way all other members of the group are selected, see for example here:

 

 

I therefore agree that there is no reason for different selection behavior.

21 minutes ago, Jesse Morris said:

Why would this be deliberate?  I don't understand why I have to choose between being able to see my low-contrast or light stroke stuff, and having the main purpose (in my use) of groups enabled.

 


Affinity Store: Affinity Suite (ADe, APh, APu) 1.8.5.703.
Windows 10 Pro, Version 20H2, Build 19042.610.
Dell Latitude E5570, i5-6440HQ 2.60 GHz, 8 GB, Intel HD Graphics 530, 1920 x 1080.
Dell OptiPlex 7060, i5-8500 3.00 GHz, 16 GB, Intel UHD Graphics 630, Dell P2417H 1920 x 1080.
Intel NUC5PGYH, Pentium N3700 2.40 GHz, 8 GB, Intel HD Graphics, EIZO EV2456 1920 x 1200.

Share this post


Link to post
Share on other sites

When I activate outline mode it is mostly to select a single object that I find it hard if not impossible to see and select in normal view mode (in a drawing with hundreds of overlapping objects), so I am very grateful that this difference between normal and outline mode exist. I think it is deliberate.


  • "The user interface is supposed to work for me - I am not supposed to work for the user interface."
  • Computer-, operating system- and software agnostic; I am a result oriented professional. Look for a fanboy somewhere else.
  • “When a wise man points at the moon the imbecile examines the finger.” ― Confucius
  • Not an Affinity user og forum user anymore. The software continued to disappoint and not deliver.

Share this post


Link to post
Share on other sites

My apologies for the delayed response here all!

On 2/8/2021 at 4:27 AM, Jesse Morris said:

If you click on any of it it will select the group, and you can option-click or double click to select internal elements.  This DOES work normally with 1.9. However, when I switch to Outline Mode, it seems to stop working - clicking inside a group just selects the single element.

I have confirmed with our developers that this behaviour is to be expected in Outline view mode;

"Outline mode shows you all the curves and this has different selection semantics to try to help you click to select something, no matter where it is or what it’s obscured by."

I hope this clears things up :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.