Jump to content

Recommended Posts

Brand new Mac Mini M1.  Very first thing I installed was the three Affinity apps I purchased from the App Store.  Once installed, upon launch, I noticed a very long delay before the app appeared.  I closed and relaunched and launch time was normal (2-3 seconds).  I rebooted and launched again.  On the first launch, each of the apps takes 17 seconds to launch.  Tested again and again with same results, each time rebooting and then launching apps.

I then compared launch time of the same App Store apps on my Intel Mac.  4 seconds, consistently for all the apps.

Someone on another forum mentioned something about OCSP and App Store apps, so I decided to try an experiment -- I downloaded  and installed trial versions of the three Affinity apps directly from the Affinity site.  Surprisingly, all the apps launch 2-3 seconds every time.  So, it does seem something is wrong with the App Store apps at first launch of session.  I'm guessing on the first launch, once an App Store app has been approved by OCSP, it doesn't make that check again during that session and is why it launches normally after the 1st try?  (just guessing, I have no idea...)

Just to be clear, the time it takes once the app is clicked and when the splash screen appears is 17 seconds.  Crazy long!

Anyone have any ideas how to rectify this?  

 

Link to post
Share on other sites

See for example:

Quote

...

Does This Happen Every Time You Launch an App?

Your Mac remembers these responses for a period of time. On November 12, 2020, responses were cached for five minutes; in other words, if you launched an app, closed it, and launched it again four minutes later, your Mac wouldn’t have to ask Apple about the certificate a second time. However, if you launched an app, closed it, and launched it six minutes later, your Mac would have to ask Apple’s servers again.

For whatever reason—perhaps due to changes in macOS Big Sur—Apple’s server was swamped and became very slow on November 12, 2020. Responses slowed down considerably, and apps took a long time to load as Macs patiently waited for a response from Apple’s slow server.

After that event, Apple’s OSCP server now tells Macs to remember certificate validity responses for 12 hours. Your Mac will phone home and ask about a certificate every time you launch an app—unless you’ve received a response in the last 12 hours, in which case it won’t need to. (The information about time periods here comes from independent app developer Jeff Johnson.)

What If a Mac Is Offline?

The OCSP check is designed to fail with grace. If you’re offline, your Mac will silently skip the check and launch apps normally.

The same is true if your Mac can’t reach the ocsp.apple.com server—perhaps because the server address has been blocked on your network at the router level. If your Mac can’t contact the server, it skips the check and immediately launches the app.

The problem on November 12, 2020 was that while Macs could reach Apple’s server, the server itself was slow. But rather than silently failing and getting on with launching an app, Macs waited a long time for a response. If the server had been down completely, no one would have noticed.

...

 

☛ Affinity Designer 1.9.3 ◆ Affinity Photo 1.9.3 ◆ OSX El Capitan

Link to post
Share on other sites
5 minutes ago, v_kyr said:

Thanks.  I had read a similar article, but it mentioned that App Store apps don't use OCSP.  Not sure if that's true or not, but I do not believe that is my issue for a few reasons:

  1. The article says the OCSP check is cached for 12 hours.  My Affinity apps from the App Store have the long delay EVERY TIME they are first launched or a long period of time goes by since it was launched.
  2. The article says that if the Mac is OFFLINE, the check is skipped.  I can disconnect my Mac from the network and the launch delay is still there.
  3. It is no longer November 12, 2020.  The delays in OCSP have been fixed.  No reason why this should be happening if it's OCSP related (Apple's fault).  It could still be an issue with Affinity.
  4. The standalone apps do not delay on launch.  Ever.  They do the same OCSP checks, right?

 

Link to post
Share on other sites

Hard to tell if and what might have been changed here for Big Sur in terms of security and in correlation with M1 related hardware. - If the launch delay is always there, it might also be more an Affinity related universal binary and vendor notorization issue.

Do you have other third party universal binary software installed? How does that behave here in this regard?

☛ Affinity Designer 1.9.3 ◆ Affinity Photo 1.9.3 ◆ OSX El Capitan

Link to post
Share on other sites
23 minutes ago, v_kyr said:

Hard to tell if and what might have been changed here for Big Sur in terms of security and in correlation with M1 related hardware. - If the launch delay is always there, it might also be more an Affinity related universal binary and vendor notorization issue.

Do you have other third party universal binary software installed? How does that behave here in this regard?

I do have some other 3rd party apps from the App Store, but no issues with them.  Just the Affinity apps from the App Store.

Link to post
Share on other sites
  • Moderators

Does it run up fast with your internet (wi-fi) turned off? It does for me

Patrick Connor
Serif Europe Ltd

There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon

 

Link to post
Share on other sites

Same here. Both Affinity Photo and Affinity Designer take almost 20s to even show the splash-screen. Same whether connected to internet (WiFi) or not.

If you start the app within a couple of minutes after closing it, it starts very quickly. But after 5 or 10 minutes they have the slow start again.

Photo and Designer purchased through the App Store. Affinity Publisher is purchased directly from Serif and does not show this behaviour.

None of my other apps from either App Store (majority) or direct purchase from developer show this behaviour.

Strange that this pops up so late in the game and has not come out with beta-testing.

 

Big Sur 11.0.1, Mac Pro 2019, Affinity apps 1.8.6.

Link to post
Share on other sites
  • Moderators
9 hours ago, Willem Jan Drijfhout said:

Strange that this pops up so late in the game and has not come out with beta-testing

If the Affinity Store version does not show this behaviour then it is not strange at all, as the Beta effectively is the Affinity Store build (with a beta flag set). We could not have known that the same files when distributed through the MAS would behave differently in this respect, and it is certainly seems to be caused by something at Apples end when dealing with this now universal app.

9 hours ago, Willem Jan Drijfhout said:

None of my other apps from either App Store (majority) or direct purchase from developer show this behaviour.

I doubt many of your other apps are universal applications, so it may be that. It is a brand new thing for the Apple architecture and the Mac App Store. If we hear any more about this we will post back here

Patrick Connor
Serif Europe Ltd

There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon

 

Link to post
Share on other sites
1 hour ago, Patrick Connor said:

I doubt many of your other apps are universal applications

Scrivener 3, Hype 4 and Omnigraffle 7 are now universal apps and load super fast. 

No need to be defensive, I love the Affinity apps, ditched adobe more than a year ago, and just trying to help you getting this right, which I'm sure you will. It's an annoyance, but workable. Much more of a showstopper for me is the lack of export to PSB-files, but that's a whole different topic...  🙂

Link to post
Share on other sites
  • Moderators
18 minutes ago, Willem Jan Drijfhout said:

Scrivener 3, Hype 4 and Omnigraffle 7 are now universal apps and load super fast. 

Oh then my guess is wrong, sorry

Patrick Connor
Serif Europe Ltd

There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon

 

Link to post
Share on other sites
5 hours ago, Patrick Connor said:

If the Affinity Store version does not show this behaviour then it is not strange at all, as the Beta effectively is the Affinity Store build (with a beta flag set). We could not have known that the same files when distributed through the MAS would behave differently in this respect, and it is certainly seems to be caused by something at Apples end when dealing with this now universal app.

I doubt many of your other apps are universal applications, so it may be that. It is a brand new thing for the Apple architecture and the Mac App Store. If we hear any more about this we will post back here

Every single one of my apps are Universal, except for one.  I've made a point of installing only Universal versions (including a beta of the Universal version of Microsoft 365 apps), and none of them have this issue.

I'm not a developer so I don't know how the process works, but there must be a difference in the code between the App Store version and the standalone version.  I see the size of the file is different, so they are not the same.  

In any case, I'm stuck on using a trial (which is temporary) so please don't sit back and wait to see if others have the same issue.  You have two people with the problem.  I'm happy to assist in troubleshooting, or...you could actually download the Universal app from the App Store on a M1-based Mac and try it yourself.

Link to post
Share on other sites
  • Moderators
1 minute ago, DEMinSoCAL said:

....you could actually download the Universal app from the App Store on a M1-based Mac and try it yourself.

Serif replicated this ourselves almost as soon as the build went live on the Mac App Store, and I was not saying it is not a problem, sorry if it looked like that. Thanks for your offer of help with troubleshooting.

Patrick Connor
Serif Europe Ltd

There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon

 

Link to post
Share on other sites
6 minutes ago, Patrick Connor said:

Serif replicated this ourselves almost as soon as the build went live on the Mac App Store, and I was not saying it is not a problem, sorry if it looked like that. Thanks for your offer of help with troubleshooting.

Well, that's comforting!  But yes, your comment to Willem above did sound very dismissive of the issue.  Hopefully it will be figured out soon!  

Thanks.

Link to post
Share on other sites
  • 2 weeks later...
  • Moderators

We are still looking into this and trying to see if it can be avoided going forward, so sorry no real news.

Patrick Connor
Serif Europe Ltd

There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon

 

Link to post
Share on other sites

Just an FYI that there is another thread about this same topic.  This issue impacts both M1 and Intel, both App Store and non-AppStore versions.  I have an Intel iMac (excited to see what future M1 surprises come out) and this only happens with Affinity applications.  All my other applications (most of them are universal) are fine and launch pretty quickly.  

Startup performance 1.8.6 - Page 2 - Photo Bugs found on MacOS - Affinity | Forum (serif.com)

Link to post
Share on other sites
  • 1 month later...
  • 3 weeks later...
  • Moderators

@mgymnop

Welcome to the Serif Affinity forums :) and my apologies for the delayed response here!

To all,

We are currently giving this advice

4 hours ago, Dan C said:

I can confirm that this issue is still with our developers to be resolved currently, as we're working directly with Apple to try and speed up the launch times of our apps on Big Sur. We suspect this is due to the new checks that Big Sur run when launching an app, however this is yet to be confirmed.

As you've mentioned, this appears to only affect the first run of the application from a cold boot and any subsequent launches are faster.

Some customers have reported duplicating the Affinity app, so that there are 2 versions the original install any your own copy, and the second version launches much faster on first launch - however this is not true for all users and isn't explicitly a workaround we're suggesting.

We do hope to have an update to resolve this shortly, however I have no further information to provide currently, my apologies. 

 

Patrick Connor
Serif Europe Ltd

There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.