Jump to content

Recommended Posts

Hello, I'm using Affinity Designer 1.8 and I'm experiencing issues when trying to use assets.

 

  1. Are you using the latest release version?
    - Yes I'm using the version 1.8.5.585
  2. Can you reproduce it?
    - Yes, basically everytime I try to drag one from the pallete the entire app crashes.
  3. Does it happen for a new document? If not do you have a document you can share that shows the problem?
    - Tried to create 3 new documents, issue was there everytime. Noticed that sometimes worked with smaller assets.
  4. If you cannot provide a sample document then please give an accurate description of the problem for example it should include most of the following:
  •    What is your operating system and version (Windows 10, OSX Mojave, iOS 12 etc)?
      - Windows 10
  •    What happened for you (and what you expected to happen)
       - The app crashed when I was trying to drag an asset from the pallete. I was hopping it placed the asset in my artboard
  •    Screenshots (very handy) or a screen capture/video.
       - Not able to creating one right now but it's easy to reproduce.
  •    Any unusual hardware (like tablets or external monitors or drives that may affect things) or relevant other applications like font managers or display managers.
       - No.
  •    Did this same thing used to work and if so have you changed anything recently? (software or hardware)
       Yes, I updated the app.

Provide a recipe for creating the problem (step-by-step what you did):

  1. Selected assets pallete
  2. Started to drag the asset from the pallete (Note that the app was already getting glitchy at this point (e.g slow animations))
  3. When I released the mouse button the entire software crashed.
Edited by Ariano
Insertion of steps.

Share this post


Link to post
Share on other sites

I have the same issue but I have to drag a few assets on my page and all of a sudden the interface disappear displaying "Affinity Designer (Not Responding)" at the top left and I have to shut down Designer with the big red "X" at the top right.


-- Window 10 - 32 gb - Intel I7 - 8700 - NVIDIA GeForce GTX 1060
-- iPad 2020 - 12,9 - 256 gb - Apple Pencil 2 -- iPad 6th gen 128 gb - Apple Pencil 1

Share this post


Link to post
Share on other sites
Just now, AlainP said:

I have the same issue but I have to drag a few assets on my page and all of a sudden the interface disappear displaying "Affinity Designer (Not Responding)" at the top left and I have to shut down Designer with the big red "X" at the top right.

I found a workaround, you can just press twice on one and then if you put your cursor above your artboard you just need to click to place it. 

This way didnt caused issues until now.

Share this post


Link to post
Share on other sites
2 minutes ago, Ariano said:

I found a workaround, you can just press twice on one and then if you put your cursor above your artboard you just need to click to place it. 

This way didnt caused issues until now.

Yes, that seems to work, I pasted a lot of assets and never had a crash.


-- Window 10 - 32 gb - Intel I7 - 8700 - NVIDIA GeForce GTX 1060
-- iPad 2020 - 12,9 - 256 gb - Apple Pencil 2 -- iPad 6th gen 128 gb - Apple Pencil 1

Share this post


Link to post
Share on other sites
1 minute ago, Gabe said:

Which asset? Can you attach a screen recording of your workflow?

At step 1 I'm at the assets pallete choosing one

At step 2 I drag and drop one of them to my artboard

At step 3 the software crashed doing this.

1.png

2.png

3.png

Share this post


Link to post
Share on other sites
1 hour ago, Gabe said:

Thanks. I logged this with our developers. 

Thank you! Hope it gets solved soon.

Share this post


Link to post
Share on other sites

Hi Affinity Designer Team,

 

Every thing works fine but one thing go wrong.

 

When I drag and drop assets from Misc every thing works.

But when I use other categories Affinity designer 1.8.0.585 all the software freeze

 

You should make a quick fix for the none beta version or tell me how to fix it

 

Thanks

Louis

Share this post


Link to post
Share on other sites

We have made fixes/improvements to this area (Hang when dragging assets that contain fonts that aren't installed) of the program in the latest customer beta. If you would like to try these changes the beta software is available in the forum posts listed below.

The latest beta builds are downloadable from links at the top of each of these beta forum posts.

These betas install parallel, next to the release version (they do not overwrite your release) and so the fixes can be tried in the beta without affecting your normal workflow in the release version.

Once these programs have been through a full beta process the change will be released in a future free 1.8.1/1.8.2 update/patch to all customers.


Patrick Connor
Serif Europe Ltd

Latest releases on each platform 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.