Jump to content
arnim

affinity photo 1.7.0 not accepting product key

Recommended Posts

I am a happy Affinity Photo user and own a paid 1.6.7 license. Have tied 3 times to download the new 1.7 release and every time get the same error message attached below (stating my e-mail or product key is wrong).

What am I doing wrong. I am logging into store.serif.com as an exciting customer, go to get my download link and download the dmg file. When I start affinity 1.7 I enter the same e-mail and the download number By hand, paste have tried it all) but it gives me the error message.

Please help since I am very eager to use 1.7 

iMAC 27 late 2015 , macOS 10.14.4, Affinity Photo Desktop 1.7

thank you!

Screen Shot 2019-06-07 at 9.19.30 AM.jpg

Share this post


Link to post
Share on other sites

Thx Leigh for getting back too me, will be away intil Wednesday and get back to you by then. With PM you mean private message Isuppose, can you kindly tell me how to do that in this forum? 

Cheers

Share this post


Link to post
Share on other sites

If I want to send you a PM I click on your name and get sent to your profile page, then I can click on the Message button and send you a message. So click on Leigh's name (or picture) and send him a message.

1371740259_ScreenShot2019-06-08at8_16_44AM.thumb.png.765d373167aba7eabe23f38fe959234d.png

the message will not show up here in the forums.


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.6

Affinity Designer 1.8.4 | Affinity Photo 1.8.4 | Affinity Publisher 1.8.4 | Affinity Designer Beta 1.9.0.2 | Affinity Photo Beta 1.9.0.199 | Affinity Publisher Beta 1.9.0.742

Share this post


Link to post
Share on other sites

1.6.7 is a Mac app store release number. You do not download the update from Serif (that's for people who bought directly and have a product key from the Affinity Store). Mac app store owners find their free updates automatically in the Mac app store "updates page" (hint press CMD+R to refresh)


Patrick Connor
Serif Europe Ltd

Latest releases on each platform 

 

Share this post


Link to post
Share on other sites

Hello All,

I too had the situation that it would not accept the product key for Photo. I wondered if this was a result of an upgrade from Windows 7 to Windows 10. I do have Photo on another machine and tried to check that I had the correct key. However, I cannot find where the key is kept. Where can I check the product key on my working copy of Photo?

Thanks,

Robin

Share this post


Link to post
Share on other sites

thank you Patrick! Yes using the mac appstore instead to upgrade the Affinity Photo solved the problem (that is not recognizing the license)!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.