Jump to content
GB_Design

Make double clicking on an object highlight it in the hierarchy

Recommended Posts

I realise that you can zoom in on an object by double clicking on the object thats in the hierarchy, but why can't it be the other way around? I often can't find an object buried in the cluttered hierarchy, while I can see it clearly on the artboard. I believe that double clicking on the object and having the hierarchy automatically scroll to it, and have it selected would be very beneficial.

Share this post


Link to post
Share on other sites

You can right click on the object, and select "find in layers panel" 


intel core i5,  16GB 128Gb ssd win10 Pro Huion new 1060plus.

philips 272p 2560x1440px on intel HD2500 onboard graphics

Razer Tartarus Chroma

Share this post


Link to post
Share on other sites

Thankyou! I kinda wish it was with a double click, but thanks for letting me know the feature exists. I'll probably delete this thread now that I know there's a solution.

Share this post


Link to post
Share on other sites

currently a double click on a curves object switches from the move tool to the node tool, so this can't be used to find in the layers panel.


intel core i5,  16GB 128Gb ssd win10 Pro Huion new 1060plus.

philips 272p 2560x1440px on intel HD2500 onboard graphics

Razer Tartarus Chroma

Share this post


Link to post
Share on other sites

Unless I’ve misunderstood the requirements, you can also set the Layers panel to “auto scroll”. When this option is on, when you select a layer on the canvas, the selected layer should be automatically highlighted in the Layers panel.

To make this happen, go to the top-right corner of the Layers panel, click on the little menu icon, and check/tick “Auto-scroll”.

Having said that, I’ve also seen this behaviour when “Auto-scroll” is off and, conversely, “Auto-scroll” doesn’t always scroll to the layer that was last created so I’m not sure if it’s working properly or I just don’t know exactly how it’s supposed to work (there’s not much in the Help about it).

P.S. Deleting threads makes it impossible for other people in the same situation to find the same answer without asking the same question again.

Share this post


Link to post
Share on other sites

Hmm, my Auto-Scroll is allways on. I thought it was used for when you manually move something down the hierarchy. Might be a bug with the auto-scroll then.

Share this post


Link to post
Share on other sites

I think I might be getting myself a bit mixed up so may I confirm something so I know we’re talking about the same thing?

From your posts it sounds like you want the following functionality: “When the user selects a layer on the canvas, the Layers panel should automatically highlight the selected layer and scroll to where that layer is in the layer hierarchy if that layer is not currently visible in the Layers panel.”

Is this what you want to happen, or something else?

Share this post


Link to post
Share on other sites

i also have autoscroll on, but it does not scroll to a layer selected on the canvas.


intel core i5,  16GB 128Gb ssd win10 Pro Huion new 1060plus.

philips 272p 2560x1440px on intel HD2500 onboard graphics

Razer Tartarus Chroma

Share this post


Link to post
Share on other sites

In Edit > Preferences > User Interface

Make sure "Show selection in Layers Panel" is ticked


Due to the fact that Boris Johnson is now our Prime Minister, punctuation, spelling and grammar will never be worried about ever again.  We now have far bigger problems to be concerned about.

Share this post


Link to post
Share on other sites
2 minutes ago, carl123 said:

In Edit > Preferences > User Interface

Make sure "Show selection in Layers Panel" is ticked

thanks,

never knew that option was there.


intel core i5,  16GB 128Gb ssd win10 Pro Huion new 1060plus.

philips 272p 2560x1440px on intel HD2500 onboard graphics

Razer Tartarus Chroma

Share this post


Link to post
Share on other sites

So what is “Auto-scroll” supposed to do?

The documentation says: “Switch off Auto-scroll (panel scrolls to layer content when it is selected on the page)”.

However, all it seems to do for me, if switched OFF, is that the layers panel no longer scrolls when I drag a layer in that panel.

Share this post


Link to post
Share on other sites
5 minutes ago, carl123 said:

In Edit > Preferences > User Interface

Make sure "Show selection in Layers Panel" is ticked

Thankyou! I wonder why that option isn't on by default...

Share this post


Link to post
Share on other sites
3 hours ago, dutchshader said:

You can right click on the object, and select "find in layers panel" 

I'm using ctrl+K shortcut very often. It does the same. It's quite handy to know it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.