Jump to content

Recommended Posts

One feature missing from Affinity Photo is the ability to handle One-bit, or black-and-white images. I do a fair amount of scanning black-and-white documents, making small edits (typically cleaning up) and then saving them. I typically use Vuescan which will scan my documents and save them as 1-bit black-and-white tiff documents. I can open these in PS CS5 or in Paintshop Pro, and they open as 1-bit documents. If I open these tiffs in AP, they open as 8-bit RGB! Not even as Greyscale. I would expect that the histogram should show just black and white pixels, such as in this histogram (from Curves):

BlackAndWhite.PNG.e38271a74d93b4ab5325b4d74feea390.PNG

However, what it shows is a histogram like this (also from  Curves):

HistogramBefore.png.54a1e229688d5be925a3cc0e82259723.png

Affinity has clearly found a range of pixels (in a 1-bit image) with intermediate values. I can apply a threshold in the Curves Adjustment at 127, which does indeed give me the histogram as seen in my first image.

Can anyone explain this phenomenon?

John

 


Windows 10, Affinity Photo 1.7 and Designer 1.7, (mainly Photo), now ex-Adobe CC

CPU: AMD A6-3670. RAM: 16 GB DDR3 @ 666MHz, Graphics: 2047MB NVIDIA GeForce GT 630

Share this post


Link to post
Share on other sites

+1 for B&W bitmap and the possibility to colour them (assigning a colour to the black and/or the white, or transparency) when placing them in APub.
And if possible doing the same with greyscale B&W.

Share this post


Link to post
Share on other sites

This message was not intended as a Feature Request. It was intended for the Affinity on Desktop Questions   forum. Could it please be moved?

John


Windows 10, Affinity Photo 1.7 and Designer 1.7, (mainly Photo), now ex-Adobe CC

CPU: AMD A6-3670. RAM: 16 GB DDR3 @ 666MHz, Graphics: 2047MB NVIDIA GeForce GT 630

Share this post


Link to post
Share on other sites

I believe this was recently logged as a bug.


-- Walt

Windows 10 Home, version 1909 (183623.476), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.3.481 and 1.8.0.514 Beta   / Affinity Designer 1.7.3.481 and 1.8.0.514 Beta  / Affinity Publisher 1.7.3.481 and 1.8.0.518 Beta

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.