Jump to content
homegro

Find something and Replace with nothing, i.e. delete it doesn't work

Recommended Posts

Hi,

trying to delete (by FIND AND REPLACE with empty replace field) the soft hyphen characters within a text pasted from a MS Word document, I didn't succeed. In case of an empty replace field, the "Replace All" button is greyed out.

Is there an other way to do it?

Share this post


Link to post
Share on other sites

Search and replace the soft hyphens in Word. Sorry for this pragmatic answer. :(

As a rule, it seems you will have to click Find before you can use Replace All. Nonetheless, you are right that “Search and Replace” currently does not work as “Search and Delete.” That means, we cannot replace strings with the empty string. But I would strongly agree: that should be possible! :)

Share this post


Link to post
Share on other sites
15 minutes ago, A_B_C said:

Nonetheless, you are right that “Search and Replace” currently does not work as “Search and Delete.” That means, we cannot replace strings with the empty string.

Actually, we can, but there's a trick. You must type something into the Replace box. So, just type a space or any other character, and backspace over it leaving the box empty. This seems to be different than having never typed anything at all, and will allow Replace to delete whatever Find selected.


-- Walt

Windows 10 Home, version 1903 (18362.239), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.2.471 and 1.7.3.476 Beta   / Affinity Designer 1.7.2.471 and 1.7.3.476 Beta  / Affinity Publisher 1.7.2.471 and 1.7.3.475 Beta

Share this post


Link to post
Share on other sites

I see you're on a Mac, so maybe that's another aspect of the Find and Replace panel not having some of the options that it has on Windows.


-- Walt

Windows 10 Home, version 1903 (18362.239), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.2.471 and 1.7.3.476 Beta   / Affinity Designer 1.7.2.471 and 1.7.3.476 Beta  / Affinity Publisher 1.7.2.471 and 1.7.3.475 Beta

Share this post


Link to post
Share on other sites
On 9/2/2018 at 5:40 PM, A_B_C said:

Unfortunately, that doesn’t work on my machine … :(

 

Same problem on my Mac...

 


iOs: iPad Pro 12,9" 1st gen., Apple pencil; Mac: Affinity Photo & Designer and really looking forward to Affinity Publisher

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×