Jump to content

Recommended Posts

Hello everyone,

I have created several symbols in my AD document so I can test different color schemes in UI mockups.

However I noticed that when I drag them into the canvas/artboard they do not snap to the pixels grid, becoming very fuzzy. Only if I release them and then start dragging again they will then start to snap to objects and moving pixel by pixel.

 

It would be cool if they snapped to the pixels grid as soon as they are dragged onto the canvas so I can make quick drag and drop without having to realign them later.

 

The three pixel alignment toggles at the top bar are on.

Link to post
Share on other sites
  • 4 weeks later...
  • Moderators

Hi fernandolins86,

 

I have been trying to recreate this issue here at my end but the Symbols are snapping to the grid. Please could you provide the exact steps you take to recreate this issue?

 

Thanks

C

Please tag me using @ in your reply so I can be sure to respond ASAP.

Link to post
Share on other sites

Hi fernandolins86,

 

I have been trying to recreate this issue here at my end but the Symbols are snapping to the grid. Please could you provide the exact steps you take to recreate this issue?

 

Thanks

C

 

Hi C (?),

 

Here is a video of the issue: (right click and save) http://fernandolins.net/dwld/ad_snap.mp4

As you can see while I'm dragging there's no snapping to pixels going on, I can drop the object simply anywhere. It would only snap to pixels if I dropped it and then started dragging again.

 

Thanks

Link to post
Share on other sites
  • Moderators

Hi fernandolins,

I'm able to reproduce the Symbols panel issue. Seems it doesn't snap immediately after dragging an element from the Symbols panel. It does it if you drop the object and move it again.

Regarding CTRL/ ALT dragging to duplicate, if you use CTRL you can duplicate the objects keeping snapping active. If you use ALT instead you can also duplicate the object but you will override the snapping. This is by design.

Link to post
Share on other sites

Hi fernandolins,

I'm able to reproduce the Symbols panel issue. Seems it doesn't snap immediately after dragging an element from the Symbols panel. It does it if you drop the object and move it again.

Regarding CTRL/ ALT dragging to duplicate, if you use CTRL you can duplicate the objects keeping snapping active. If you use ALT instead you can also duplicate the object but you will override the snapping. This is by design.

 

Great, Control seems to snap when duplicating, thanks!

Is that an intended difference between alt-dragging and control-dragging, having snap on or off?

 

Would be nice if dragging symbols from the panel would automatically snap because if you drop a symbol at say X 0.4 and Y 0.4 it will then move in 1px increments from that point (1.4,1.4; 2.4, 2.4; etc.) instead of snapping to the pixel "grid" and only attaching to integer values (1,1; 2,2; 3,3, etc).

Link to post
Share on other sites
  • Moderators

Hi fernandolins86,

Yes, the difference in behaviour between pressing ALT-dragging and CTRL-dragging is intentional (by design).

Regarding the snapping when dragging symbols from the symbols panel, this is a bug in the Windows version. The Mac version does snap the objects when you drag them for the first time. I'm logging this to be looked at.

Link to post
Share on other sites
  • 9 months later...

@MEB Although the snapping (when dragged from the symbols panel) does seem to be working on Windows now, I don't see the red/green snapping indicators that are present if I Ctrl+Drag a new instance on the canvas.

 

5a023dc97530a_AffinitySymbolDrag.gif.0bc8375b2b7391211ce9cb5016e6df9d.gif

 

Do you see the indicator on mac?

Win10 Home x64   |   AMD Ryzen 7 2700X @ 3.7GHz   |   16 GB RAM   |   1TB SSD   |   nVidia GTX 1660   |   Huion 1060 Plus

How I make GIFs >>> ScreenToGIF (Windows only, Open Source, Portable, ~600kB)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.