Jump to content
You must now use your email address to sign in [click for more info] ×

Publisher 2.5: pages cannot be numbered any more


Recommended Posts

After updating to Affinity 2.5 documents in publisher can no longer be numbered - they always start with 0 or 1. And worse: the numbering in existing documents is destroyed, all documents now start with page #1, no matter which value I insert in "start page numbering at xxx" and no difference if it's an older (pre-2.5) document or a freshly created one.

Bildschirmfoto 2024-05-24 um 12.53.55.jpg

Link to comment
Share on other sites

  • Staff

Hi emte,

Thanks for letting us know. I'm able to reproduce this on a new document and reported to development, however opening an existing document made in 2.4.2 is displaying the correct page numbers, however attempting to edit that value will cause it to break.

Are you able to attach one of the pre 2.5 documents you have that displays the issue on opening as well please?

Link to comment
Share on other sites

Thanks both, for reporting and for acknowledging the bug. Downgrading now to 2.4.2 because we are just finishing a multi-document  450 pages book and this could be disastrous, having to go printing in the next days.

We will have 2.5 on a test computer to check for future resolution but this and another bug in the last version puts our work in risk.

Waiting for 2.5.1

 

Link to comment
Share on other sites

Thanks for acknowledging! This is an Affinity 1 document. Opening fine, correct page numbers. Editing the numbers - bang - break.

Right now I'm working on a 700-page document consisting of 9 books... Thank god I have backups. Will be downgrading to 2.4.xx until I'm on the safe side!

 

Kind regards from Germany - and keep on trucking!

Franklin Varianten 05:21 2.afpub

Link to comment
Share on other sites

  • Staff

You're welcome! Thank you very much for the file! I can confirm this is the same as what I'm seeing here. As I said it is now logged with development. :) 

Thanks again :)

Link to comment
Share on other sites

Here's a workaround to tide you over until it is fixed. Make a backup copy of your document before trying this.

  1. Create a book
  2. Add the document to the book
  3. Choose Page Number Options from the Books panel menu and set the starting page number as desired
  4. Save and close the document
  5. Close the Book without saving
  6. Re-open the document - it will have the correct starting page number. You still won't be able to change that with the Section Manager, but at least it will start on the page you want now.
Link to comment
Share on other sites

I can confirm this issue is affecting our shop as well and on Windows.

There appear to be other issue as well with the book feature now in addition to this one.

It would really be nice to have an umbrella thread on Book feature bugs which simply links to every Book related bug report.

In reality, Serif should establish a separate bug reporting/tracking system (ie. Bugzilla, etc.) This is much more efficient than attempting to use a forums setting for bug reporting and tracking.

Link to comment
Share on other sites

3 hours ago, MikeTO said:

Here's a workaround to tide you over until it is fixed. Make a backup copy of your document before trying this.

  1. Create a book
  2. Add the document to the book
  3. Choose Page Number Options from the Books panel menu and set the starting page number as desired
  4. Save and close the document
  5. Close the Book without saving
  6. Re-open the document - it will have the correct starting page number. You still won't be able to change that with the Section Manager, but at least it will start on the page you want now.

This is a real headache. Down grading is much quicker and more efficient.

This issue simply highlights the fact that Serif's entire development and release cycle needs managerial help.

Link to comment
Share on other sites

  • 2 weeks later...
  • Staff

The issue "[macOS] Unable to set page number using 'Start/Restart Page Numbering At' in Section Manager" (REF: AF-3203) has been fixed by the developers in internal build "2.5.3.2514".
This fix should soon be available as a customer beta and is planned for inclusion in the next customer release.
Customer beta builds are announced here and you can participate by following these instructions.
If you still experience this problem once you are using that build version (or later) please reply to this thread including @Affinity Info Bot to notify us.

Link to comment
Share on other sites

1 minute ago, Affinity Info Bot said:

The issue "[macOS] Unable to set page number using 'Start/Restart Page Numbering At' in Section Manager" (REF: AF-3203) has been fixed by the developers in internal build "2.5.3.2514".
This fix should soon be available as a customer beta and is planned for inclusion in the next customer release.
Customer beta builds are announced here and you can participate by following these instructions.
If you still experience this problem once you are using that build version (or later) please reply to this thread including @Affinity Info Bot to notify us.

@Affinity Info BotThis issue affects Windows as well.

Link to comment
Share on other sites

  • Staff

Yes thanks @Chris_06 I will correct the ticket 

<edit> see below </edit>

Patrick Connor
Serif Europe Ltd

"There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon

 

Link to comment
Share on other sites

  • Staff

@Chris_06

We cannot replicate this problem on Windows in Affinity Publisher 2 v2.5.2. Please can you walk me through the exact steps to replicate?

Patrick Connor
Serif Europe Ltd

"There is nothing noble in being superior to your fellow man. True nobility lies in being superior to your previous self."  W. L. Sheldon

 

Link to comment
Share on other sites

On 6/14/2024 at 10:45 AM, Patrick Connor said:

@Chris_06

We cannot replicate this problem on Windows in Affinity Publisher 2 v2.5.2. Please can you walk me through the exact steps to replicate?

Hi @Patrick Connor

At the moment we're under a very tight schedule. As mentioned earlier in this thread, we rolled back to 2.4.0 because of this problem (mainly). I will need to upgrade and then build a demo. I have it on my list, but it will be several weeks most likely. I'll post the results under the Windows V2 bug forum and link to it when I do.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.