Jump to content
You must now use your email address to sign in [click for more info] ×
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Bug - Affinity Photo 2.4.0 (2222) Luminance mask / Hue mask


Recommended Posts

Macos 14.2.1 on M2 Pro

Affinity Photo 2.4.0 (2222)

Steps to reproduce:

Open document.

Create luminosity mask, play with with the curve. No discernible change occurs. Going out of the mask and clicking on it, the curve has reset to default. Note that it loads and applies presents fine, however, but these cannot be edited, and revert again, to the saved values. Expected behaviour - modifying the curve modifies the mask, and does not lose current edited values. Hmm. Oddly enough, clicking on the checkboxes changes the blur radius slider from 0 to 1 to 0.

 

?!?!?

 

Create hue mask, play with the wheel. No discernible change occurs. Going out of the mask and clicking on it, the wheel has reset to default. Does not mask the default hue range either. Have not checked presets here.

 

Happy new year.

Link to comment
Share on other sites

Hi @AP-,

I can confirm that I'm seeing the same issue with both the Luminosity Range and Hue Range Masks...

  1. The Preview doesn't work for either
  2. The Graph Settings are removed once the Mask Dialog is closed

Affinity Designer 2.5.3 | Affinity Photo 2.5.3 | Affinity Publisher 2.5.3
MacBook Pro M3 Max, 36 GB Unified Memory, macOS Sonoma 14.5, Magic Mouse

Link to comment
Share on other sites

Thanks @Hangman.

I've been playing with this a bit, because the masks are something I use all the time.

Quick fix for the luminosity mask: Edit your curve. Play with the blur radius. It now displays. Or click the linear checkbox, it also now displays. Seems to want to fiddle the radius and. that does it.

My guess would be that when you fixed the blur radius slider bug that I reported previously, the fix introduced the new bug.

Dear Serif! Please to fix before release! I trade you the spiral tool. :) Thank you for addressing the other mask bugs though.

Link to comment
Share on other sites

Hi @AP-,

4 minutes ago, AP- said:

Quick fix for the luminosity mask: Edit your curve. Play with the blur radius. It now displays. Or click the linear checkbox, it also now displays. Seems to want to fiddle the radius and. that does it.

I can confirm this is the case, it appears you have to adjust the Blur Radius and then move it back again to its original setting or check then uncheck (or vice versa) with the Linear checkbox for the graph setting to both preview and for the setting to remain in place between closing and reopening the Mask dialog window...

Affinity Designer 2.5.3 | Affinity Photo 2.5.3 | Affinity Publisher 2.5.3
MacBook Pro M3 Max, 36 GB Unified Memory, macOS Sonoma 14.5, Magic Mouse

Link to comment
Share on other sites

If this is really about 2.4, it should have been posted in Other New Bugs and Issues in the Betas, not here in the general Bugs forum.

Perhaps (if that's true) a moderator will move it.

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.5, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.5

Link to comment
Share on other sites

  • Staff
On 1/13/2024 at 8:31 AM, Lecho said:

Hi,
I have a problem with the general use of any mask. They appear but don't work. When I switched back to version 2.3.1 it worked perfectly fine.

Hi Lecho,

Would you be able to create a new thread for this issue and attach a video detailing/reproducing the issue you're getting and attach any supporting files (ideally so we can also open them in 2.3.1 to compare) you've used.

Thanks!

Link to comment
Share on other sites

  • 2 weeks later...
  • Staff

The issue "Live Luminosity or Hue Range Masks no longer function on macOS" (REF: AF-1750) has been fixed by the developers in internal build "2.4.0.2252".
This fix should soon be available as a customer beta and is planned for inclusion in the next customer release.
Customer beta builds are announced here and you can participate by following these instructions.
If you still experience this problem once you are using that build version (or later) please reply to this thread including @Serif Info Bot to notify us.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.