Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Columns field in the context toolbar doesn't work (shows 0 after editing).


Recommended Posts

Welcome to the forums @LukasSladky

It seems to be working okay for me on Windows 10 Home.
I can’t tell what sort of content you have in your Frame Text layer so I can’t say if that would affect anything.

Can you tell us how you created the content and supply a video showing the problem happening?
If you can't share a video then a full-screen screenshot showing the Layers Panel with the Frame Text later selected might help.

(The more you can show us of what you can see the better we can help, usually.)

Link to comment
Share on other sites

It might also be useful to have a sample .afpub document that shows the problem.

-- Walt

Desktop:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 
Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
        Affinity Photo 1.10.6 (.1665) and 2.0..3  and 2.0.3.1670 beta/ Affinity Designer 1.10.6 (.1665)  and 2.0.3 and 2.0.3.1670 beta / Affinity Publisher 1.10.6 (.1665)  and 2.0.3 and 2.0.3.1670 beta
iPad Pro M1, 12.9", iPadOS 16.3, Apple Pencil 2, Magic Keyboard

      Affinity Photo 1.10.6 and 2.0.3 / Affinity Designer 1.10.6 and 2.0.3 / Affinity Publisher 2.0.3

Link to comment
Share on other sites

I've duplicated this on macOS.

The issue seems to be with master page frames. Here's a screen recording that illustrates the problem. Keep an eye on the column count in the Context Bar as I click around. You'll see the master 2-column frame shown as 1 column and then when I deselect the frame and reselect it switches to 0. Then it's stuck on 0 even when I go back to frames on the page itself. Here's the document so you can try it.

frames2.afpub

With my long-running book project, the column count for my master page frames is always shown as 0.

 

 

Affinity Publisher/Designer/Photo 2 for macOS Ventura 13.2, MacBook Pro 14" (M1 Pro)

Link to comment
Share on other sites

I think this might just be a ‘security thing’ to stop the user from accidentally changing the number of columns of a Frame Text layer on a master page without deliberately going to the master page to do it.

Otherwise the user could think they were changing it for just one page and not realise that other pages have also been (maybe accidentally) changed.

It might be better if the Columns field were to be disabled in this situation, rather than the value being set to (and kept at) zero.

I don’t think this is a bug, as such, but more of an opportunity for a bit of a UI tweak.

Link to comment
Share on other sites

7 hours ago, GarryP said:

I think this might just be a ‘security thing’ to stop the user from accidentally changing the number of columns of a Frame Text layer on a master page without deliberately going to the master page to do it.

Otherwise the user could think they were changing it for just one page and not realise that other pages have also been (maybe accidentally) changed.

It might be better if the Columns field were to be disabled in this situation, rather than the value being set to (and kept at) zero.

I don’t think this is a bug, as such, but more of an opportunity for a bit of a UI tweak.

I believe this is definitely a bug and Publisher already disables the Columns field when you select a frame on the master page. The issue is that the value gets stuck at the master frame's value when you next select a regular frame, or it gets stuck at zero in certain cases such as selecting a master frame and then clicking on the page before selecting a regular frame. The control isn't being properly set each time a frame is selected.

Affinity Publisher/Designer/Photo 2 for macOS Ventura 13.2, MacBook Pro 14" (M1 Pro)

Link to comment
Share on other sites

26 minutes ago, MikeTO said:

I believe this is definitely a bug ...

Something hinky is going on here. I can get the 0 (zero) sticking if I use the Move tool to select one of the text frames from the Master page (on an Actual page). The Move tool changes to the Text Caret. Then any Text frame I select with the newly promoted text caret is showing the 0 columns. If I use the text tool to select the frames then I get the Actual page's text frames to show the proper columns.

Or it could be that by using the Text Caret to select a Text frame on an Actual page immediately after using it to select a text frame on a Master page Publisher is unaware that I have selected a frame which is on an Actual page and not on a Master page. If I click on the empty canvas, not a text frame, then click on a Text frame from the Actual page I get the correct number of columns showing.

I am not going to spend too much time on this other than to confirm the bug. I doubt I have ever used the Context Toolbar to change the number of columns in a text frame, I have always used the Text Frame panel.

Mac Pro (Late 2013) Mac OS 11.7.3 
Affinity Designer 2.0.4 | Affinity Photo 2.0.4 | Affinity Publisher 2.0.4 | Beta versions as they appear.

I have never mastered color management, period, so I cannot help with that.

Link to comment
Share on other sites

Posted (edited)

The issue is when editing element which comes from Master page. 

Text Frame Studio is correctly disabled with the number of columns from the Master page, but in the top toolbar there is this quirky behavior. It looks like I should be able to edit the field but when I do, it only jumps to zero.

And I confirm it breaks other Text Fields on the page, even if they don't come from a master page.

 

image.thumb.png.9f04e5156292ec4ad381a9683d606e38.png

Edited by LukasSladky
Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.