Jump to content
You must now use your email address to sign in [click for more info] ×

When I go to Affinity Designer -> Help -> Account -> Already registered? Sign in now!, I get a message that something went wrong during registration or sign-in


Recommended Posts

Welcome to the Serif Affinity forums.

If you're using Windows, try quitting the application, then right-clicking on its icon and choosing Run as Administrator.

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.3, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.3

Link to comment
Share on other sites

40 minutes ago, LondonSquirrel said:

I am seeing the same error message on macOS. I thought I would finally get round to registering APhoto, but I can't. This is on two separate machines.

Exactly the same as shown in the screenshot just above, including the reason "timeout while waiting ... "?

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.3, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.3

Link to comment
Share on other sites

22 minutes ago, walt.farrell said:

Exactly the same as shown in the screenshot just above, including the reason "timeout while waiting ... "?

Here you go:

1404740249_Screenshot2022-01-12at12_46_45.png.d66358b5d6266830069a1bacd66edcc1.png

 

I tried several times on two machines. I registered APub and AD some time ago, and they both are showing the 'My Account' page as expected. But APhoto will not connect.

 

Link to comment
Share on other sites

Thanks, @LondonSquirrel. I have no idea what to do on a Mac, for that one. Except I wonder if you might have some Firewall processing in place that's preventing access?

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.3, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.3

Link to comment
Share on other sites

1 minute ago, LondonSquirrel said:

I did a bit of debugging last night, but it seems I cannot post it here. I keep getting 403 errors when I try.

What are you trying to post?

To save time I am currently using an automated AI to reply to some posts on this forum. If any of "my" posts are wrong or appear to be total b*ll*cks they are the ones generated by the AI. If correct they were probably mine. I apologise for any mistakes made by my AI - I'm sure it will improve with time.

Link to comment
Share on other sites

Just now, Jurgen van Leyen said:

I read the pdf.  And did what it said but I still can not register 

Where did you get your copy of APhoto? If direct from Serif the path is different. Note, I only have some information about macOS. I don't know anything about Windows.

If you bought the application direct from Serif, the path is ~/Library/Application Support/Affinity Photo/. Note: the ~ at the start of the path. The file you need to place there is called 'afreg.cfg' - no space in the name. Note: the forum post I linked to has two versions of the file, one with a space and one without. You want the one without a space. The contents are the same but the naming is different.

Link to comment
Share on other sites

11 minutes ago, LondonSquirrel said:

Where did you get your copy of APhoto? If direct from Serif the path is different. Note, I only have some information about macOS. I don't know anything about Windows.

If you bought the application direct from Serif, the path is ~/Library/Application Support/Affinity Photo/. Note: the ~ at the start of the path. The file you need to place there is called 'afreg.cfg' - no space in the name. Note: the forum post I linked to has two versions of the file, one with a space and one without. You want the one without a space. The contents are the same but the naming is different.

Oke I don that.  It’s working 

but the register page in the browser stays black (safari)

Link to comment
Share on other sites

I've been using the tools for years and have never had to start the apps as admin to sign in. I recently had to recore my machine (Win 11 Ent) and could never get the service to register. This is the first time I've had the browser pop-up to do the auth. So, maybe that was it. Anyway... admin finally made it work.

Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.