Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Brush, fill and eraser stopped working (reviewed previous threads and no luck finding the answer.


Recommended Posts

Hi everyone, absolutely stumped with this one. 

This has happened twice today where the brush/ eraser just stopped working. The first time, because i hadn't made a lot of changes, i just closed and opened the document version again. But this time, i've made a lot of changes so if i was to start from a previously saved version, i will have lost about 2 h of work, with no idea why it happened in the first place. 

I wasn't doing anything i haven't done before. The second time round, it happened just after i had added a rectangle and was erasing 1 of the sides, which automatically erased as a mask. After that, nothing worked

I checked this forum before posting to see if there was advice from anyone in a similar situation but am still having the same issue. All my pen settings are fine, no Protect Alpha. I've tried the "deselect" option - still nothing. None of my other layers work, even on my other pages and the fill tool is also firing blanks. 

What am i missing? See the attached screenshot. I'm not a professional digital artist and i've only been using Affinity for about a year so i am very open to the idea that i have no idea what i'm really doing. 

Really really appreciate some help.

Screenshot 2021-09-11 at 08.43.16.png

Link to comment
Share on other sites

Perhaps you have an active pixel selection, even a very tiny one, which is limiting your tools. Try Select > Deselect in the Menu.

-- Walt

Desktop:  Windows 11 Home, version 21H2 (22000.613) 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 
Laptop:  Windows 10 Home, version 21H2 (19044.1706) 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
        Affinity Photo 1.10.6 (.1665) and 2.0..3  and 2.0.3.1670 beta/ Affinity Designer 1.10.6 (.1665)  and 2.0.3 and 2.0.3.1670 beta / Affinity Publisher 1.10.6 (.1665)  and 2.0.3 and 2.0.3.1670 beta
iPad Pro M1, 12.9", iPadOS 16.3, Apple Pencil 2, Magic Keyboard

      Affinity Photo 1.10.6 and 2.0.3 / Affinity Designer 1.10.6 and 2.0.3 / Affinity Publisher 2.0.3

Link to comment
Share on other sites

56 minutes ago, walt.farrell said:

Perhaps you have an active pixel selection, even a very tiny one, which is limiting your tools. Try Select > Deselect in the Menu.

Thank you so much for responding Walt. Have given this a go but no luck. Any other suggestions?

Link to comment
Share on other sites

Have you tried saving the file, File>Save or Save as? That would be one of the first things I'd try. Then bring up Task Manager, it should show Affinity Photo as not responding, as well as how much resources it's using. You should be able to right-click on Affinity Photo and from the menu select Create Dump file. This would give the developers something to look at to see why it's hanging/freezing up.

Are you running other programs/apps at the same time you're using AP, that might be requiring a lot of resources? Things like video players, internet... ? In task manager you can click on the column header (CPU, Memory, Disc..) to reorder from small to large, to see what all is using a lot of resources. From this you can select one and press End Task to shut it down. I've done this in the past, so the hanging program can access more resources, so hopefully I won't have to force it to close.

Are you running any anti-virus programs while working in AP? Does it allow excluding programs? I just run AVG-Free version (which is one of Avast's), and they finally made it so it will not interfere with apps. If not you can certainly shut the AV program down while working in AP, AND so long as you're not using the internet. Just need to remember to enable it once you're done.

Would you mind providing us with your system information, OS version, RAM, HDD availability, GPU (video card info).. ? Have you tried disabling Hardware Acceleration/OpenCL, in AP's Preferences>Performance?

Affinity Photo 1.10.5.1342 ; Affinity Designer 1.10.5.1342;Affinity Photo 2.0.0.1640 Affinity Designer 2.0.0.1640; Affinity Publisher 2.0.0.1640; Affinity2 Beta versions. Win10 Home Version:21H2, Build: 19044.1766: Intel Core i7-4770, 3.90GHz, 32GB Ram, Nvidia GTX 645, 3-Internal HDD (1 Crucial MX5000 1TB, 1-Crucial MX5000 500GB, 1-WD 1 TB), 4 External HDD

Link to comment
Share on other sites

4 hours ago, Ron P. said:

That would be one of the first things I'd try. Then bring up Task Manager, it should show Affinity Photo as not responding, as well as how much resources it's using.

The OP did not say anything about the app not responding, but regardless, from the status bar two things are evident. One is this is running on a Mac (because the color picker shortcut shows the Mac Option Key symbol). The other is this is showing a 2 page spread (pp 16 & 17) of a 44 page file open in what appears to be the Photo persona of APub, not AP.

However, I am not sure this has anything to do with the tools no longer working.

All 3 1.10.6, & all 3 V2.03 Mac apps; 2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.10.6; Affinity Designer 1.10.6; & all 3 V2 apps for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 15.7

Link to comment
Share on other sites

Tools not working is quite vague, I have to guess (going from the screenshot) that the brush is not painting. Could well be one of the brushes is set to some extremes in the dynamics tab that it is not painting.

It is possible to set the secondary and primary colours to transparent and that will also look like nothing is happening.

Mac Pro (Late 2013) Mac OS 11.7.3 
Affinity Designer 2.0.4 | Affinity Photo 2.0.4 | Affinity Publisher 2.0.4 | Beta versions as they appear.

I have never mastered color management, period, so I cannot help with that.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.