Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Cmd+click to select layers hides transfrom handles


Recommended Posts

@konstantnnnBack a couple years ago I turned in a comment on this action.  You are the only other person I have seen to comment on having this issue.  What I have found is it seems to only happen in Separated Mode, which puts us in the minority.  And it only seems to happen when in the Move tool.  It seems to happen when the command key has been pressed and released in the layers panel and then the cursor is moved to the canvas.  If I pause after letting the command key up before moving the cursor I don't have the problem.  The easiest way I have found to recover from this is to switch to the Node tool then back to the Move, I've gotten good at a quick A then M. 

Does that agree with what you are finding?  I am hoping if more people complain it will get a higher priority.  Some days I bet I have to recover from this 20 to 30 times a day.  Mike

iMac (27-inch, Late 2009) with macOS Sierra

Link to comment
Share on other sites

6 hours ago, Gear maker said:

@konstantnnnBack a couple years ago I turned in a comment on this action.  You are the only other person I have seen to comment on having this issue.  What I have found is it seems to only happen in Separated Mode, which puts us in the minority.  And it only seems to happen when in the Move tool.  It seems to happen when the command key has been pressed and released in the layers panel and then the cursor is moved to the canvas.  If I pause after letting the command key up before moving the cursor I don't have the problem.  The easiest way I have found to recover from this is to switch to the Node tool then back to the Move, I've gotten good at a quick A then M. 

Does that agree with what you are finding?  I am hoping if more people complain it will get a higher priority.  Some days I bet I have to recover from this 20 to 30 times a day.  Mike

Thank you so much, the tips helped me.

I certainly wish this will be fixed, asap.

I hate how the small issues are ignored. They are really important.

Hackintosh running Big Sur 11.2.3, Coffe Lake i3 with UHD630 graphics

MacBook (Early 2015) running macOS Mojave

iPad Pro 11-inch (1st generation) running iPadOS 13.5

Vista PC in the attic 

Link to comment
Share on other sites

54 minutes ago, konstantnnn said:

I hate how the small issues are ignored. They are really important.

Unfortunately resources are limited.  The moderators and developers are great guys.  I just wish that maybe one week each month they'd concentrate on fixing what is already in the system but doesn't work quite right.  It now makes toast too, but unfortunately it burns the toast sounds like something that is run by marketing.

iMac (27-inch, Late 2009) with macOS Sierra

Link to comment
Share on other sites

On 8/24/2021 at 1:12 PM, konstantnnn said:

Cmd+click to select layers is hiding transform handles, even when you let go of the key.

I believe this is intended behaviour, Cmd+click to select multpile layers displays the measuring guides when you move the cursor onto the canvas (which is an AD 'requested' feature)...

The only time I can think that you would need to 'see' the transform handles after selecting multiple objects is when you want to transform the selected objects about their centre point, to do so simply involves releasing the Cmd key to display all the control handles and then selecting the appropriate control handle so you can transform the selected objects as desired which you could argue is an unneccessary additional step but equally it may be that you want to transform your selection from the Top Left corner in which case you would need to release the Cmd key and hit the Shift key instead.

On 8/24/2021 at 4:26 PM, Gear maker said:

What I have found is it seems to only happen in Separated Mode, which puts us in the minority.  And it only seems to happen when in the Move tool.  It seems to happen when the command key has been pressed and released in the layers panel and then the cursor is moved to the canvas.  If I pause after letting the command key up before moving the cursor I don't have the problem.  The easiest way I have found to recover from this is to switch to the Node tool then back to the Move, I've gotten good at a quick A then M.

This is the case when not in separated mode as well and as far as I can see it is irrespective of which tool you have selected...

Maybe I'm missing something here, if so let me know what action you would expect to undertake after selecting multiple objects that you can't already do, is it simply not having to release the Cmd key to transform the selected objects around their centre point or some other function, I'm curioius and keen to understand...

 

436356139_MeasuringGuides.thumb.jpg.5fe28fea828f9694536350ce5d6a5e11.jpg

Affinity Designer 2.0.0 (.52), Affinity Photo 2.0.0 (.307), Affinity Publisher 2.0.0 (.1604) | Affinity Designer 1.7.3, Affinity Photo 1.7.3
MacBook Pro 16GB, macOS Monterey 12.6.1

Link to comment
Share on other sites

@Hangman What we are seeing is the measuring guides.  But this is when the cursor is in the drawing and the mouse buttons are not down.  No keys are down.  As shown below this with the hands off the mouse.  Only one layer is selected.  And the cursor is in the drawing.

1283610869_ScreenShot2021-08-31at11_07_43AM.png.0f756e085ca0408c3f7eb77c1cfef096.pngIt acts just you are saying but the alt/opt key was released long ago.  Maybe the video will help.  In the video the alt/opt key is not down except  I put it down for maybe 1/2 second as the cursor passed over the border between the layer panel and the drawing.  It was never down at the time a click was done.

 

iMac (27-inch, Late 2009) with macOS Sierra

Link to comment
Share on other sites

@Gear maker Thanks for the clarification, I see the issue now... Cmd Click isn't acting as a toggle like it is in non-separated mode. Interestingly, when in separated mode, if you Cmd Click to select multiple objects in the layers panel, then move your mouse over the canvas with the Cmd key selected so you see the measuring guides, either a Cmd Right Click or a Ctrl Click will effectively release the measuring guides and then show your selection but you would need to repeat this action should you then Cmd Click another item from the layers panel.

After a Cmd Right Click or Ctrl Click on the canvas, holding Cmd does then correctly toggle between showing the measuring guides and your selection but only after moving your mouse outside the border of the selected items.

Certainly not a solution but perhaps an option until it is fixed.

Affinity Designer 2.0.0 (.52), Affinity Photo 2.0.0 (.307), Affinity Publisher 2.0.0 (.1604) | Affinity Designer 1.7.3, Affinity Photo 1.7.3
MacBook Pro 16GB, macOS Monterey 12.6.1

Link to comment
Share on other sites

5 hours ago, Hangman said:

Cmd Click isn't acting as a toggle like it is in non-separated mode

You've got it.  And it's so easy when doing a multiple layer selection to not get the cmd key released before the cursor crosses the Layer panel border.  In fact sometimes I'd swear that the key was released in time but there was maybe a slight delay before AD realized it.

Over the years I've gotten pretty good at typing AV as soon as I see the dimensioning on the screen. 

But it tis a pain having to do it several times an hour day after day...  It disrupts the flow.

iMac (27-inch, Late 2009) with macOS Sierra

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.