Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Using File> Export on "selected objects" isn't trimming area to just the selected objects


Recommended Posts

I frequently create memes assembled from multiple graphic elements and export the result to an image file. I started this with PagePlus and did not notice this problem until I started using Publisher: If I select all the elements in the design (which is typically bounded by a visible, bordered rectangle) the resulting image has an obvious extra, transparent "space" on the right and bottom. I can't connect the extra space's dimension to any specific element, although I first suspected that it might be due to cropped elements. I have to then open the final result in an image editor and crop it, which is tedious and prone to mistakes in crop placement.

Here is a piece of a resulting image that I exported with "Selection only" and then placed in a new document. When this image is selected, the selection handles should correspond to the corners of the outer rectangle, but as you can see, on the bottom right they do not. The selection indicators in the original design clearly included only that border rectangle and the elements within it. Although this extra space is transparent, it causes problems when uploaded and the dimensions don't match the image itself.

664651726_Screenshot-07_09_217_42_35AM.png.4fb233f95f0fe55a5c2deb759aa63986.png

This occurs with both PNG and JPEG exports. I haven't tried other formats. As I mentioned, I've tried it with "Selection area," too. Thanks for any input.

Link to comment
Share on other sites

  • Moderators

Hi @JCarls,

Thanks for the file.

Okaay, i've found the issue, its being caused by the Outer Glow Layer Fx you've applied.  A quick workaround but you'd lose the editaibly of the Layer Fx and brightness and contrast adjustment, is to right click the layer with the Layer Fx applied and select Rasterise, this will then show you the extra transparent space and if you select the Crop tool, you can crop this away.  You can then export and it will be fine.

I'll run this past the QA guys and get something logged with the Dev team if it isn't already :) 

Link to comment
Share on other sites

  • 4 weeks later...

Hi. I am experiencing a similar problem but the solution on this page does not apply to my issue. 

I am trying to export a selected drawing to jpeg using Selection Area or Selection Only (Not sure what the difference is). The resulting Jpeg has space around the drawing as if I had chosen export Artboard. Although I have had some success with other drawings, with this file I can not make Designer export a jpeg that has only the selection. 

I'd appreciate anybody being able to point out the issue here. 

warriparri-21-FP.afdesign

Link to comment
Share on other sites

How are you selecting the objects? Image below shows the objects of the Site Plan selected with the Move tool, note that the North arrow is not included

Export using Selection Only is perfect

Export using Selection Area also includes the arrow clipped within the blue box

For what it's worth, for images with limited colours and geometric lines I'd use png rather than jpg

SitePlan-Selection.png

Microsoft Windows 10 Home, Intel i7-9750H CPU @ 2.60GHz, 16 GB RAM, 500GB SSD, 1TB Whirlygig, NVIDIA GeForce RTX 2060
Affinity Photo - 24/05/20, Affinity Publisher - 06/12/20, KTM Superduke - 27/09/10

Link to comment
Share on other sites

I was actually selecting all four drawing on that file. I've attached the jpeg. (In my little slice it's a jpeg world but I know what you mean).

Can you try selecting all by any means and see the resulting jpeg for yourself?  The selection appears to select exactly what I want to export but the jpeg shows quite a bit of padding.

Thanks for the clarity on Selection Only and Selection Area

warriparri-21-FP.jpg

Edited by hudson2800
An unfinished sentence
Link to comment
Share on other sites

Thanks Lagarto. Problem layers they are indeed. I cannot see them, or select them. This is a bit frustrating for someone coming from 30 years of Illustrator. 

Your solution is fine. My solutions was to just edit the artboard size. Same result, a trimmed image. With illustrator this was only ever an issue with a stray point dropped somewhere, and they were easy to find and delete. 

I like everything about this software so far apart from the layers panel. It is really testing me!  Shouldn't artboards and layers be separate concepts?

Link to comment
Share on other sites

1 hour ago, hudson2800 said:

Can you try selecting all by any means and see the resulting jpeg for yourself? 

I tried and failed. The only success I had was to copy all layers then with APhoto do New from Clipboard

Microsoft Windows 10 Home, Intel i7-9750H CPU @ 2.60GHz, 16 GB RAM, 500GB SSD, 1TB Whirlygig, NVIDIA GeForce RTX 2060
Affinity Photo - 24/05/20, Affinity Publisher - 06/12/20, KTM Superduke - 27/09/10

Link to comment
Share on other sites

  • Moderators

Actually this issue is caused by a single layer which is a vector mask applied to a group without content. Simply adding something to that group or deleting the group's mask fixes the issue. The other minor differences (a few pixels) are due to the way Designer handles the strokes, caps, alignments which only count up to the bounding box area, strokes aligned to outside, caps that use other option that butt cap etc will add a few pixels more to what's reported in the Transform panel depending on the strokes dimensions - I'm checking if there anything else besides that.
Other way to get the desired result is to draw a slice around the part you are interested in in the Export Persona and export it from there.
I'm logging the issue with masks applied to empty groups.

Link to comment
Share on other sites

1 hour ago, MEB said:

Actually this issue is caused by a single layer which is a vector mask applied to a group without content.

Could you point out that layer for me? I didn't intend to add a vector mask to a group. If I did I do not know I had done it.  

Thanks for taking up the issue.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.