Jump to content
Our response time is longer than usual currently. We're working to answer users as quickly as possible and thank you for your continued patience.

Has anyone else been experiencing problems with Unsplash (again)


Recommended Posts

Everytime I have tried to directly drag and place a stock photo from Unsplash onto my screen this week I have had to press Ctrl Alt Delete for task manager in order to restart both Affinity Photo/ Designer because they both simply stop working....only the mouse cursor moves screen. This isn't the case with Pexels and Pixabay which are both working as normal.

Is anybody else having similar problems?

Any advice would be much appreciated

Link to comment
Share on other sites

  • Moderators

Hi @AITCH,
I'm also experiencing issues, although Affinity doesn't become unresponsive for me. Dragging an image from Unsplash simply does nothing in my case. There have been other reports on the forums in the last couple days so it's not only you who is having trouble. We are investigating this. Thanks for reporting it.

Link to comment
Share on other sites

2 minutes ago, MEB said:

I'm also experiencing issues, although Affinity doesn't become unresponsive for me. Dragging an image from Unsplash simply does nothing in my case.

I second that rather than the OP's issues for most of the time. But sometimes the apps just close without saving or any other reaction, which is kinda annoying.

»A designer's job is to improve the general quality of life. In fact, it's the only reason for our existence.«
Paul Rand (1914-1996)

Link to comment
Share on other sites

13 minutes ago, MEB said:

Hi @AITCH,
I'm also experiencing issues, although Affinity doesn't become unresponsive for me. Dragging an image from Unsplash simply does nothing in my case. There have been other reports on the forums in the last couple days so it's not only you who is having trouble. We are investigating this. Thanks for reporting it.

Hi MEB thanks for replying mate, I wasn't aware that this is already being investigated so apologies for the extra thread

Link to comment
Share on other sites

Hi @MEB - in case the additional data point helps diagnosis, I was doing a mini project for work last week (Tuesday 2nd March) and using Unsplash was crashing the app then.  It reminded me of the teething problems the Stock feature had when originally launched.  (Ironic that I've probably not used it since then. :))

—— Gary ——

Photo/Designer/Publisher: Affinity Store, v2.0 release

Mac mini (M1, 2020), 16GB/2TB, macOS Big Sur: 11.7.1 • MacBook Pro (Intel), macOS Big Sur: 11.7 • Windows 10 via VMware Fusion • iOS: current release

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.