Jump to content

Recommended Posts

I love Affinity products and have been a huge advocate of the suite trying to coax anybody to switch. But as of late I have been experiencing the most disappointing and frustrating lag when using Publisher. 

Although it's two years old, I have an above average computer that is constantly freezing and lagging only while I'm in Publisher. I've included screen shots of computer data as well as activity monitoring but to list the scenario: 

MacBook Pro 2018, Quad Core i5, 16 GB Ram 

Activity Monitor Peak: CPU % 320

Project: 18 Master Slides, <400 hyperlinks total, Tables, Text Boxes, Shapes. There are no photos, no embedded items. File Size - 1.4 MB Total.

What the lag looks like: Spinning beach ball while trying to type a FOUR letter word on the attached page (21 hyperlinks). 

Note: I've even deleted most all of the hyperlinks (less than 40) and I am still experiencing lag and freezing.

Screen Shot 2020-07-07 at 1.10.02 PM.png

Screen Shot 2020-07-07 at 2.51.34 PM.png

Screen Shot 2020-07-07 at 2.59.40 PM.png

Screen_Shot_2020-07-07_at_8_24.31_AM.png

Edited by MLeaman
Link to post
Share on other sites

I have a similar problem with Publisher in Windows 10; CPU- and memory use are soaring on almost every function up to the point that the app freezes (from which it does not recover) and after several of such problems, closing and opening the app in an attempt to get it working, it refuses to open all together and I had to re-install it to make it start up. After re-install the same problems continued.

Home: https://vectorwhiz.com  : : : :  Portfolio blog: https://communicats.blogspot.com

Link to post
Share on other sites
  • 1 month later...

I also am having issues with a document that I used to edit on an old macbook in an earlier version of publisher with no lag. My macbook died and I upgraded to a Windows 10 machine with the same 16gb ram and an SSD but this one has an 8th gen i7 whereas the old macbook had like a first gen i7.

I paste in a background and am trying to move in a small pasted vector on a 240 pg document and the thing is so laggy I can't work.

Doesn't matter if I tell it to use the integrated Intel vs the Nvidia graphics card.

 

 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.