Jump to content

Recommended Posts

Despite having a reasonable beefy computer (some i7 CPU with 8 cores, 16G of RAM and an AMD Vega 64), Designer is lagging terrible when moving stuff around, creating new vector shapes or reordering things. I recorded a little video to depict my problem:

I'm not sure what could go wrong, there is no other applications or background tasks running and the CPU as well as the graphics card are a bit bored (see the CPU load graph in the video).

I wonder what might cause this, how I can work around it and if I can't, what component might be responsible/needs an upgrade to get rid of this. I tried resetting everything to stock settings already and double checked that Designer is using the right graphics device in the settings, however, no success. :(

(I'm on Windows 7, fully updated OS and drivers)

Share this post


Link to post
Share on other sites

Hi pekranodon,

Do you get this on any document, or is just the one shown in the video? Could you try pressing Tab to hide the UI temporarily and see if that improves the situation for you please?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.