Jump to content

Search the Community

Showing results for tags 'SVG'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Affinity Support
    • News and Information
    • Affinity Support & Questions
    • Feature Requests & Suggestions
  • Learn and Share
    • Tutorials (Serif and Customer Created Tutorials)
    • Share your work
    • Resources
  • Bug Reporting
    • Report a Bug in Affinity Designer
    • Report a Bug in Affinity Photo
    • Report a Bug in Affinity Publisher
    • (Pre 1.7) Affinity Range Bugs Forums
  • Beta Software Forums
    • Affinity Designer Beta Forums
    • Affinity Photo Beta Forums
    • Affinity Publisher Beta Forums

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 376 results

  1. Web developer here, bought Affinity Designer in hopes of switching off Adobe completely. The app was great, got the job done, then I go to export the icon as an SVG and... it saves the color black as "fill:#000". Why Affinity why? :( It should save the color black with no fill tag at all, which will still appear as black, but lets web developers like me then alter the color dynamically via CSS. svg { fill: #888; } Am I hopefully just missing this setting somewhere? Kinda breaks the whole process of making svg icons. I don't want to have to use some important rule or something to overrule such a silly mistake.
  2. Hi, For some reason, when I export a file to an SVG format, some of the colours seem to warp (please see attachments – the PNG is how it should be and notice the purplish tinge to SVG version). Also, it doesn't happen with every colour. What can I do to fix this? shieldcornertest.svg
  3. I am having some issues exporting PNGs from the SVGs in this pack from kenney.nl: http://kenney.nl/content/4-assets/41-platformer-art-deluxe/platformer-art-complete-pack-0.zip The SVG file in that pack is in the following location "Base pack/Vector/tiles.svg" An example of a properly exported PNG without weird gaps is here: "Base pack/Tiles/grassCenter.png" Please find the result when I export that part of the SVG attached, it has either white gaps or transparent gaps (this depends on the section of the SVG I try and export). I understand that there isn't any overlapping of the SVG paths and believe this might be the issue. Suggestions on how to workaround this issue would be much appreciated.
  4. Dear Developers, When exporting a file to SVG with text fields (ASCII art in my case) multiple spaces are written as simple consequent spaces in the XML file. Unfortunately XML, as HTML, will display these as a single space. Declaring xml:space="preserve" as you do, unfortunately does not suffice, because it works only if the string contains only spaces. A better approach would be to use non-breaking spaces: To keep the XML more readable you could code it to change from simple to non-breaking spaces only from the second consequent (included) onwards, so that normal prose would not be cluttered. Just a thought. Thank you in advance. Kind Regards, Philip
  5. I've been using Affinity Designer for some time now but lately I've come across an issue that's turning out to be a big pain in my work. I have two files that look great in .afdesign format but once I export them to EPS, SVG, PDF or any other format the result isn't the same shown in Affinity. In one, the guy at the print shop says my shapes appear in tones of black and grey even thou they appear all black in my computer (be it in Affinity or Illustrator). The other is a drawing that, in all the formats seem to result in thicker and overlapping black lines (take a look at the background houses as an example). I've tried every type of export alternative and software program to open that I can think of, and the problem is always there. Does anyone ever ran into similar issues or know what probably is going wrong? Thank you in advance! Any input is welcome!
  6. I am adding support for SVG sprites to one of my website frameworks. I'm loving the fact that in AD I can export all the individual icons as SVG in situ from the designs supplied, rather than having to assemble them in their own separate document. Being able to select each layer, create a slice and then adjust that slice's dimensions if I need to is fantastic. The end result is I get a lot of separate SVG icons. Then I expended a lot of energy installing Node, Grunt, SVGO, you name it in order to do the following: Optimise the SVG files Create an SVG sprite Copy all the individual icons into the sprite as symbols I realised it would have been SO much easier if AD (or AP) offered the ability to export selected slices as a sprite. I thought that might be what the Continuous checkbox did, but alas, no. For reference, my starting point for this was this page: https://24ways.org/2014/an-overview-of-svg-sprite-creation-techniques/, the section beginning HTML INLINE SVG SPRITES (specifically the latter section dealing with external sprite. It would also be advantageous to me if the style="fill:#HEXCOL" could optionally be dropped on each element on export as it prevents styling the elements with CSS. Thanks for making a great app even greater.
  7. Hi, Is there a way to export images in a doc as links instead of base encoding them in the SVG. Thanks Greg
  8. Hi, There seems to be a bug when importing this SVG file: https://upload.wikimedia.org/wikipedia/commons/f/f6/Hurd-logo.svg Expected result: Result from Affinity Designer: Cheers, Wojtek
  9. Hi, An SVG/color issue: Why are colors wrong when pasting in a #SVG? Logo found here: https://upload.wikimedia.org/wikipedia/commons/e/e2/Google_Chrome_icon_%282011%29.svg I copied the raw SVG (view source, copy) and pasted it into Affinity Designer 1.4, only to see this result:
  10. Does anyone know if there is a way to force all elements converted to SVG 'path' tags rather than primitive shapes such as 'rect', 'circle' etc. Converting a simple shape elements to curves doesn't help to my surprise. Even adding extra nodes to e.g. a rect or circle shaped curve still doesn't force it exported as a path in SVG file. It is extremely critical for us due to nature of the project. Any ideas please? I was so happy to escape Adobe CC train and last I want is to jump back just for the sake of SVG exports :(
  11. I could use some help. I have some typed some phrases with glyphs and I want to export them as SVG for use with vinyl cutters. When I export the file as SVG and open it in my other software the phrase is all wonky. I have read that I would need to pull it into inkscape and trace it there but I don't seem to be able to do that either. I even downloaded an app "super vectorizer" with no luck. Can anyone give me some ideas here of what I am doing wrong? I have attached the file Kiss Me Now.afdesign
  12. Hi, I really like to draw with Designer, but sadly, I can't use it for most of my designs, because they get completely broken after pasting them to Sketch, Photoshop or Keynote: Check the append screenshots: Steps to reproduce: 1. Start Affinity Designer 2. Select Pencil 3. Set controller to anything but None 4. Draw something with Wacom (or with mouse and acceleration) 5. Select pencil strokes 6. Copy 7. Paste to Keynote, Sketch or Photoshop 8. The artifacts also appear when exporting as EPS. Assigning a brush-stroke shape with constant width removes the problem but looks ugly. Interestingly, every brush-shape preset produces different but reproducible artifacts. Does anybody else had the problem? Any hints or work-arounds? BR, tom
  13. Hi there, I have a problem with Affinity Designer.app concerning the file-size of svg-exports. When I just export a simple elipse the filesize is very small, but as soon as I add a ring to the elipse and adjust the border a bit, suddenly the exported svg turns way bigger (>100kb) because every pointer within that ring is exported instead of the figure… The same figure in Illustrator exports just fine. This seems to happen as soon as I switch the border-style from outer to inner… Is this a problem with the settings or with the svg-export-module of Affinity Designer.app? I attached the two files, same Figure, different border-style -> very different Export size as SVG Kind regards Hubi svg export bug.zip
  14. Hello, I have downloaded the trial version and have to say it is very nice. I loaded my current tvOS projects character SVG which has about 110 frames of character animations. Each frame comprised of about 30 elements. So a good test to compare to Inkscape 0.91 for performance. System is fairly maxed out 2011 iMac. Pros: Wow it is fast and scrolls in and out so smoothly Using the same keyboard shortcuts as the rest of OSX is nice as well Near perfect import of the test SVG (see cons for issues) Easy to use so far Awesome export options Cons: Clipped & Masked items in the test SVG did not import clipped or masked. This is actually quite a mess to have to clean up by hand. Color picker eye dropper was not nearly as intuitive to use as pretty much any other apps I have used. The click & hold then move selection area to color felt very awkward. Much prefer the select tool then move to area and click on color desired style eye dropper tools. Not so happy with the path node tools either. Enjoy having control arms on all three types of control nodes in Inkscape. Questions: 1. Is there something I am missing to fix the problem with Clipped elements on SVG import? I use this technique often in Inkscape so getting this right on import is important. Just to much work to fix it all by hand on every image and if I can't bring in all my old art it negates the value of moving to AD from Inkscape. 2. Is there a way to get a color picker that works more in line with the select object, select tool, select color (like inkscape) with out the need for the click/hold/drag AD uses? Being new I bet I missing something here. 3. Path node control arms for all nodes types would be nice, so am I missing the obvious on how to get them to appear? 4. I know they keep this tool up to date so I will ask about PNG export without transparency (Alpha). Anyone that is developing for Apple knows that they have moved several items to no Alpha channel and that they prefer PNG format files. The latest is Image Stacks for tvOS apps require the back most layer to not have any Alpha. So could that becomes a PNG export option? I ask about PNG because it is easier to keep all images in the same format vice a mix of PNG and JPG files. Also right now Apples tool chain for image stacks is young and mixing PNG/JPG in the stack has resulted in fun and for me it being easier to use Preview to fix the alpha channel as required and stay all PNG files. 5. Speaking of tvOS will there be an Export option to create the Parallax Images (.lsr files) added at some point? I have an idea on this might be done. Special template with 1 to 5 layers (range that Apple's LSR format allows. The export option would export each layer into the LSR file (layer 1 being back most) and then counting up from there. It would sure be awesome to have something like this for AD given that Apple released a plugging for PhotoShop to do just this. Again great product. Loving the trial version. Besides the clipped and masked objects not importing correctly I am thinking this is a clear move from Inkscape for me. Look forward to hearing back. Matt
  15. Hello! When I take a vector-only .afdesign file, and place it into another vector-only .afdesign file, all the placed documents end up being rasterized. If I choose not to rasterize, they simply don't appear in the SVG file at all. This makes my SVG files huge (what will normally be a 5KB file will balloon to 150KB on export), and also makes them look really fuzzy. This is particularly problematic when I am making diagrams by taking pieces of dozens of different design elements and placing them into a single file. I've attached two versions of the file below: one with a vector (bob), and one with that vector placed into the same size document (bob-placed). As you can see, bob.svg is only 4.87KB in size, but bob-placed.svg ends up being 496KB. bob.afdesign bob.svg bob-placed.afdesign bob-placed.svg
  16. Hello! I have two very similar files with little figurine people in them. Neither one of them has a lot of complicated curves, they both have a few radial gradients, etc. Alice exports to a 4.5KB SVG file, but Bob exports to a 360KB SVG file, and I cannot figure out why. The Bob SVG file just has a zillion points in it, for no particular reason. If anybody can help me figure out why the Bob file is exporting to something so huge, it would be a great relief. Thanks so much! alice.afdesign bob.afdesign alice.svg bob.svg
  17. Affinity Designer 1.3.5 I have a lot of Visio flowcharts that I would like to bring into designer so I created a flowchart test file in Visio from which I exported all the objects to SVG. The following 2 issues occur when I open this SVG file in Affinity Designer: The text that is normally center shifts to the right. The direction arrows on the connection lines disappear. Yet the SVG renders properly with a 3 finger tap preview or opening this SVG in Safari. Here are 3 screen shots that show this. 3 Finger Tap Preview Open in Safari Open in Affinity Designer I have also attached the test SVG file to see if you can reproduce this. Visio 2010 Test Flow Chart 2015-10-08.svg Let me know if you also need the Visio file.
  18. Hey guys, I ran into a really unfortunate bug in the latest Affinity Designer beta as it seems, probably existent in the previous versions, too, as I was wondering about it then already. I need to export a graphic that contains strokes – I tried several options, nothing worked as expected: every single stroke gets converted/expanded into a filled shape! For now I try to get the shapes exported via the latest official App Store release of Designer, neither works for me. Is it just me, did I check a box or something, maybe someone can provide another solution for this? -_- Right now it’s not helpful at all and very, very inconvenient – I sincerely hope this gets fixed for the next beta! :( Here’s a quick outline-view-example. The original form has a stroke of about 12 pt that gets converted into a shape if exported as a PDF or other vector based formats, regardless of thickness or position (inside, middle, outside). Cheers Dennis
  19. Make a document with a few colors, export to SVG, open SVG in browser, colors are all wrong. That seems like a bug. Similarly if you go to Document Setup and switch color spaces I'd expect at least the option to convert the colors. Thoughts?
  20. I am working in AD and I need my file to be able to be opened in AI. I saw somewhere that svg is best if you have clipping masks. So I tried all and it the file gets rasterized weird and is not usable at all, and I get the Clipping will be lost on roundtrip to Tiny message. What blows my mind is that Inkscape gives me the file intact along with all the clipping masks and everything! Any clue anyone?
  21. After installing the Affinity Designer via the App Store I dragged in a complicated SVG in to play around with for the first time. Nothing happened except for the app opening and freezing. I'm unable to use any of the app menus. I just hear error beeps when I click in the window. When control clicking the Affinity icon in the system dock it appears that the initial SVG file is hung importing (it never makes progress). I can only close the app at this point via the "Force Quit" menu. This is preventing me from using the app in any way. I tried renaming the file but it still somehow attempted to open the renamed version on the next launch. While writing up this report I tried deleting this file and that did prevent it from having the freeze on open issue. The app freezes now anytime I attempt to make a new document. I've tried reinstalling the app but it does not help the issue. A few questions: - Is there any way I can stop the app from freezing. - Is Affinity choking on SVGs a common thing? Can I send you files that break the app in the future as bug reports? - I'm running the latest OSX beta (OS X 10.11 15A243d). Is this a known issue with that? Am I just out of luck and money with your software until the beta is final?
  22. I have spent a few hours playing with the trial version of Designer. It seems to work like a charm, however, I don't seem to be able to export SVG images with CSS style sheets, either external or internal (CorelDraw works quite good in that respect). In Designer, all SVG style information appears to be in the form of in-line styles, resulting in unnecessarily large file sizes and making it difficult to use various css features and/or script manipulation of SVG images. Is this something you may be considering for future—hopefully not very distant—releases?
  23. I have a very simple SVG file that was originally created in svgedit, and when trying to open it, Designer just hangs (uses 100% CPU, consumes more and more memory) until I kill the process in Activity Monitor. I have attached the file here. Is this a known issue? I should be able to open the SVG file from the "Open..." menu or by dragging it onto the dock icon, correct? Is the file from svgedit malformed in a way that's confusing Designer? My info: OS X 10.7.5 Mac Pro 1.1 (it's pretty old) 2x2 Ghz Dual-Core Intel Xeon 12 GB RAM NVIDIA GeForce 7300 GT 256 MB I love both Designer and Photo so far. I'll do whatever I can to be helpful in resolving this issue. sphere.svg
  24. Is it possible to support an exported file from Inkscape that miss these...? - Corner Radius (Can be solved by turning curve to outline object) - Masking is lost **About masking; the SVG file which export from Illustrator, masking is lost too, but .ai .eps still work.
  25. Hello, if you try to open SVG with dx and/or dy attributes in text- or tspan-tag, Affinity-Designer ignores this. <text x="30px" y="30px" style="font-family:Verdana;font-size:12px;fill:#000;" dx="0,1,1,1">TEST</text> <text x="30px" y="60px" style="font-family:Verdana;font-size:12px;fill:#000;"><tspan dx="0px,1px,1px,1px">TEST</tspan></text> <text x="30px" y="90px" style="font-family:Verdana;font-size:12px;fill:#000;">TEST</text> Line 1 and 2 should a text with 1px space between each character. This does not work. It looks the same as the result of line 3 without any dx-attribute. Kind regards, Oliver
×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.