Jump to content
OldGoat

Photo opens but crashes when starting a new project or opening an image

Recommended Posts

My photo refused to open anything this morning. Ver 1.7.2.471, windows 10.
Noticed when I tried to open an image "open with" Affinity Photo it started to launch then just closed. I then opened photo and it launched OK but then closed as soon as I tried to start a new project.

I often leave my PC on and rather let the PC "sleep" than shut down. When I couldn't fix the error, I rebooted my PC and all started to work normally. Photo now OK.


Oldgoat Marketing - For all your internet marketing needs

Share this post


Link to post
Share on other sites

Hey OldGoat,

Is this the first time it has happened? I'm not able to reproduce it on a whim and the only bugs we've seen with Sleep mode are macOS related. It may be worth seeing if you got a crash report in %AppData%\Affinity\Photo\1.0\CrashReports\reports to see if we can figure out what happened.

Share this post


Link to post
Share on other sites

Hi. Exactly the same happens to me and it is more, it also happens to me in Affinity Designer. The software opens but closes immediately and when it manages to open it remains stuck trying to open a recent file. I had to reinstall affinity Photo and Affinity Designer and the problem is fixed but in a couple of days it starts to fail again. This started to happen to me after the last update ... what could it be? ... I urgently need to solve this since I use these software for my work.
Best regards
Note: Sorry for my English, it is translated by google translator

Share this post


Link to post
Share on other sites

Can you see if this issue also occurs with Hibernation mode?

I've also done a bit of research and it has been suggested to make sure that your graphics drivers are also fully up to date.

Share this post


Link to post
Share on other sites

Hi Chris B. Along with greeting you, I comment that I do not use the hibernation mode or the sleep mode. My laptop is always running and when I stop using it, I simply turn it off. Today, for example, I had to double click on the Affinity Photo executable since the first time it started to open but when it came to the moment to open a new document or some work done previously, it closed immediately and on the second attempt it was placed in functioning. I also tell you that before I had it installed on a second SSD drive and now I tried to install it on drive C: / which is also an SSD and the same fault occurs. This did not happen to me before and I have been using Affinity Photo for several years.

Best regards


Nota: Perdón por mi inglés, está traducido por el traductor de google

Share this post


Link to post
Share on other sites

In that case, please uninstall your graphics drivers and reinstall them. Do not simply check for updates and install any found updates.

We've seen this happen quite a bit and the fresh install of graphics drivers usually sorts it. I would also check the list of known software conflicts:

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.