Jump to content

Recommended Posts

In the View menu on the Tool Bar "Preview Mode" is shown as Control + W, but nothing happens and my MacBook makes that 'boop' noise that it does when no action can be completed at this time. Am I pushing the wrong keys, or is this a bug?

Share this post


Link to post
Share on other sites
21 minutes ago, HearIsMatt said:

In the View menu on the Tool Bar "Preview Mode" is shown as Control + W, but nothing happens and my MacBook makes that 'boop' noise that it does when no action can be completed at this time. Am I pushing the wrong keys, or is this a bug?

Are you sure it's showing Control, and not Cmd?


-- Walt

Windows 10 Home, version 1909 (183623.476), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.3.481 and 1.8.0.514 Beta   / Affinity Designer 1.7.3.481 and 1.8.0.514 Beta  / Affinity Publisher 1.7.3.481 and 1.8.0.518 Beta

Share this post


Link to post
Share on other sites

Yes, that's Ctrl. Sorry; I thought the default on Mac was Cmd for that one.

 


-- Walt

Windows 10 Home, version 1909 (183623.476), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.3.481 and 1.8.0.514 Beta   / Affinity Designer 1.7.3.481 and 1.8.0.514 Beta  / Affinity Publisher 1.7.3.481 and 1.8.0.518 Beta

Share this post


Link to post
Share on other sites

Command-W is the nearly universal shortcut for closing a window (thus, closing a document, as in Publisher).

Control-W should work, but I occasionally get Publisher in a state where I get the alert sound with any keyboard input I try, including command-Q (quit). I wish I could figure out how to get it in that state so I could report it. So far all I can do is to quit from the menu, and when I restart Publisher, all is right again.

Share this post


Link to post
Share on other sites
54 minutes ago, garrettm30 said:

Command-W is the nearly universal shortcut for closing a window (thus, closing a document, as in Publisher).

That's similar to Windows, where Ctrl+W is the shortcut for closing a document or window (but not the application window). So, on Windows, the Preview Mode shortcut is Ctrl+Shift+W.

It's interesting that the Affinity default on Mac isn't simply Cmd+Shift+W, to match the Windows Affinity default.


-- Walt

Windows 10 Home, version 1909 (183623.476), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.3.481 and 1.8.0.514 Beta   / Affinity Designer 1.7.3.481 and 1.8.0.514 Beta  / Affinity Publisher 1.7.3.481 and 1.8.0.518 Beta

Share this post


Link to post
Share on other sites
2 hours ago, garrettm30 said:

Command-W is the nearly universal shortcut for closing a window (thus, closing a document, as in Publisher).

Control-W should work, but I occasionally get Publisher in a state where I get the alert sound with any keyboard input I try, including command-Q (quit). I wish I could figure out how to get it in that state so I could report it. So far all I can do is to quit from the menu, and when I restart Publisher, all is right again.

that's pretty wild, actually. never heard of cmd+q not working. i guess there's still a few bugs

Share this post


Link to post
Share on other sites

Hi @HearIsMatt,

Sorry for the delayed reply. 

I can only get that sound if I press Fn+W (instead of Ctrl+W). Have you changed your FN and CTRL buttons System Preferences > Keyboard > Modifier Keys ? 

Thanks,

Gabe. 

Share this post


Link to post
Share on other sites

Hi @gabriem

i have not changed any buttons. the shortcut for preview mode just does not work the the indicated shortcut for some reason. i've tried other combos but nothing works. 

Share this post


Link to post
Share on other sites

Go to preferences > Keyboard Shortcuts > View and try to assign a different shortcut. See if that works. If it does, you might have a different system app or system shortcut that's using CTRL + W and conflicting with our shortcut. 

Share this post


Link to post
Share on other sites

@GabrielM so i just tried and control + w works now. i got a new laptop since i made this post, so maybe it had something to do with that machine. to be clear, i did not get a new laptop to fix this issue LOL i was upgrading anyway. thanks for the tip though!! much appreciated.

Edited by HearIsMatt
tag the person i am responding to

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.