Jump to content
Ron99

Problems getting a transparent background on PNG

Recommended Posts

Hi all.

I'm having trouble getting a transparent background on an exported PNG.  I'm using AD on ipad.  Here's the scenario:

I've imported a .ai file of a speech bubble and want to export 'as-is'  as a transparent PNG.  When I export the file, I'm seeing the bubble as a square image with a grid in in the background (see screenshot - blue background)

Here's what I've tried.  Each time, I get this grid in the background:

1. Gone to file -> Canvas -> set 'Transparent Canvas'

2. Deselected all.  Export persona -> selected top level slice (whole page) -> selected PNG -> exported

3. Pixel persona -> Selected all -> Export -> select PNG -> Area: 'Whole Document"

4. Pixel persona -> Selected all -> Export -> select PNG -> Area: 'Selection without background"

I'm really confused.  I would have thought that the image has transparency by default.  Why is AD adding this grid background (which in my limited, novice's understanding normally represents transparency)??

What am I doing wrong?

Thanks in advance!

 

CleanShot 2019-07-20 at 13.01.58@2x.png

AD_PNG export settings.png

Share this post


Link to post
Share on other sites

I can’t help sorry, but I too am interested in finding an answer. I’m not finding this setting transparency thing at all intuitive yet.

Is it possible to put the original .ai file somewhere accessible? Or have you since posting, solved the problem?

Share this post


Link to post
Share on other sites

Hi,

When you go to export make sure you have the cloud image selected, then when you go to Export as png, you will get the option in the Area settings to choose: 'Selection without background', at the moment it looks like that is greyed out in your settings and the whole document is getting exported.

Share this post


Link to post
Share on other sites

Thanks. I’ll give that a try. I’m out at the moment. Which reminds me,  if that imported image of the cloud has a transparent background, why can’t I see the blue background?

thanks

robert

Share this post


Link to post
Share on other sites
29 minutes ago, HarryMcGovern said:

if that imported image of the cloud has a transparent background, why can’t I see the blue background?

I would think it was probably not transparent when it was imported or got flattened and rasterised because some of the effects added (like the drop shadow) were not supported.

Share this post


Link to post
Share on other sites
22 hours ago, Ron99 said:

Why is AD adding this grid background (which in my limited, novice's understanding normally represents transparency)??

Are you saying that you only see the chequerboard on export, not within AD? :/


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.3.481 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.8.2.174 • Designer for iPad 1.8.2.4 • iPadOS 13.3.1 (iPad Air 2)

Share this post


Link to post
Share on other sites

Hi Ron99 :)

Could you please post a copy of your Affinity or AI file so we can look into this further please? As Alfred above, I too am confused that you're seeing a chequerboard after export!

Share this post


Link to post
Share on other sites
7 hours ago, HarryMcGovern said:

I can’t help sorry, but I too am interested in finding an answer. I’m not finding this setting transparency thing at all intuitive yet.

Is it possible to put the original .ai file somewhere accessible? Or have you since posting, solved the problem?

Hi Harry.  I was about to post the .ai file, but I realised I'd be in breach of the license from Adobe.  Sorry.  

Share this post


Link to post
Share on other sites

Thanks all for your input on this - I've just found an answer!

It turns out that the .ai file included a checkerboard image within the artwork!!  I only realised when zooming, and noticed that the checkerboad squares were zooming too.

So it wasn't an AD issue at all - really annoying though!  One to watch out for.

Thanks for your input folks!

Share this post


Link to post
Share on other sites
6 hours ago, Alfred said:

Are you saying that you only see the chequerboard on export, not within AD? :/

 

5 minutes ago, Ron99 said:

Thanks all for your input on this - I've just found an answer!

It turns out that the .ai file included a checkerboard image within the artwork!!  I only realised when zooming, and noticed that the checkerboad squares were zooming too.

Thanks for confirming my suspicions!


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.3.481 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.8.2.174 • Designer for iPad 1.8.2.4 • iPadOS 13.3.1 (iPad Air 2)

Share this post


Link to post
Share on other sites
6 minutes ago, Ron99 said:

Thanks all for your input on this - I've just found an answer!

It turns out that the .ai file included a checkerboard image within the artwork!!  I only realised when zooming, and noticed that the checkerboad squares were zooming too.

So it wasn't an AD issue at all - really annoying though!  One to watch out for.

Thanks for your input folks!

Wow, that’s a real trap. Glad you spotted it.

Share this post


Link to post
Share on other sites

I am having a similar issue with saving png files as transparent.

1. I created a transparent document at the start.

2. Selected Export, turned switch off by matte background, selected png and no matter what I do it saves with a white background, even when I do it by selection, and selecting selection without background.

3. The screenshots of the picture were loaded into procreate after exporting from designer but this is what it looks like. Procreate supports png files.

I am including screen shots of what it looks like when exported.

Any help would be greatly appreciated.

 

Thanks,

Cheryl

IMG_1176.PNG

IMG_1174.PNG

IMG_1177.PNG

IMG_1175.PNG

Share this post


Link to post
Share on other sites

Hi Cheryl53

Im not having a problem importing transparent png’s into procreate.

I’m using the ‘Share’ option in export tho and saving images to my photos, bringing them into procreate that way.

You don’t say if your using Photo or Designer? Try clicking on the settings burger menu in the layers (3 lines in box) and check the box for:  Checkboard Background.

As you’ve mentioned, make sure the item on your canvas is selected (blue marquee) and that you have the ‘Selection without background’ set in ‘Area’  on the export dialogue page. Maybe the issue is where you are exporting too and some kind of bug.

Share this post


Link to post
Share on other sites

Ok. So when I export the png to the files app instead of saving to camera roll via share option it saves with transparent background. I’ve not had that issue before. Strange. 

Share this post


Link to post
Share on other sites

Hmm. That is a weird one.  Perhaps files are converted to jpgs automatically when saved to the camera roll? Dunno. Still - good to hear you have a fix for your issue Cheryl53. :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.