Jump to content
Steve-K

Publisher - How can I select all text in a document?

Recommended Posts

How can I select all the text in a document? The background is that the spell check language is set to English and the actual language of the document is German. I wish to select all the text in the document and change it in one fell swoop from English to German.

I have tried selecting all the pages in the "Pages" window on the left of the UI, and I have tried selecting all the Text Layers in the Layers window on the right of the UI, but unfortunately neither of them worked. Interestingly, selecting the Text Layers did seem to select all the Text Boxes in the document, but when I changed the language in the Character Tab, it had no effect.

Thanks for any help!

Steve

Share this post


Link to post
Share on other sites

Welcome to the Serif Affinity forums, Steve.

If you've used a paragraph style for your text, you could change the language there.

Or, if the Text Frames are linked, clicking in one of them and doing a Ctrl+A will select the text from all the linked frames, I think.

 


-- Walt

Windows 10 Home, version 1903 (18362.239), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.2.471 and 1.7.3.476 Beta   / Affinity Designer 1.7.2.471 and 1.7.3.476 Beta  / Affinity Publisher 1.7.2.471 and 1.7.3.475 Beta

Share this post


Link to post
Share on other sites
1 minute ago, walt.farrell said:

if the Text Frames are linked, clicking in one of them and doing a Ctrl+A will select the text from all the linked frames, I think.

You think right with the caveat that on Mac it is Command + A


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.2 | Affinity Photo 1.7.2 | Affinity Publisher 1.7.2 | Affinity Designer Beta 1.7.2.2 | Affinity Photo Beta 1.7.2.151 | Affinity Publisher Beta 1.7.2.458

Share this post


Link to post
Share on other sites

Thanks for the warm welcome and rapid response, Walt!

Unfortunately neither of those two prerequisites apply.

There is no paragraph style and the text frames are not linked.

I should perhaps explain that the document in question is a PDF which I imported for experimentation purposes. Nonetheless it seems a bit peculiar that there doesn't appear to be a straightforward way to select all text frames...

Share this post


Link to post
Share on other sites

The frames in a PDF are not linked.


MacBook Pro (13-inch, Mid 2012) Mac OS 10.12.6 || Mac Pro (Late 2013) Mac OS 10.14.5

Affinity Designer 1.7.2 | Affinity Photo 1.7.2 | Affinity Publisher 1.7.2 | Affinity Designer Beta 1.7.2.2 | Affinity Photo Beta 1.7.2.151 | Affinity Publisher Beta 1.7.2.458

Share this post


Link to post
Share on other sites

Create a new paragraph style which includes German as the spelling language

Find and replace all occurrences of

Paragraph Style [No Style]

to

Paragraph Style [whatever you called your new paragraph style]


Due to the fact that Boris Johnson is now our Prime Minister, punctuation, spelling and grammar will never be worried about ever again.  We now have far bigger problems to be concerned about.

Share this post


Link to post
Share on other sites

Thanks, Carl!

Your proposal is definitely on the right track. Unfortunately, though, I'm having some difficulty implementing it.

I have set the new paragraph style to German language spelling and have set the font characteristics as shown in the first attachment (no change to all parameters). However, when I run a find and replace, the text ends up being deleted and I am left with a lot of text frames with no text in them.

688779089_Screenshot2019-07-01at12_57_47.thumb.png.a67e683959321b8452248c03ec26f9b4.png

Interestingly, if I run the same find and replace with the text size set to, say, 12pt, (second attachment) then the language is indeed changed to German, but of course all the text is then converted to 12 pt throughout the document.

439600077_Screenshot2019-07-01at13_07_50.thumb.png.122f22986d8d446111a7df0d50208a67.png

I'm not sure what is going on there.

 

Share this post


Link to post
Share on other sites
27 minutes ago, Steve-K said:

I'm not sure what is going on there. 

 

Me neither, my settings appear to be the same as yours and it works OK here

But I am on Windows and you are on a Mac so maybe that is a factor that may be involved

If you could redo the procedure from scratch to get the "no text" result and upload that document with the history saved, it might shed some light on what is happening

 

textstyle.png


Due to the fact that Boris Johnson is now our Prime Minister, punctuation, spelling and grammar will never be worried about ever again.  We now have far bigger problems to be concerned about.

Share this post


Link to post
Share on other sites

So, I have just repeated the procedure once again from a clean start after shutting down the computer in the meantime. This time it has worked without deleting the text. Everything has worked as it should do - all text is now set to German as the language.

Thanks once again, Carl!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×