Jump to content
NataliePH

Constant freezing and crashing

Recommended Posts

Hi,

I'm a long time user and fan of Affinity Designer - I've been using the desktop version since Beta. But over the last month or so after using it since release with no issues at all Affinity Designer on my iPad has begun to freeze and then crash. 

I will be working in a document using the pencil either drawing in vector (most common) or colouring in pixel and suddenly the app no longer responds to any interaction - gesture or pencil. The only way to escape is to close the app from home and then to reload, invariably using large chunks of work including work that I have actively saved. It's incredibly frustrating, sometimes I get no more than 2 or 3 strokes before the crash, and so I have had to return to using a wacom and macbook in order to work.

I am not working on particularly large documents and have plenty of storage space. I've tried the obvious turn it off and on again, as well as changing the auto-save to no avail. I have the pen set to pressure with no stabilisers. I don't rest my hand particularly hard on the screen and have even tried to place a book between my hand and the screen in case that was causing interference.

I haven't produced a screen record of the issue because nothing specific triggers it and there are no error messages/indications.

I'm using 1.7.1 (although I had the same issue in the version before) on a 12.9 inch iPad Pro (second generation).

I'm completely at a loss.

Share this post


Link to post
Share on other sites

Hi NataliePH,

Welcome to the Affinity Forums! Sorry for the delay in responding, there is a known issue that can cause the tool to get stuck, so you cannot switch tool, however this is resolved by just drawing on the screen. 

Does this only happen on specific documents, or have you had it on a new document. Once it goes wrong are you able to use a phone to record an example that shows the behaviour? 

Thanks!

Share this post


Link to post
Share on other sites

Hi MichaelMeeuwissen,

This definitely looks like the problem I mentioned. In your video you can see a very small selection marquee stuck in the top of the screen. This disappears once you go into the iPad pull down menu. If you just tap on the actual work area it should correct the selection and sort you out. This has been fixed by development and will be in the next release.

Share this post


Link to post
Share on other sites

Hi Sean,

It happens on all documents, typically when I am drawing using vector often mid-line or just as I've finished. The entire screen is unresponsive, whether I try to draw using a finger or the pencil nothing happens. The only way to get back into the frozen document is to double tap the home button, close the affinity window and then reopen often losing large chunks of my work.

As this isn't caused by a specific action, it's hard for me to film - I don't know when it's going to happen. When it freezes it just looks like a normal window. 

Thanks,

Natalie

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.