Jump to content
Nathan Shirley

Page number formatting changes not taking effect

Recommended Posts

I've got a project with page numbers setup in master pages. I made an adjustment to them, removing underlining from the # symbol in the master pages, but it didn't take effect on the project pages. I had to manually re-apply the master pages to each page in the project to get it to update. I assume that's not by design?

Share this post


Link to post
Share on other sites

It should update if the frames containing the page numbers haven't been detached from the master page.

I assume if you make another change now (remove the underline, change colour etc) everything behaves as expected?


Serif Europe Ltd. - www.serif.com

Share this post


Link to post
Share on other sites

Hmm, that's very strange. I'm almost positive the master pages were attached to the pages in the project as I remember specifically testing it by adding a seperate element to the master pages which took effect on the project's pages, but changing the page number format didn't take effect. But now when I try it the changes take effect as they should.

I'll post back if I figure out how to reproduce it again.

Share this post


Link to post
Share on other sites

Still having issues with this.

The master pages seem to be properly attached (tested by creating new element in master pages which shows on attached frames). However if I try to change anything about the page numbers in the master pages, the frames don't change. If I copy a page number (# symbol) and paste it elsewhere in the master page it will pass changes through to the attached frames... but no changes to the original page numbers pass through.

Strange.

(by the way this is now the latest version, not beta)

Share this post


Link to post
Share on other sites
7 minutes ago, Nathan Shirley said:

Still having issues with this.

The master pages seem to be properly attached (tested by creating new element in master pages which shows on attached frames). However if I try to change anything about the page numbers in the master pages, the frames don't change. If I copy a page number (# symbol) and paste it elsewhere in the master page it will pass changes through to the attached frames... but no changes to the original page numbers pass through.

Strange.

(by the way this is now the latest version, not beta)

If you can provide a sample file that demonstrates it, we might be able to spot what's wrong. For example, you could save a copy of your document with only a couple of the affected document pages, and the Master page, included. Open it and verify that the problem still exists, and then attach that reduced copy here.


-- Walt

Windows 10 Home, version 1909 (183623.476), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.3.481 and 1.8.0.514 Beta   / Affinity Designer 1.7.3.481 and 1.8.0.514 Beta  / Affinity Publisher 1.7.3.481 and 1.8.0.518 Beta

Share this post


Link to post
Share on other sites

Thanks.

I renamed the page number layer on the left-hand master to make it easier to find, and that change passed through to the pages. I then changed the color of the text for that page number, and as you indicated, the color did not pass through to the document pages.

Here's the Layers panel for page 2:

image.png.666e545c6529cc13d8c88c01155f1361.png

Note the orange bars on the left edge of each layer. The broken orange bars indicate that you have done an Edit Detached and modified something in that layer. Whatever attribute you changed has been detached from the master, to protect it from further changes made on the master. If you hover over the layer title you'll get a tootip telling you what has been detached, and that says "Unlinked attributes: Text"

That should mean that you edited that text, which is preventing further changes being applied from the master.

As far as I know there is no way to fix that, other than deleting the layer on the master page and recreating it.


-- Walt

Windows 10 Home, version 1909 (183623.476), 16GB memory, Intel Core i7-6700K @ 4.00Gz, GeForce GTX 970
Affinity Photo 1.7.3.481 and 1.8.0.514 Beta   / Affinity Designer 1.7.3.481 and 1.8.0.514 Beta  / Affinity Publisher 1.7.3.481 and 1.8.0.518 Beta

Share this post


Link to post
Share on other sites

I am not sure if I quite followed  but you can reapply the master page items and restrict the effect to just a specific page area (the default being the currently selected pages), from within the Pages panel. Select the page(s) to which you want to reapply a master page (you can pick individual multiple pages by holding down the Ctrl key, or successive pages by holding down the Shift key), right click and choose "Apply Master", then confirm the master page to be applied, and the page range, and whether you wish to replace the current master page items on affected pages (which you probably do, so that there is no need to manually remove anything from the pages). If you want to reapply a specific master page to the whole document, you can do that more easily by selecting the master page from the Master Pages panel and choosing "Apply Master to Pages" command from the context menu.

But no idea what initially caused your page numbers to lose links to the page number items on the master page (could be an issue related to different versions of Affinity Publisher).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.