Jump to content

Recommended Posts

When I place an image – by dragging or tool / jpg or tiff – it appears to have an "Image DPI" which always is my document resolution. This makes, in an 300 dpi document, screenshots always appear with about 1/4 of their size only. The use of the nice button "100%" does not help here.

This is especially weird because Resource Manager does recognize and tell the correct image DPI.
So the bug seems to be that the images DPI becomes ignored by the place action.

Furthermore there seems to be a UI bug in the image info line at the upper left of the main window: There an image dimension always is given in pixels, regardless of a documents millimeter preference. Here again the Resource Manager is aware about the correct info and shows the image size in millimeter.

 

p.s.: It reminds me to an earlier topic where the issue was vice versa: placed images appeared in 72 DPI, even 300-dpi-images.
https://forum.affinity.serif.com/index.php?/topic/66358-affinity’s-running-gag-not-honouring-resolution/

 


macOS 10.12.6,  Macbook Pro 15" + Eizo 24"

Share this post


Link to post
Share on other sites

Hi @thomaso,

We have fixed the 1:1 button and it should be working once the next build is up on the forums. 

I've closed this issue as fixed, but please come back if it's still broken for you. 

Thanks,

Gabe. 

Share this post


Link to post
Share on other sites

Hi Gabe,

It' still broken in 1.7.0.312 - to be sure that there is not a problem with ImageMagick or with my existing (big) .afpub document I've tried to reproduce it with a new image and a new document:

  • Created a new 72dpi image in Affinity Photo (1.6.5.123)
  • Save this document as .afphoto
  • Export the image as .png
  • create new Affinity Publisher Document (300 dpi)
  • drag and drop the .png into the publisher document - it is scaled to 300dpi - which is also shown in dpi-box in the upper left corner (I would expect it to be 72dpi)
  • after ressing pressing the "original size" button changes the image back to 300dp (I would expect it should resize it back to 72dpi)
  • I've also tried to drag&drop the .afphoto into the publisher document - this is correctly embedded with 72dpi - BUT - no dpi-control is available (but an edit document button)

Note: in the resource manage the orignal DPI is shown correctly for both .png and .afphoto

Note: I've also tested using .jpg instead of .png - same results.

Thanks, Christian

Share this post


Link to post
Share on other sites

Hi @GabrielM,

indeed in v312 Resource Manager doesn't report the Placed DPI always as documents DPI any more, thanks!

But the "Original Size" button seems to be better named "Set to Documents DPI".

Not broken but possibly disturbing is the fact that a placed image gets its Placed DPI from the .afpub documents DPI: that forces the momentary 100% button to make a linked file appear in a different size than possibly expected, if the DPI of the linked file is different to the .afpub documents DPI. For instance if one layouts a printed manual with screenshots – they all get placed at first in for instance 300 dpi (= appear quite small on page) and can't get reset to their original visual size by using the 100% button.

However, the momentary button is useful, too:

A probably more often use of this button supports layouts where document page size is different to print size, for instance: Fair trade exhibition walls in scale 1:10 (cause a PDF may not be larger than 500 cm). In such a case the .afpub document might have for instance 2000 dpi (to achieve a print with 200 dpi) and therefore it is useful to get placed any image in 2000 DPI as well, to print them in 200 dpi.

Conclusion: to finally prevent irritation it either needs two buttons ("Use Document's DPI" / "Use image's DPI") or for instance an additional checkbox like "Ignore documents DPI" besides the button "Original Size" to define the button's functionality.


macOS 10.12.6,  Macbook Pro 15" + Eizo 24"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×