Jump to content

Recommended Posts

Hello Community,

I've already asked that in the past and saw others complain about it, but there does not seem a real solution? However when I watch video tutorials from other professionals, I don't see them having the issue with snapping:

I want to snap two objects together, but I mostly end up with a thin line between them.

1) Here you can see my current snapping options. Also I've created a black rectanglewd1.thumb.png.b9118e7fdc2514ae5398e46e68c13f8b.png

 

2) I duplicate the rectangle and "try" to snap both together.

wd2.thumb.png.ff2a644c5033f0d6dab279c6c6a0fabb.png

 

3) Once I let go of the mouse, I end up with the fine thin line inbetween the rectangles

wd3.thumb.png.0a4592101b6f2b2908afec40625e6ec0.png

 

4) When I export it, it looks like this:

wd4.thumb.png.354b1d2e6fbfac3f1b35b126b994b1a0.png

 

I have no idea what to do about it, but I really have run out of energy on this one .... Can anyone help out here?

Share this post


Link to post
Share on other sites

Hi Burian,

Welcome to the forums :)

Usually this is just down to the apps anti aliasing however it shouldn't happen on export. If possible could you provide the file in question?

Thanks

Callum

Share this post


Link to post
Share on other sites

Hello @Callum
and thanks for the mega fast reply.

I was angry before and deleted the file. I tried to recreate it and of course this time it did NOT happen after the export.

However when I turned off the outlines, the line is there again (Which I don't want). The .afdesign and the exported image are attached.

I really appreciate your time!

udud.png

whiteLineSnapping.afdesign

Share this post


Link to post
Share on other sites

The line will appear when working on the document unfortunately there is no way to disable anti aliasing at the moment however this has been logged.

Thanks

C

Share this post


Link to post
Share on other sites
9 minutes ago, Callum said:

unfortunately there is no way to disable anti aliasing at the moment

You can use the Coverage Map to adjust the antialiasing of the edges of vector objects:

 


Alfred online2long.gif
Affinity Designer/Photo/Publisher 1.7.1.404 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.7.1.143 • Designer for iPad 1.7.1.1 • iOS 12.3.1 (iPad Air 2)

Share this post


Link to post
Share on other sites

The rectangle is at a non integer position an has a non integer hight. And move by whole pixels is turned on.

Maybe this is the cause of the line showing up on export.


intel core i5,  16GB 128Gb ssd win10 Pro Huion new 1060plus.

philips 272p 2560x1440px on intel HD2500 onboard graphics

Razer Tartarus Chroma

Share this post


Link to post
Share on other sites

Hi @Alfred,

thank you for linking that post. Now the white line vanished from the .afdesign and the export files.

I don't really understand what happened there, so I got to do some research I guess. Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×