Jump to content
iambia

Quitting on Start

Recommended Posts

Added fonts via the fonts tab and some brushes. The app is now periodically quitting on start. Reinstalled it. Issue continues. Quits on start.


----------------------------------------
i am everything. i am nothing
therefore, i can be anything

Share this post


Link to post
Share on other sites

Hi iambia,

Very odd, can you remember the names of the fonts and brushes?

To try and get Affinity back working, try the following:

Could you uninstall the app, turn the iPad off and back on again, then reinstall the app.

 

Share this post


Link to post
Share on other sites
6 hours ago, stokerg said:

Hi iambia,

Very odd, can you remember the names of the fonts and brushes?

To try and get Affinity back working, try the following:

Could you uninstall the app, turn the iPad off and back on again, then reinstall the app.

 

Far too many fonts to list. And then there is no simple way to capture all of them via screenshot. Will reinstall.


----------------------------------------
i am everything. i am nothing
therefore, i can be anything

Share this post


Link to post
Share on other sites
6 hours ago, stokerg said:

Hi iambia,

Very odd, can you remember the names of the fonts and brushes?

To try and get Affinity back working, try the following:

Could you uninstall the app, turn the iPad off and back on again, then reinstall the app.

 

Pretty strange. I did exactly as you suggested. I uninstalled. I restarted. Then I reinstalled. I tried to open the app and it quit! I did nothing but attempt to open it and it just shut down.


----------------------------------------
i am everything. i am nothing
therefore, i can be anything

Share this post


Link to post
Share on other sites
9 hours ago, stokerg said:

Hi iambia,

Very odd, can you remember the names of the fonts and brushes?

To try and get Affinity back working, try the following:

Could you uninstall the app, turn the iPad off and back on again, then reinstall the app.

 

I notice something else strange. When I reinstalled it, the fonts I had previously installed are still there. I thought it should remove everything and clean install the Affinity Photo app. If not, is there something else I need to delete to get it to install without the fonts?


----------------------------------------
i am everything. i am nothing
therefore, i can be anything

Share this post


Link to post
Share on other sites
1 hour ago, iambia said:

I notice something else strange. When I reinstalled it, the fonts I had previously installed are still there. I thought it should remove everything and clean install the Affinity Photo app. If not, is there something else I need to delete to get it to install without the fonts?

How did you install the fonts? Was it via the Fonts tab in Affinity Photo, or via a configuration profile in the Settings app, or both? ears.gif


Alfred online2long.gif
Affinity Designer 1.6.5.123 • Affinity Photo 1.6.5.123 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.6.11.85 • Affinity Designer for iPad 1.6.4.45 • iOS 12.1.1 (iPad Air 2)

Share this post


Link to post
Share on other sites

via fonts tab, as i wrote in my initial query. 


----------------------------------------
i am everything. i am nothing
therefore, i can be anything

Share this post


Link to post
Share on other sites
3 minutes ago, iambia said:

via fonts tab, as i wrote in my initial query

My bad. So you did! oops.gif

I vaguely recall a previous discussion about ‘deleted’ fonts still showing up in that list. I’ll try to track it down if you can’t find it yourself.


Alfred online2long.gif
Affinity Designer 1.6.5.123 • Affinity Photo 1.6.5.123 • Windows 10 Home (4th gen Core i3 CPU)
Affinity Photo for iPad 1.6.11.85 • Affinity Designer for iPad 1.6.4.45 • iOS 12.1.1 (iPad Air 2)

Share this post


Link to post
Share on other sites
14 hours ago, iambia said:

When I reinstalled it, the fonts I had previously installed are still there

Can i just ask how you are confirming that?  Just if Affinity is crashing at start up i suspect you wouldn't be able to get to Preferences to check the font tab.

14 hours ago, iambia said:

I thought it should remove everything and clean install the Affinity Photo app

I would of expected the same as well, i'll need to get that logged with the Dev Team, if it isn't already.

One thing i did notice, if you can get into Preferences and then onto the Fonts tab, make sure to swipe the font name to the left and tap on Delete.  If you select the font and tap the trash icon, this doesn't always seem to delete the font and it could come back next time you start Affinity.  This issue is already logged with the Dev Team.

Share this post


Link to post
Share on other sites
5 hours ago, stokerg said:

Can i just ask how you are confirming that?  Just if Affinity is crashing at start up i suspect you wouldn't be able to get to Preferences to check the font tab.

I would of expected the same as well, i'll need to get that logged with the Dev Team, if it isn't already.

One thing i did notice, if you can get into Preferences and then onto the Fonts tab, make sure to swipe the font name to the left and tap on Delete.  If you select the font and tap the trash icon, this doesn't always seem to delete the font and it could come back next time you start Affinity.  This issue is already logged with the Dev Team.

after repeatedly trying to open it, it eventually opens. but still will crash after a while of doing things. that is how i was able to check. it is happening sporadically, but with extreme frequency. sometimes within 5 minutes it will crash. sometimes a reopen will be met with a crash and it won’t open. another reopen will allow it to open, but then crash again in 5 or 10 or 20 minutes. reopen, crash before opening. it is literally that wildly varied and sporadic. if i leave the app open and do something in another app, rather than coming back to where i left off, it reopens the app all over again and i must start over and reopen the file i was working on. other apps don’t do that . i am able to select them and they are in the state that i left them. they only change state if i actually quit them and close them out. 


----------------------------------------
i am everything. i am nothing
therefore, i can be anything

Share this post


Link to post
Share on other sites

Also, when I delete the app, restart ipad, then reinstall app, all fonts are still there. How do I clean them out without having to delete them one by one, which will take me over an hour? I thought with apps, everything is deleted when you uninstall. I've reinstalled the app about 5 times already and fonts are still there when I reinstall. How is that happening?


----------------------------------------
i am everything. i am nothing
therefore, i can be anything

Share this post


Link to post
Share on other sites
6 hours ago, stokerg said:

One thing i did notice, if you can get into Preferences and then onto the Fonts tab, make sure to swipe the font name to the left and tap on Delete.  If you select the font and tap the trash icon, this doesn't always seem to delete the font and it could come back next time you start Affinity.  This issue is already logged with the Dev Team.

I think I may have found the issue. I was doing more research online and came across something that mentioned iCloud storage. I'd forgotten about that selection. I was continually focusing my attention under the General tab under Settings. I decided to select my name, at the top for the Apple ID. Then I selected "iCloud". Under there, you have manage storage and "Apps Using iCloud". I turned off both Affinity apps (i had the issue with Photo), which were on and in green. When I uninstalled, restarted then reinstalled, the fonts were gone!!!! FINALLY!! It seems it is storing the fonts there and bringing them back when reinstalled. Odd, because all the other times I reinstalled, all other settings actually went back to default. Everything was default except for the fonts, which kept reappearing. By turning off that iCloud portion, the fonts are gone. It was also happening in Designer. I reinstalled that one as well, for the second time, and the fonts in there are now gone. I decided to test with Designer a moment ago to see if the issue was with it as well and it was. The first reinstall, the fonts remained. But upon turning off iCloud for them, the fonts are now gone. Will see if the issue with quitting persists after reinstalling some fonts and some brushes, which was the primary issue. Then I will know it is most likely certain fonts or brushes, which is what I suspect was the problem, but couldn't verify because the fonts wouldn't delete! 

[NOTE - added @ 11:08am] Additionally, now when i leave and go back into the app, the state where I left off at remains (the document is still open to where I was working) without automatically quitting the app simply because I went into another app. So something might be amiss with iCloud. 


----------------------------------------
i am everything. i am nothing
therefore, i can be anything

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×