Jump to content

Recommended Posts

Please look at the enclosed attachment enlarged screen shot. Look at the normal spaces between the words, in this case real names, and then compare to the non-breaking spaces added between the names "Trevor Horn; Boris Blank; and Tan Dun". Clearly you can see that these NBS are noticeably wider.

This problem exists within Publisher (the latest beta 238) and the previous version too. This problem was identified from viewing an exported 300dpi pdf.

Thank you.

Space bug.JPG


W10 Pro 64bit | i7 4790K 4.40GHz | 32GB RAM | 250GB SSD | 7TB Storage | nVIDIA GTX 1050 Ti 4GB | Lots and lots of creative software

https://digitaldharmamusic.wordpress.com/

https://digitaldharmamusic.bandcamp.com/

Share this post


Link to post
Share on other sites

What font are you using?
I would like to take a look and see if the non-breaking space is actually the same size as a regular space.

I guess you could check using different fonts to see if it happens with all of them.
That would point to a problem with APub.

 

Share this post


Link to post
Share on other sites

It would be good to see a screen shot of the same area in APub with Show Special Characters turned on.

Try as I might, I cannot replicate the issue. In the screen shot below, APub is at the top, the resultant PDF is on the bottom.

capture-002508.png.dac39ffdbd02a21dcddf1a63bd8f9955.png

If U+00A0 (Unicode for the non-break space) isn't present, I forget what Dave Harms mentioned what they do. It would take diligent searching as this topic was discussed.


My computer is a nothing-special Toshiba laptop with unremarkable specs running Windows 10 64-bit.

Share this post


Link to post
Share on other sites

The font is Charter BT 10 pt on 12 leading. The text frame is part of a linked sequence and the text is set Left. Everything else text-wise normal, default settings. Nothing special going on here. If you check the screen grab from within Publisher you will see the NBS as previously indicated. Please remember that all these three names are automatically text-wrapped within the frame boundaries which is why they appear at the start of each line.

However I have just reduced the right side of the frame to allow the text to re-wrap and the same wide spaces apply. (see new screen shot below).

I hope this provides some further assistance.

Thank you.

Capture.JPG

Capture 2.JPG


W10 Pro 64bit | i7 4790K 4.40GHz | 32GB RAM | 250GB SSD | 7TB Storage | nVIDIA GTX 1050 Ti 4GB | Lots and lots of creative software

https://digitaldharmamusic.wordpress.com/

https://digitaldharmamusic.bandcamp.com/

Share this post


Link to post
Share on other sites

Please check with some different fonts.
Charter BT may be the problem.

I do not have a current Charter BT to examine.
I only have the original TTF fonts and cannot find my old Bitstream CD at the moment.
So I went out into the ether to find Charter BT.
All of the different versions I found had a problem with the space vs. non-breaking space.
One font had no non-breaking space.
Two fonts had non-breaking spaces which were much larger than the regular space.
This is the issue you are seeing.

I checked some high quality FOSS fonts such as Open Sans, Fira Sans, Noto Sans & Serif.
In all of them the space and the non-breaking space are the same width.
I checked some high quality commercial fonts such as Arno Pro, Bookmania, and Myriad Pro.
In all of them the space and the non-breaking space are the same width.

So please check your text with some different fonts of good quality.

If you would like I can take a look at your font and confirm it is the issue (and maybe fix it).
Just send it to me via personal message here in the forum.

 

Share this post


Link to post
Share on other sites

Thanks to everyone who replied, it's appreciated.

Libre Training you have hit the nail on the head -- it's a font issue. Interesting any font that is "font name" BT and the spaces are wide. Other, non BT, fonts and the spacing seems perfect. I have hundreds of fonts on my system and an awful lot are of the BT variety. So basically it's a big problem.

Now the issue is whether Publisher is at fault with these fonts or not? It is hard for me to imagine that the whole BT font category is somehow flawed.

Perhaps the Devs can investigate further?

I think that about covers it for now. Thanks you again for the replies.

Finally I love what Serif are doing with the Affinity product range. Publisher is shaping up very well. Keep up the great work Serif, you are onto a big winner here.


W10 Pro 64bit | i7 4790K 4.40GHz | 32GB RAM | 250GB SSD | 7TB Storage | nVIDIA GTX 1050 Ti 4GB | Lots and lots of creative software

https://digitaldharmamusic.wordpress.com/

https://digitaldharmamusic.bandcamp.com/

Share this post


Link to post
Share on other sites

This is not an issue with the software.
The problem is the fonts.

I took a look at the only BT fonts I have on my system right now.
Cooper Black BT (1999) - this is an original TTF font and it is bad.
The real (not poor conversions) updated OTF fonts are fine.
EngraversGothic BT (2011) and Revival565 BT (2013) are real updated fonts with OpenType features and both have proper non-breaking spaces.

Bad conversions of the original TTF to OpenType only have kerning and nothing else.
All of the BT fonts I checked are bad.
Old original BT TTF fonts I un-installed from Windows XP long ago - all bad.
Hundreds of BT fonts included with WordPerfect Office X7 - all bad.
I have seen these old BT fonts bundled with other applications - assume those are also bad.

Old MT fonts from the same era - all non-breaking spaces are fine.

Why all these old BT fonts are like this, I do not know.
But the place to fix this is in the fonts, not in the software.
APub cannot guess which fonts have broken metrics and try to adjust.

There are some updated versions of some of the more popular fonts (like the two above).
For example there is an updated Charter BT with real OpenType features.
https://www.myfonts.com/fonts/bitstream/charter/ 
If you look at the tech specs page for the Roman font
https://www.myfonts.com/fonts/bitstream/charter/roman-49523/specs.html 
you will see the file size is much larger and all the OT features are listed.
And I assume like my newer BT fonts above, the non-breaking space is the correct width.

The alternative is for you to fix the fonts yourself.
Free tools like FontForge will enable you to tweak the fonts.

So in conclusion ... not an issue with APub.

 

Share this post


Link to post
Share on other sites
10 hours ago, LibreTraining said:

This is not an issue with the software.
The problem is the fonts.

InDesign doesn't seem to have this problem with BT fonts

image.png.c523b89f5ef1e5d0e239cb1f82bd4356.png


Windows 7 Pro, I5 3.3G PC 16G RAM

Share this post


Link to post
Share on other sites

This would appear to be another example of InDesign using some rules or logic to protect users from bad fonts.
These old BT fonts are everywhere so I am sure Adobe had to deal with this same issue long ago.

So APub could be helping users by incorporating a font check to make sure the non-breaking space is rendered the same width as the regular space regardless of the metrics in the font.
A sort of font sanity check. :-)

Feature Request!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×