Jump to content
TEcHNOpls

Redrawing fails, a lot

Recommended Posts

Hi,

in my file I'm able to repeatedly get a redraw fail, where after changing one object I get transparent or black parts of image and I have to zoom in-out to get it redraw properly.

Contact me so I can send you the file pls.


"I'm a lumberjack and I'm OK, I sleep all night, and I work all day..."

Amature camera user, Adobe avoider. Still missing: HLS improvements, Raw development with sidecars, Gradient list in gradient layer/tool. Do want: Liquefy as Layer.

Share this post


Link to post
Share on other sites

Once I get back home, sure!


"I'm a lumberjack and I'm OK, I sleep all night, and I work all day..."

Amature camera user, Adobe avoider. Still missing: HLS improvements, Raw development with sidecars, Gradient list in gradient layer/tool. Do want: Liquefy as Layer.

Share this post


Link to post
Share on other sites

Uploading right now. You can start by enabling the group that is disabled and try moving some objects inside. I also sent a screenshot of how it looks.

Also, pleas take a look at the other file, I marked the issue in 16bpp mode (it disappears in 8bpp).


"I'm a lumberjack and I'm OK, I sleep all night, and I work all day..."

Amature camera user, Adobe avoider. Still missing: HLS improvements, Raw development with sidecars, Gradient list in gradient layer/tool. Do want: Liquefy as Layer.

Share this post


Link to post
Share on other sites

Bear in mind, you can try other layers two. I believe something in the way these layers are set up causes all sorts of different issues when redrawing.


"I'm a lumberjack and I'm OK, I sleep all night, and I work all day..."

Amature camera user, Adobe avoider. Still missing: HLS improvements, Raw development with sidecars, Gradient list in gradient layer/tool. Do want: Liquefy as Layer.

Share this post


Link to post
Share on other sites

Hey TEcHNOpls,

I can see a pretty bad redraw issue where the render tiles go black and seem to stay like that for a little bit longer than I'd expect (a second or so as opposed to a flash). However, I cannot get them to stick in place or get the transparency you've mentioned. 

Does it happen as soon as you open the file or do you have to be working on it for a while? 

The files don't really strain my average-spec machine either. However, if I open it on my MacBook Pro i7 performance is very poor which is very unexpected to be honest. I'll give the files to the developers.

Also, the halo issue doesn't seem present on Mac but it does Windows so that's another issue to log.

---------

Update

- I've logged an issue with the halo on Windows (doesn't affect Mac as I said above)
- I've also logged the fact the file runs poorly with Metal Compute enabled on the Mac but also mentioned the severe redraw issue we can see on Windows. They might request a separate bug report for this but it could just be a more severe tile rendering issue that we've seen in other files.

Share this post


Link to post
Share on other sites

I'll send you some videos/instructions how I got this transparency issue, once I get home.
Even if pixel selection is the culprit, I don't think it should work like this.

The Halos effect is indeed a separate issue, but I think it needs to be investigated.


"I'm a lumberjack and I'm OK, I sleep all night, and I work all day..."

Amature camera user, Adobe avoider. Still missing: HLS improvements, Raw development with sidecars, Gradient list in gradient layer/tool. Do want: Liquefy as Layer.

Share this post


Link to post
Share on other sites
Just now, TEcHNOpls said:

Even if pixel selection is the culprit, I don't think it should work like this.

We've seen hidden or accidental pixel selections cause issues before. I know active selections use a lot of resources but it shouldn't be causing this behaviour. 

Share this post


Link to post
Share on other sites

1. How did you spot that selection? I can't see anything that shows there is a selection.

2. With selection I can get these transparent redraws. Enable the marked group and try rotating the elements inside, sometimes it's OK sometimes it fails

image.png.b0888b851a3c441f5c63a78d7e4614e8.png

image.png.ee8373db330566c9b6203e26a9bbed99.png

image.thumb.png.97487bf9d8d6e297a7cae0307378ff31.png


"I'm a lumberjack and I'm OK, I sleep all night, and I work all day..."

Amature camera user, Adobe avoider. Still missing: HLS improvements, Raw development with sidecars, Gradient list in gradient layer/tool. Do want: Liquefy as Layer.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×