Jump to content
You must now use your email address to sign in [click for more info] ×

No request sent out by Designer to access camera roll

Recommended Posts

Hi, I have searched through various topics but don't find anything that deals with this: I have an iPad pro running Affinity Designer with absolutely no trouble at all. Flawless function. EXCEPT when I want to access my camera roll. There is nothing there. 

I looked in iPad settings and AD has not requested permission to access photos... I've reinstalled app and everything. No change. Still no way to get the app to see my pics. :(

Please help? Thanks a million

Link to comment
Share on other sites

Hi @Annenigma

What does happen?

Sorry if you have already done the following ---

If I press the + on the Home screen to open a file, then tap Import from Photos,


I get this


If you see nothing, go to the iPad home screen and check the Settings app


and scroll down on the left until you find Designer


Is Photos set to Read and Write ?


Windows PCs. Photo and Designer, latest non-beta versions.

Link to comment
Share on other sites

Hi there thanks for the replies.

@toltec, I have done as you mentioned. I only have Siri available in the settings for designer...no photos option to set permissions :,(

@DWright , this is exactly the thing I’m looking for but doesn’t show up!? I uninstalled, reinstalled etc but AD never gives me this pop-up thingy...


Version I am runnng is and I am using an iPad Pro iOS 12.1 if that info is of any use.



Link to comment
Share on other sites

If you have tried resetting your iPad by pressing and holding both the home key and power button until you see the Apple logo, and that didn’t work,  then my next suggestion would be to reset your settings. You will lose Wi-fi passwords and wallpaper changes so make sure you know what they are but you won’t lose any data. When you go into Affinity you should now be asked if you want to grant it permission to access your photos.



My dad always told me, a bad workman always blames their tools….

Just waiting for Ronny Pickering…..

Affinity Photo, Designer, Publisher 1.10 and 2.4 on macOS Sonoma 14 on M1 Mac Mini 16GB 1TB
Affinity Photo, Designer, Publisher 1.10 and 2.4 on Windows 10 Pro. Deceased
Affinity Photo, Designer, Publisher 2.4 on M1 iPad Pro 11” on iPadOS 17.4 



The hardest link to find https://affinity.help

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.