Jump to content

Recommended Posts

This is how I see the PDF in Preview on Mac. Nothing seems to be wrong. What viewer do you use?

screenshot_0724.thumb.png.84964c234f2caf1e9b761665151355e2.png


UX/UI designer, IT analyst & consultant, Business Architect at Cool Ticket (www.coolticket.co).

MacBook Pro 13'' Early 2015, 3,1 GHz Intel Core i7, 16 GB 1867 MHz DDR3, Apple Thunderbolt Display 27'' (2560 x 1440).

Share this post


Link to post
Share on other sites

I tend to think it's some kind of Adobe Reader issue... Anyway, do you have the possibility to print this PDF and see how it comes out of the printer? Maybe it's just rendering issue. I see similar problems very often with PDFs exported from Photoshop, for example.


UX/UI designer, IT analyst & consultant, Business Architect at Cool Ticket (www.coolticket.co).

MacBook Pro 13'' Early 2015, 3,1 GHz Intel Core i7, 16 GB 1867 MHz DDR3, Apple Thunderbolt Display 27'' (2560 x 1440).

Share this post


Link to post
Share on other sites

it is intended for 2mx1.8m :D

Say if I am printing it in smaller size and the lines are not showing, is it safe to assume that it is Adobe Reader issue?

I will try to open it on another PDF reader and see how it goes

 

Thanks again

 

E.

Share this post


Link to post
Share on other sites

This is a (widly unvoidable) rendering/antialiasing problem. Normally these lines aren't visible in print.

They normally disappear, if you go to Acrobat's Preferences and deselect "Page Display/Smooth line art" and "Smooth images".

Share this post


Link to post
Share on other sites

Hi Mac_heibu,

 

Tried your suggestion, however the lines are still there.

When I open in Adobe Reader, they load it in one by one, left, middle, and then right section. you know like an animation. like 3 pieces put together side by side. I don't know how to explain it haha.

the lines appear in between the pieces.

While preview load it more as a whole page

 

Thanks

E

Share this post


Link to post
Share on other sites

Then export your PDF as PDF 1.4 or higher.

If you export as PDf/X (1.3) these "lines" are unavoidable and only can be hidden by using the Acrobat preferences I already have described. You are sre to uncheck ( not check) the options?

Share this post


Link to post
Share on other sites

Ups, didn’t see the files.

This is definitely a Affinity „issue“. I exported the file as PDF 1.7. In this case there is no need to flatten and tile the page content. However, Affinity tiles the document during rasterizing the colour gradient, if you don’t choose the correct rasterizing settings: In PDF export choose a PDF format higher 1.3, under „More …“ chosse „Rasterizing: Nothing“ and all is ok. (The word may differ, I am using the German GUI.

Share this post


Link to post
Share on other sites

Don't force the rasterization at all. Keep it vector, which you can/should be able to do with the current 1.6 beta. I am using the Windows beta, but that shouldn't matter.

 

In the release version one couldn't keep such a gradient vector because of the middle stop is not at 50%, but the beta fixes that. If you want to use the release version, just make that middle stop 50%.

 

Mike

 

 

Test2.pdf

capture-001255.png

Share this post


Link to post
Share on other sites

You are sure?

• I opened the document in AD 1.5.5.

• In „Export …“ I chose „PDF“, everything else was left default.

• Under „More“ I chose „Rasterisation: None“ and Compatibility: PDF/X-3 or whatever format.

 

The exported PDF has no tiling at all (checked in Acrobat DC) and in consequence no „lines“. The rectangle filled with a gradient, remains vector.

 

I attach the exported PDF, you may check it.

 

Nevertheless there is an issue in the exported PDF: If I export a PDF/X-3, the PDF version should be 1.3. But Acrobat tells me, that the file, exported from Affinity, is PDF 1.4, a format which may contain transparencies, and therefore isn’t compatible to PDF/X-3.

Test3.pdf

Share this post


Link to post
Share on other sites

PDF/X can leave a gradient like this as vector.

 

PDF/X-3:2003 is a revision 1.4 file and is proper. That is what your PDF is, Mac. There is no transparency in the test gradient and so no rasterization. If one adds even 1% transparency to one of the color stops of the gradient, the gradient will rasterize under the PDF/X-2 or -3 profiles. If one sets the Rasterize to Nothing like you suggest, then the transparency will be excluded and a vector result will occur in this sample.

 

Using the setting I show will keep the vector as vector when there is opacity not equal to 100.

 

The PDF/X-4 profile and just setting the compatibility to what I show should allow for transparency, but it is broken when the opacity is altered from 100.

Share this post


Link to post
Share on other sites

Mike,

 

I opened the file you attached (Test2.pdf), yes there is no line in it. Yeay.

However, since I am using 1.5.5 on Mac, I have to set the middle stop at 50% right?

I hope I don't miss understand what you meant by "middle stop 50%"

I have amended the af file and tried to export it. it still has the lines 

What I did wrong?

 

I attached all related files if you don't mind checking.

Thanks in advance

E

Test_mid.afdesign

Test_mid.pdf

PDF_Export.png

Share this post


Link to post
Share on other sites

Here's the gradient mid-point you need to change:

 

capture-001256.png.f967e3e61a246cf9580b6a9ff3359272.png

 

Then just use the following setting...

capture-001257.png.edb7a8d48b7a66e57c668c3b0d8e7172.png

 

This is the beta area. The mid-point setting should be fixed in the beta version (1.6x).

 

 

 

Share this post


Link to post
Share on other sites

Okay, more question. 

Turned out I need to combined the gradient vector with a half transparent background picture (JPEG)

If I don't rasterise, the background picture wont be transparent. But if I rasterise, the gradient background will have lines 

I have put the transparent mid point to 50% 

What should I do?

 

 

Test_more.afdesign

Test_more.pdf

Share this post


Link to post
Share on other sites

Not necessarily. The background is 72 dpi. For large format work I generally use 150 dpi until such time the design is, well, pretty massive. Just export using the same For Print setting but set the rasterization dpi to 150.

 

Technically, your design doesn't need a change to the dpi setting if all your bitmap elements are lower than whatever threshold you set. But, for instance, if you add text with a drop shadow, you would want that drop shadow to hit the PDF at 150 dpi on a design of this size.

 

Your image hits the PDF retaining its transparency without "stitching," which are what those lines are called. Even so, you will find there are times that stitching will occur no matter what one does. There are few options of dealing with stitching. These are simple things, but can be involved. Stitching in general will not appear on the print to a high-resolution device. So most desktop-type printers will often show stitching lines, but a hi-res print device will not.

 

If you run into it on a final output, we can deal with it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.