Jump to content
Sign in to follow this  
Gasman

New graphic tablet works fine with AP!

Recommended Posts

Hi guys

I`ve been looking for some time for a graphics tablet and had decided to get the Intuos pro medium but can`t seem to get hold of one in the UK, SO plan B I started looking on youtube for recommendations and came across the XP-Pen Star05 which I gather has not been out long, it has wireless, has an 8"x5" active area and so I thought I`d order one and if it didn`t work with any of my gear then the excellent Amazon returns would be used. Ordered yesterday and arrived today and have to say I`m delighted with it. Following the advice given I made sure yesterday any tablet drivers were uninstalled, my virus checker disabled and downloaded and installed the latest driver from the XP-Pen web site and waited for it to arrive. Plugged it in, instantly recognised and up and running in about 10 seconds and works perfectly with AP. It actually seems fine with all the software I have, I don`t think it has a tilt feature which I`m not bothered about but all in all I think not getting an Intuos has worked out ok for me as I now have an excellent graphics tablet for a quarter of the price of the Intuos and it works like a dream no lag at all.

 

cheers

Steve

Share this post


Link to post
Share on other sites

I did a similar thing, I bought a Huion tablet (made in China), it has a 9.5x5.5 inch screen, and it works like a dream with all my graphics/photo software, and at around £50 is a real bargain!


http://www.bluebottleexchange.com

 

The above site was created in Serif WebPlus X7 and X8, and is in continuous development.

Share this post


Link to post
Share on other sites

I bought the Huion New 1060 Plus tablet. (NB the driver is on a preinstalled removable drive, not on a CD as as stated in the literature). It works brilliantly on both AP and AD. It was particularly good for doing the painting type tutorials in the Designer Workbook. But I have found one defect, which seems to apply to all text inputs. For example when I try to rename a layer, hovering over the text box causes a graphics text input box to pop up, but it does not work and the new name has to be added via the keyboard. I tried the same thing on my Elements Editor and found that it does work there, so it would appear that the problem lies with the AP software, not the Huion driver. It is not a big issue, but it would be good to fix it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

Please note the Annual Company Closure section in the Terms of Use. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.