Jump to content
Sign in to follow this  
Tim Gummer

Can't Select all to Transform

Recommended Posts

This one is driving me crazy, particularly as AD's freehand-like selection savvyness is one of the things i really love about the app.

 

I have this world map with african countries on one layer, the rest on another (and a third layer for text).

 

 

I want to scale the whole world up, so africa fills more of the artboard, but I can't select-all, 'move' is effectively  stuck as 'pan'.

 

Is this a bug or what stupd thing am i missing.

 

A bit urgent this one! I really don't want to resort to using ai to do something so basic.

 

thanks

video elements 1.afdesign


one planet, one chance

Share this post


Link to post
Share on other sites

Turn on "Edit all layers" - button at the bottom of the Layers panel.  Then you can select everything and scale.


SerifLabs team - Affinity Developer
  • Software engineer  -  Photographer  -  Guitarist  -  Philosopher
  • iMac 27" Retina 5K (Late 2015), 4.0GHz i7, AMD Radeon R9 M395
  • MacBook (Early 2015), 1.3GHz Core M, Intel HD 5300
  • iPad Pro 10.5", 256GB

Share this post


Link to post
Share on other sites

My "move" and "pan" tools are getting stuck as well - already reported.

Zoom in and out again seems to bring it to its senses but it's becoming a real pain.

 

No reason why it shouldn't all scale - there's a "scale with object" check box in the "Stroke" panel you need to select.

At present text will scale (I think the bug was fixed)  

As a FH user myself I find the selection methods really frustrating. In FH I got to the point  where I never used the tool box - all achieved with keystrokes.

I'm finding the endless trips to the toolbox tiresome - and the Move/Zoom* bug maddening.

 

Great potential though - I'm sure it'll get there.

Share this post


Link to post
Share on other sites

Ok - so this is actually a bug not a usage question?


SerifLabs team - Affinity Developer
  • Software engineer  -  Photographer  -  Guitarist  -  Philosopher
  • iMac 27" Retina 5K (Late 2015), 4.0GHz i7, AMD Radeon R9 M395
  • MacBook (Early 2015), 1.3GHz Core M, Intel HD 5300
  • iPad Pro 10.5", 256GB

Share this post


Link to post
Share on other sites

I think it's bug - hard to tell.  Thanks for the "Edit All Layers" - didn't realize that was a thing. But doesn't seemed to have helped.  

 

And I've unlocked all sub layers.

 

But the problem seems to be intermittant, i just cant' work out what is making the difference. SO sigh… have had to go back to ai to get the job done (also fore the multiple artboards and pasteboard) - which I HATE.

 

Gonna keep at this though.


one planet, one chance

Share this post


Link to post
Share on other sites

I've just had this happen myself.  It's very hard to recreate the problem every time, but we know about it and someone will try fix it.


SerifLabs team - Affinity Developer
  • Software engineer  -  Photographer  -  Guitarist  -  Philosopher
  • iMac 27" Retina 5K (Late 2015), 4.0GHz i7, AMD Radeon R9 M395
  • MacBook (Early 2015), 1.3GHz Core M, Intel HD 5300
  • iPad Pro 10.5", 256GB

Share this post


Link to post
Share on other sites

Hi - pester pester - this is SO constant I can't believe it hasn't been patched within a week, let alone three weeks.  Driving me bonkers  - I SOOO want to use this app but almost anything I do triggers this issue and I have to reopen the file not once, but at least twice to be able to use it again.  

 

Here in the trenches, we could use a little hope! 


one planet, one chance

Share this post


Link to post
Share on other sites

Hi Tim,

 

I don't want you to lose hope, so I thought I'd post a reply to you! :) There will definitely be a beta really soon - I wanted to get the Corner Tool in and working properly before updating the beta, so this has been the delay, I'm afraid - basically all my fault... We could release an update at any point, but I am very close to finishing it and I'd really like it in there because it changes a lot of things behind the scenes and I want it to go to beta so it gets lots of testing so we could update the Mac App Store version as early as possible... I haven't spoken to Ben about his findings, so I don't know if he has been able to reproduce and fix the issue, either - I'll check with him when he gets in... :)

 

Maybe I'm guilty of wanting to get too much in each new beta - I just don't want people to get it and go 'where is this feature? I've been waiting for it for months!?!' so I'm trying to make it do too much each time? I can only apologise - it's not because things aren't getting done - I'm just maybe trying to do too much each time? :S I'm hopefully going to be done with the Corner Tool this week so fingers-crossed there'll be an update very soon - and if I'm not, then maybe we should just update the beta anyway? :)

 

To give you some idea of the scale of the changes, it took Adobe a team of 6 developers working for 6 months and they also had to call in 2 of their 'top guys' to help with the maths behind the problem in order to reach their current solution... (they obviously got stuck on exactly the same thing we've just been stuck on!)... I intend for ours to be better... and we've had 2 people (including myself) looking at it on and off for a few weeks - and we're nearly done now, hehe :) If we'd gone for a simpler implementation like the one in Sketch it would've literally taken a couple of days - but it's ultimately not as useful, so... if you're going to do something, do it properly! :)

 

Thanks,

Matt

Share this post


Link to post
Share on other sites

Thanks for the update Matt - much appreciated.  I understand the desire to roll out a substantive feature upgrade - and when I use AD I get  (something of) a clear sense of how much extra work must have gone in to make AD's implementations so demonstrably better than any other app I've used (frequently including FH, which is saying something). 

 

I guess I'd want (from the sidelines) to suggest that rolling out bugfix dot-dot-dot update might be worth the bother of the  forking required, for an issue as pervasive as this one.  But whatev's - looking forward to it when it comes.  (that would be the next beta? not the release?)


one planet, one chance

Share this post


Link to post
Share on other sites

Hi Tim,

 

We've just updated the beta build now - give it a go and let me know if your problem still exists. I've not been able to provoke the bug you describe, but it may just be that I'm using it differently to you.

 

Thanks,

Matt

Share this post


Link to post
Share on other sites

wow - sorry - must have missed the memo

 

First impressions with the beta are that it fixes the problem - ie specific unselectable element are now selectable and transformable when opened in the beta.

 

SO so far… thanks!


one planet, one chance

Share this post


Link to post
Share on other sites

*sigh* oh dear - well, I really thought the 1.0.21458 beta would have sorted it out - if you can manage to put any clues together then I'll definitely look into it further. Thanks, Tim :)

 

Matt

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.