Jump to content
You must now use your email address to sign in [click for more info] ×

Batchjob - ok button not activating

Recommended Posts

I've been waiting to buy just for this one feature...
I created a macro to auto adjust white balance, color, contrast and levels.  Saved it to the library.  Opened the New Batch job.  In the panel, I selected all the images (64 of them) into the left panel.  It was populated and showed the image thumbs and file names.  I left the save to location as original so the new files would overwrite the old ones. Changed the save as file type to jpg and made sure the sizing was empty and the A box check-marked so that the size would not change.  Selected and added my macro from the list to the box on the left.  At no time during that process or at the end, did the OK button light up and become active.


I watched the video and the OK button was lit up the whole time.  What am I missing in the process?  I did reboot after installing the software.  I've also tested the macro and it does work.  Just the Batch - which was the major reason for the purpose at this point that isn't working.


I'm running a year old MacBookPro with a Core i7 and Sierra loaded.




Link to comment
Share on other sites

  • Staff

Hi Chimper,


Welcome to the forums.


I can't seem to reproduce the issue, the OK button remains active going through the same process. To cover all bases can you export your macro and send it to me here via this forum or PM/Dropbox link just so I can test it on my system. You can try resetting the app by holding down the CTRL key while opening. When prompted make sure Reset Macro Library is NOT checked and then click Clear. If it is checked your macros will be lost and I don't want that to happen  :(

Link to comment
Share on other sites

  • 2 weeks later...

I'm having the same issue, except minus the bit about macros.  The OK button remains inactive, all the others are fine and respond as they should.  I've tried quitting and reopening but to no effect.


I was trying to change Canon RAW files into jpgs, they appear quite happily in the source panel, but that's as far as it goes

Link to comment
Share on other sites

  • 4 years later...


The topic seems to be old, but I'm having the same problem. :( OK button is inactive in my Batch dialogue.

Tried authorizing location.

Tried resetting the app.

Does anyone have this problem now? How can I fix it?

Screen Shot 2021-04-18 at 19.01.40.png

Edited by Anastasia
Added screenshot
Link to comment
Share on other sites

1 hour ago, Anastasia said:

OK button is inactive in my Batch dialogue.

From your screenshot, it looks like you have not added any sources.

All 3 1.10.8, & all 3 V23.0 Mac apps; 2020 iMac 27"; 3.8GHz i7, Radeon Pro 5700, 32GB RAM; macOS 10.15.7
Affinity Photo 
1.10.8; Affinity Designer 1.108; & all 3 V2 apps for iPad; 6th Generation iPad 32 GB; Apple Pencil; iPadOS 15.7

Link to comment
Share on other sites

  • 5 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.