Jump to content

What Photoshop Plugins will work with Affinity Photo Beta


Recommended Posts

I am developer of Reactor Player plugin http://www.mediachance.com/reactorplayer/index.html

and it seems as if Affinity photo sends empty alpha channel to the plugin if nothing is selected. The plugin works fine everywhere else in Photoshop, Corel etc as it should - when nothing is selected then the plugin receives only 3 channels..., but in Affinity Photo if no selection is made, I am still receiving empty alpha channel (that is fully transparent).

If selection is made then I receive the correct 4 channels with opaque pixels. I will patch this on my side, but I am curious why it is this way?

Link to post
Share on other sites
  • 2 weeks later...

I'm confused .. I've been using NIK Plug-Ins on 16-bit images in CS6 for a long time now. I have read so many places that it is important to stay in 16-bit if you're doing any kind of serious editing of images. Here with Affinity I am told to just convert to 8-bit and it all works. I'm not making JPEGS for Facebook ... I'm making prints. This is a major stumbling block for me. I am seriously committed to converting to Affinity when this issue is cleared up, but for now I am back to CS6 for my workflow because it works.

Link to post
Share on other sites

I'm confused .. I've been using NIK Plug-Ins on 16-bit images in CS6 for a long time now. I have read so many places that it is important to stay in 16-bit if you're doing any kind of serious editing of images. Here with Affinity I am told to just convert to 8-bit and it all works. I'm not making JPEGS for Facebook ... I'm making prints. This is a major stumbling block for me. I am seriously committed to converting to Affinity when this issue is cleared up, but for now I am back to CS6 for my workflow because it works.

 

Where do you see to 'convert to 8 bit' ?? I never touched 8bit mode in Affinity since the very first Windows beta.

Link to post
Share on other sites

You are correct .. I was wrong. My apologies. I was told that I had to convert to sRGB to get NIK to work and I think of it as 8-bit color. My mistake. I just don't work in sRGB. Thanks for pointing out my error.

Link to post
Share on other sites

Filter Forge 7 works fine with Affinity Photo.

When installing Filter Forge, Filter Forge's installation program is recognizing Affinity Photo (tested on Win 64bit version).

 

If Filter Forge is already installed before (e.g. Photoshop), you can:

 

copy the files

- Filter Forge 7 x64.8bf

- Filter Forge.config

from C:\Program Files\Adobe\Adobe Photoshop CS6 (64 Bit)\Plug-ins\Filters\Filter Forge 7 to C:\ProgramData\Affinity\Photo\1.0\Plugins\Filter Forge 7 (create a new folder)

 

Activate Filter Forge in Affinity Photo -> Plugins (allow unknown plug-ins)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Please note there is currently a delay in replying to some post. See pinned thread in the Questions forum. These are the Terms of Use you will be asked to agree to if you join the forum. | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.