Jump to content
You must now use your email address to sign in [click for more info] ×

Affinity Designer 2 vector brushes are missing after upgrading to version 2.3


origami

Recommended Posts

It is possible you'll have to Reset the brushes, which will remove any brushes (Vector or Raster) you've added or modified from all of your Affinity applications and restore all brushes to the original factory state. You'll then have to reinstall any that didn't come with the applications or from the Affinity Store.

There's a FAQ that will help you locate the internal files (raster_brushes.propcol and vector_brushes.propcol) that hold your brushes and it would be good to keep a copy of those two files before you do the Reset. But after the reset you'll need to use any .abr or .afbrush files you have to recover the brushes you've personally installed.

To do the Reset you'll need to fully quit all your Affinity V2 applications. Then you can start Designer while pressing Ctrl. Release Ctrl when you get the Clear User Data dialog. In that dialog, uncheck Reset Studio and check Reset Brushes. Then press Clear.

 

 

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.3, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.3

Link to comment
Share on other sites

  • Staff
9 hours ago, evtonic3 said:

My raster brushes disappeared on ipad

9 hours ago, evtonic3 said:

How can a new install not include the default brushes?

This does unfortunately sound like your local brushes file has corrupted if the default brushes are not available, on iPad it can be reset to default by doing the following:

  1. Close all Affinity apps
  2. Open Photo/designer 2 and quickly double tap on the screen during loading
  3. A 'Clear user data' menu will prompt, tick 'Reset Brushes' and then press 'Reset'

The brushes should now have been restored to default and you can re-import/download brush packs from your Account

Link to comment
Share on other sites

9 hours ago, evtonic3 said:

How can a new install not include the default brushes?
 

Was this your first install of V2 on your iPad, or had you previously had 2.2.1 and just updated to 2.3?

There were reports previously of the brushes disappearing on the first install, but I don't recall if it was happening on updates. And I don't know if a bug was ever logged.

-- Walt
Designer, Photo, and Publisher V1 and V2 at latest retail and beta releases
PC:
    Desktop:  Windows 11 Pro, version 23H2, 64GB memory, AMD Ryzen 9 5900 12-Core @ 3.00 GHz, NVIDIA GeForce RTX 3090 

    Laptop:  Windows 11 Pro, version 23H2, 32GB memory, Intel Core i7-10750H @ 2.60GHz, Intel UHD Graphics Comet Lake GT2 and NVIDIA GeForce RTX 3070 Laptop GPU.
iPad:  iPad Pro M1, 12.9": iPadOS 17.3, Apple Pencil 2, Magic Keyboard 
Mac:  2023 M2 MacBook Air 15", 16GB memory, macOS Sonoma 14.3

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

Terms of Use | Privacy Policy | Guidelines | We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.